aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-06-04 02:57:20 +0800
committerpgj <pgj@FreeBSD.org>2012-06-04 02:57:20 +0800
commitb794b2537366efd7f5b215fcbbc6cba4b3ed9a34 (patch)
treeb2028c20c7607a6dae7fdcce7cabc5253705271c
parenta1b5d323b9c37ce88183e3e0b77c56f2b992cfc7 (diff)
downloadfreebsd-ports-gnome-b794b2537366efd7f5b215fcbbc6cba4b3ed9a34.tar.gz
freebsd-ports-gnome-b794b2537366efd7f5b215fcbbc6cba4b3ed9a34.tar.zst
freebsd-ports-gnome-b794b2537366efd7f5b215fcbbc6cba4b3ed9a34.zip
The Par monad(s) offer an alternative parallel programming API to that
provided by the 'parallel' package. A Par monad allows the simple description of parallel computations, and can be used to add parallelism to pure Haskell code. The basic API is straightforward: a Par monad supports forking and simple communication in terms of IVars. This module is an interface module only. It provides a number of type clasess, but not an implementation. The type classes separate different levels of Par functionality. WWW: https://github.com/simonmar/monad-par Obtained from: FreeBSD Haskell
-rw-r--r--devel/hs-abstract-par/Makefile20
-rw-r--r--devel/hs-abstract-par/distinfo2
-rw-r--r--devel/hs-abstract-par/pkg-descr10
-rw-r--r--lang/ghc/bsd.hackage.mk1
4 files changed, 33 insertions, 0 deletions
diff --git a/devel/hs-abstract-par/Makefile b/devel/hs-abstract-par/Makefile
new file mode 100644
index 000000000000..dd535636349c
--- /dev/null
+++ b/devel/hs-abstract-par/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: hs-abstract-par
+# Date created: May 9, 2012
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= abstract-par
+PORTVERSION= 0.3.1
+CATEGORIES= devel haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Type classes generalizing the functionality of the 'monad-par' library
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/devel/hs-abstract-par/distinfo b/devel/hs-abstract-par/distinfo
new file mode 100644
index 000000000000..3212e63a7c57
--- /dev/null
+++ b/devel/hs-abstract-par/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/abstract-par-0.3.1.tar.gz) = d3ab9ea69100d90668b22cac9a2533d524e8d5bf362792333c600d818028fb63
+SIZE (cabal/abstract-par-0.3.1.tar.gz) = 4792
diff --git a/devel/hs-abstract-par/pkg-descr b/devel/hs-abstract-par/pkg-descr
new file mode 100644
index 000000000000..b1685653b46c
--- /dev/null
+++ b/devel/hs-abstract-par/pkg-descr
@@ -0,0 +1,10 @@
+The Par monad(s) offer an alternative parallel programming API to that
+provided by the 'parallel' package. A Par monad allows the simple
+description of parallel computations, and can be used to add parallelism
+to pure Haskell code. The basic API is straightforward: a Par monad
+supports forking and simple communication in terms of IVars. This module
+is an interface module only. It provides a number of type clasess, but
+not an implementation. The type classes separate different levels of Par
+functionality.
+
+WWW: https://github.com/simonmar/monad-par
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index e37a87c6260d..285f3b1155d8 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -12,6 +12,7 @@
# KEEP THE LIST ALPHABETICALLY SORTED!
abstract-deque_port= devel/hs-abstract-deque
+abstract-par_port= devel/hs-abstract-par
aeson_port= converters/hs-aeson
Agda_port= math/hs-Agda # executable
Agda-executable_port= math/hs-Agda-executable # executable