aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2016-01-20 18:30:04 +0800
committerolgeni <olgeni@FreeBSD.org>2016-01-20 18:30:04 +0800
commitb7bc8933647766a7fd8fc5fb36977717f0391cbd (patch)
tree22dccb5497f628d79cf4ecc672fbc1df976e9a08
parent48238c30be5aadb2679d29f6f1eaf74571f50b92 (diff)
downloadfreebsd-ports-gnome-b7bc8933647766a7fd8fc5fb36977717f0391cbd.tar.gz
freebsd-ports-gnome-b7bc8933647766a7fd8fc5fb36977717f0391cbd.tar.zst
freebsd-ports-gnome-b7bc8933647766a7fd8fc5fb36977717f0391cbd.zip
Improve the DTrace build for Erlang 18.
With a couple of changes it seems to work just fine when building as a user, and also inside poudriere jails. If you want to build in poudriere, you must: - Have dtraceall.ko loaded. - Have a kernel inside the jail (i.e. create the poudriere jail with -K).
-rw-r--r--lang/erlang-runtime18/Makefile6
-rw-r--r--lang/erlang/Makefile6
2 files changed, 4 insertions, 8 deletions
diff --git a/lang/erlang-runtime18/Makefile b/lang/erlang-runtime18/Makefile
index 67d5b7a41cf2..ce7b3b6d3096 100644
--- a/lang/erlang-runtime18/Makefile
+++ b/lang/erlang-runtime18/Makefile
@@ -59,10 +59,6 @@ LDFLAGS+= -L${LOCALBASE}/lib
DISTFILES+= ${ERLANG_DOCS}:erlangorg
.endif
-# See http://wiki.freebsd.org/DTrace to learn how to enable DTrace
-# on your system. You will need to configure STRIP, WITH_CTF and
-# CFLAGS in your make.conf before building.
-
# If you run Erlang and get a message resembling "WARNING: number of
# probes fixed does not match the number of defined probes (54 != 132,
# respectively)" you probably misconfigured DTrace in some way.
@@ -79,6 +75,8 @@ USE_GCC?= yes
.if ${PORT_OPTIONS:MDTRACE}
CONFIGURE_ARGS+=--with-dynamic-trace=dtrace
+CFLAGS+= -fno-omit-frame-pointer
+STRIP=
.else
CONFIGURE_ARGS+=--without-dynamic-trace
.endif
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index 1077608bbd63..2091018a9699 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -76,10 +76,6 @@ DOC_DISTFILES= armstrong_thesis_2003.pdf:joe \
programming_rules.pdf:erlangse
.endif
-# See http://wiki.freebsd.org/DTrace to learn how to enable DTrace
-# on your system. You will need to configure STRIP, WITH_CTF and
-# CFLAGS in your make.conf before building.
-
# If you run Erlang and get a message resembling "WARNING: number of
# probes fixed does not match the number of defined probes (54 != 132,
# respectively)" you probably misconfigured DTrace in some way.
@@ -96,6 +92,8 @@ USE_GCC?= yes
.if ${PORT_OPTIONS:MDTRACE}
CONFIGURE_ARGS+=--with-dynamic-trace=dtrace
+CFLAGS+= -fno-omit-frame-pointer
+STRIP=
.else
CONFIGURE_ARGS+=--without-dynamic-trace
.endif