aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-07-15 15:54:56 +0800
committerclsung <clsung@FreeBSD.org>2006-07-15 15:54:56 +0800
commitb7da2191de1ccbcee2e7ed990ec6e2c03c737205 (patch)
tree2cc6456dc2987043cb9f1576dee69496d50bbf4d
parent1bb51a3b75107e51d9bbe646275b541e51d2b36c (diff)
downloadfreebsd-ports-gnome-b7da2191de1ccbcee2e7ed990ec6e2c03c737205.tar.gz
freebsd-ports-gnome-b7da2191de1ccbcee2e7ed990ec6e2c03c737205.tar.zst
freebsd-ports-gnome-b7da2191de1ccbcee2e7ed990ec6e2c03c737205.zip
Add p5-XML-Mini 1.2.8, perl implementation of the XML::Mini XML
create/parse interface. PR: ports/100265 Submitted by: Vivek Khera <vivek at khera.org>
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-XML-Mini/Makefile28
-rw-r--r--textproc/p5-XML-Mini/distinfo3
-rw-r--r--textproc/p5-XML-Mini/pkg-descr6
-rw-r--r--textproc/p5-XML-Mini/pkg-plist16
5 files changed, 54 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 49f4d94fc095..cd95d6c28aea 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -580,6 +580,7 @@
SUBDIR += p5-XML-LibXML-XPathContext
SUBDIR += p5-XML-LibXSLT
SUBDIR += p5-XML-Liberal
+ SUBDIR += p5-XML-Mini
SUBDIR += p5-XML-NamespaceSupport
SUBDIR += p5-XML-Node
SUBDIR += p5-XML-NodeFilter
diff --git a/textproc/p5-XML-Mini/Makefile b/textproc/p5-XML-Mini/Makefile
new file mode 100644
index 000000000000..a9d56509279d
--- /dev/null
+++ b/textproc/p5-XML-Mini/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: textproc/p5-XML-Mini
+# Date created: 12-JUL-2006
+# Whom: Vivek Khera <vivek@khera.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Mini
+PORTVERSION= 1.2.8
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vivek@khera.org
+COMMENT= Perl implementation of the XML::Mini XML create/parse interface
+
+PERL_CONFIGURE= yes
+
+RUN_DEPENDS+= p5-Text-Balanced>=0.0:${PORTSDIR}/textproc/p5-Text-Balanced
+
+MAN3= XML::Mini.3 XML::Mini::Document.3 XML::Mini::Element.3 \
+ XML::Mini::Element::CData.3 XML::Mini::Element::Comment.3 \
+ XML::Mini::Element::DocType.3 XML::Mini::Element::Entity.3 \
+ XML::Mini::Element::Header.3 XML::Mini::Node.3 \
+ XML::Mini::TreeComponent.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-Mini/distinfo b/textproc/p5-XML-Mini/distinfo
new file mode 100644
index 000000000000..3038364fe746
--- /dev/null
+++ b/textproc/p5-XML-Mini/distinfo
@@ -0,0 +1,3 @@
+MD5 (XML-Mini-1.2.8.tar.gz) = ca3a9dffd09f6675c4ed5fd9318ec8fa
+SHA256 (XML-Mini-1.2.8.tar.gz) = 9e66e218796c503da2fe47b0670581880121427860faa58a7d2c704ad02ccf51
+SIZE (XML-Mini-1.2.8.tar.gz) = 35349
diff --git a/textproc/p5-XML-Mini/pkg-descr b/textproc/p5-XML-Mini/pkg-descr
new file mode 100644
index 000000000000..3bd4a70f8e23
--- /dev/null
+++ b/textproc/p5-XML-Mini/pkg-descr
@@ -0,0 +1,6 @@
+XML::Mini is a set of Perl classes that allow you to access XML data and
+create valid XML output with a tree-based hierarchy of elements.
+
+XML::Mini does not require any external libraries or modules and is pure Perl.
+If available, XML::Mini will use the Text::Balanced module in order to escape
+limitations of the regex-only approach (eg "cross-nested" tag parsing).
diff --git a/textproc/p5-XML-Mini/pkg-plist b/textproc/p5-XML-Mini/pkg-plist
new file mode 100644
index 000000000000..3ff8c9598e80
--- /dev/null
+++ b/textproc/p5-XML-Mini/pkg-plist
@@ -0,0 +1,16 @@
+%%SITE_PERL%%/XML/Mini.pm
+%%SITE_PERL%%/XML/Mini/Document.pm
+%%SITE_PERL%%/XML/Mini/Element.pm
+%%SITE_PERL%%/XML/Mini/Element/CData.pm
+%%SITE_PERL%%/XML/Mini/Element/Comment.pm
+%%SITE_PERL%%/XML/Mini/Element/DocType.pm
+%%SITE_PERL%%/XML/Mini/Element/Entity.pm
+%%SITE_PERL%%/XML/Mini/Element/Header.pm
+%%SITE_PERL%%/XML/Mini/Node.pm
+%%SITE_PERL%%/XML/Mini/TreeComponent.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Mini/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Mini
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML
+@dirrm %%SITE_PERL%%/XML/Mini/Element
+@dirrm %%SITE_PERL%%/XML/Mini
+@dirrmtry %%SITE_PERL%%/XML