aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2013-01-18 21:48:30 +0800
committerkuriyama <kuriyama@FreeBSD.org>2013-01-18 21:48:30 +0800
commitb845645f8d4de7cda0a147f105e4d166730fdffa (patch)
tree93cf80f014523e8867069a4318f01cba0d955fc7
parent413b1f59532d7800a5acd70f4f5307e5bd1fccd0 (diff)
downloadfreebsd-ports-gnome-b845645f8d4de7cda0a147f105e4d166730fdffa.tar.gz
freebsd-ports-gnome-b845645f8d4de7cda0a147f105e4d166730fdffa.tar.zst
freebsd-ports-gnome-b845645f8d4de7cda0a147f105e4d166730fdffa.zip
This class is a factory for text pipes. A pipe has a filter() method
through which input can pass. The input can be a string or a reference to an array of strings. Pipes can be stacked together using Text::Pipe::Stackable. WWW: http://search.cpan.org/dist/Text-Pipe/
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Text-Pipe/Makefile58
-rw-r--r--textproc/p5-Text-Pipe/distinfo2
-rw-r--r--textproc/p5-Text-Pipe/pkg-descr6
-rw-r--r--textproc/p5-Text-Pipe/pkg-plist40
5 files changed, 107 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 7fbf99e73b2f..4f307f78b13e 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -826,6 +826,7 @@
SUBDIR += p5-Text-ParagraphDiff
SUBDIR += p5-Text-ParseWords
SUBDIR += p5-Text-Patch
+ SUBDIR += p5-Text-Pipe
SUBDIR += p5-Text-Prefix-XS
SUBDIR += p5-Text-QRCode
SUBDIR += p5-Text-Query
diff --git a/textproc/p5-Text-Pipe/Makefile b/textproc/p5-Text-Pipe/Makefile
new file mode 100644
index 000000000000..12908cbf149b
--- /dev/null
+++ b/textproc/p5-Text-Pipe/Makefile
@@ -0,0 +1,58 @@
+# $FreeBSD$
+
+PORTNAME= Text-Pipe
+PORTVERSION= 0.10
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for common text filter API
+
+RUN_DEPENDS= \
+ p5-Class-Accessor-Complex>0:${PORTSDIR}/devel/p5-Class-Accessor-Complex \
+ p5-Class-Accessor-Constructor>0:${PORTSDIR}/devel/p5-Class-Accessor-Constructor \
+ p5-Sub-Name>0:${PORTSDIR}/devel/p5-Sub-Name \
+ p5-UNIVERSAL-require>0:${PORTSDIR}/devel/p5-UNIVERSAL-require
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+# Hack to avoid invoking CPAN.pm downloading...
+CONFIGURE_ENV= PERL5_CPANPLUS_IS_RUNNING=1
+
+MAN3= Text::Pipe.3 \
+ Text::Pipe::Append.3 \
+ Text::Pipe::Base.3 \
+ Text::Pipe::Chomp.3 \
+ Text::Pipe::Chop.3 \
+ Text::Pipe::Code.3 \
+ Text::Pipe::List::First.3 \
+ Text::Pipe::List::Grep.3 \
+ Text::Pipe::List::Map.3 \
+ Text::Pipe::List::Max.3 \
+ Text::Pipe::List::MaxStr.3 \
+ Text::Pipe::List::Min.3 \
+ Text::Pipe::List::MinStr.3 \
+ Text::Pipe::List::Pop.3 \
+ Text::Pipe::List::Reduce.3 \
+ Text::Pipe::List::Shift.3 \
+ Text::Pipe::List::Shuffle.3 \
+ Text::Pipe::List::Size.3 \
+ Text::Pipe::List::Sort.3 \
+ Text::Pipe::List::Sum.3 \
+ Text::Pipe::Lowercase.3 \
+ Text::Pipe::LowercaseFirst.3 \
+ Text::Pipe::Multiplex.3 \
+ Text::Pipe::Prepend.3 \
+ Text::Pipe::Print.3 \
+ Text::Pipe::Repeat.3 \
+ Text::Pipe::Reverse.3 \
+ Text::Pipe::Say.3 \
+ Text::Pipe::Split.3 \
+ Text::Pipe::Stackable.3 \
+ Text::Pipe::Tester.3 \
+ Text::Pipe::Trim.3 \
+ Text::Pipe::Uppercase.3 \
+ Text::Pipe::UppercaseFirst.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Text-Pipe/distinfo b/textproc/p5-Text-Pipe/distinfo
new file mode 100644
index 000000000000..535318cc37fa
--- /dev/null
+++ b/textproc/p5-Text-Pipe/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Text-Pipe-0.10.tar.gz) = e1bdeb748c3f8fbda81b769c5632224ef325012dd3a919f506a7d7ff3b2c0d26
+SIZE (Text-Pipe-0.10.tar.gz) = 43680
diff --git a/textproc/p5-Text-Pipe/pkg-descr b/textproc/p5-Text-Pipe/pkg-descr
new file mode 100644
index 000000000000..0b1cd028ae72
--- /dev/null
+++ b/textproc/p5-Text-Pipe/pkg-descr
@@ -0,0 +1,6 @@
+This class is a factory for text pipes. A pipe has a filter() method
+through which input can pass. The input can be a string or a
+reference to an array of strings. Pipes can be stacked together using
+Text::Pipe::Stackable.
+
+WWW: http://search.cpan.org/dist/Text-Pipe/
diff --git a/textproc/p5-Text-Pipe/pkg-plist b/textproc/p5-Text-Pipe/pkg-plist
new file mode 100644
index 000000000000..ebaaa27f6181
--- /dev/null
+++ b/textproc/p5-Text-Pipe/pkg-plist
@@ -0,0 +1,40 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Pipe/.packlist
+%%SITE_PERL%%/Text/Pipe.pm
+%%SITE_PERL%%/Text/Pipe/Append.pm
+%%SITE_PERL%%/Text/Pipe/Base.pm
+%%SITE_PERL%%/Text/Pipe/Chomp.pm
+%%SITE_PERL%%/Text/Pipe/Chop.pm
+%%SITE_PERL%%/Text/Pipe/Code.pm
+%%SITE_PERL%%/Text/Pipe/List/First.pm
+%%SITE_PERL%%/Text/Pipe/List/Grep.pm
+%%SITE_PERL%%/Text/Pipe/List/Map.pm
+%%SITE_PERL%%/Text/Pipe/List/Max.pm
+%%SITE_PERL%%/Text/Pipe/List/MaxStr.pm
+%%SITE_PERL%%/Text/Pipe/List/Min.pm
+%%SITE_PERL%%/Text/Pipe/List/MinStr.pm
+%%SITE_PERL%%/Text/Pipe/List/Pop.pm
+%%SITE_PERL%%/Text/Pipe/List/Reduce.pm
+%%SITE_PERL%%/Text/Pipe/List/Shift.pm
+%%SITE_PERL%%/Text/Pipe/List/Shuffle.pm
+%%SITE_PERL%%/Text/Pipe/List/Size.pm
+%%SITE_PERL%%/Text/Pipe/List/Sort.pm
+%%SITE_PERL%%/Text/Pipe/List/Sum.pm
+%%SITE_PERL%%/Text/Pipe/Lowercase.pm
+%%SITE_PERL%%/Text/Pipe/LowercaseFirst.pm
+%%SITE_PERL%%/Text/Pipe/Multiplex.pm
+%%SITE_PERL%%/Text/Pipe/Prepend.pm
+%%SITE_PERL%%/Text/Pipe/Print.pm
+%%SITE_PERL%%/Text/Pipe/Repeat.pm
+%%SITE_PERL%%/Text/Pipe/Reverse.pm
+%%SITE_PERL%%/Text/Pipe/Say.pm
+%%SITE_PERL%%/Text/Pipe/Split.pm
+%%SITE_PERL%%/Text/Pipe/Stackable.pm
+%%SITE_PERL%%/Text/Pipe/Tester.pm
+%%SITE_PERL%%/Text/Pipe/Trim.pm
+%%SITE_PERL%%/Text/Pipe/Uppercase.pm
+%%SITE_PERL%%/Text/Pipe/UppercaseFirst.pm
+@dirrm %%SITE_PERL%%/Text/Pipe/List
+@dirrm %%SITE_PERL%%/Text/Pipe
+@dirrmtry %%SITE_PERL%%/Text
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Pipe
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text