aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrobak <robak@FreeBSD.org>2015-09-09 19:00:46 +0800
committerrobak <robak@FreeBSD.org>2015-09-09 19:00:46 +0800
commitb94b51215eb8492b895f0cabbbe4e4d6522ceb9d (patch)
tree91c4a12026b9cbc4b0d057fb8d3c3459fd79da7a
parent49a2dc84ffe94129fb031dd84b366e6eae2595e1 (diff)
downloadfreebsd-ports-gnome-b94b51215eb8492b895f0cabbbe4e4d6522ceb9d.tar.gz
freebsd-ports-gnome-b94b51215eb8492b895f0cabbbe4e4d6522ceb9d.tar.zst
freebsd-ports-gnome-b94b51215eb8492b895f0cabbbe4e4d6522ceb9d.zip
devel/gitlist: NEW PORT - Web based Git repository browser written in PHP
GitList is a web based git repository browser written in PHP similar to GitHub WWW: http://gitlist.org PR: 198063 Submitted by: Andre Rikkert de Koe <andre@ark-ict.nl>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/gitlist/Makefile48
-rw-r--r--devel/gitlist/distinfo2
-rw-r--r--devel/gitlist/files/pkg-message.in5
-rw-r--r--devel/gitlist/pkg-descr3
5 files changed, 59 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 002a14e6bd71..469d74130e63 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -637,6 +637,7 @@
SUBDIR += git-bzr-ng
SUBDIR += git-codereview
SUBDIR += git-extras
+ SUBDIR += git-list
SUBDIR += git-lite
SUBDIR += git-merge-changelog
SUBDIR += git-modes
diff --git a/devel/gitlist/Makefile b/devel/gitlist/Makefile
new file mode 100644
index 000000000000..a68240fdabb5
--- /dev/null
+++ b/devel/gitlist/Makefile
@@ -0,0 +1,48 @@
+# Created by: Andre Rikkert de Koe - ARK-ICT <andre@ark-ict.nl>
+# $FreeBSD$
+
+PORTNAME= gitlist
+PORTVERSION= 0.5.0
+CATEGORIES= devel www
+MASTER_SITES= https://s3.amazonaws.com/gitlist/ \
+ http://freebsd.ark-ict.nl/ports/
+
+MAINTAINER= andre@ark-ict.nl
+COMMENT= Web based Git repository browser written in PHP
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= git:${PORTSDIR}/devel/git
+
+PLIST= ${WRKDIR}/plist
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+NO_BUILD= yes
+WANT_PHP_WEB= yes
+
+USERS?= ${WWWOWN}
+GROUPS?= ${WWWGRP}
+SUB_FILES= pkg-message
+
+post-patch:
+ ${MKDIR} ${WRKSRC}/cache
+ cd ${WRKSRC}; \
+ ${REINPLACE_CMD} -e 's|/usr/bin/git|/usr/local/bin/git|g' config.ini-example; \
+ ${FIND} . ! -type d | ${SORT} | ${SED} -e "s,^\.,%%WWWDIR%%," > ${PLIST};
+ ${ECHO} "@dir %%WWWDIR%%/vendor/phpmd/phpmd/setup" >> ${PLIST}
+ ${ECHO} "@dir(${WWWOWN},${WWWGRP},) %%WWWDIR%%/cache" >> ${PLIST}
+
+do-install:
+ cd ${WRKSRC}; \
+ IFS="$$(printf '\n\t')"; \
+ for src in $$( ${FIND} . ); do \
+ dst="${STAGEDIR}${WWWDIR}$${src#.}"; \
+ if ${TEST} -d "$$src"; then \
+ ${MKDIR} "$$dst"; \
+ else \
+ ${INSTALL_DATA} "$$src" "$$dst"; \
+ fi \
+ done
+
+.include <bsd.port.mk>
diff --git a/devel/gitlist/distinfo b/devel/gitlist/distinfo
new file mode 100644
index 000000000000..7786b0512f03
--- /dev/null
+++ b/devel/gitlist/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gitlist-0.5.0.tar.gz) = 5f47a42580e2ae4ef156c726c4127316c1bbe6d3f22b93299354bb2aa0458bad
+SIZE (gitlist-0.5.0.tar.gz) = 3045723
diff --git a/devel/gitlist/files/pkg-message.in b/devel/gitlist/files/pkg-message.in
new file mode 100644
index 000000000000..bbfddfbb97f9
--- /dev/null
+++ b/devel/gitlist/files/pkg-message.in
@@ -0,0 +1,5 @@
+The port will install an htdocs dir %%WWWDIR%%.
+Copy %%WWWDIR%%/config.ini-example
+to %%WWWDIR%%/config.ini and
+edit it to make it use your git repositories.
+Then configure your webserver to use the htdocs directory.
diff --git a/devel/gitlist/pkg-descr b/devel/gitlist/pkg-descr
new file mode 100644
index 000000000000..dc8ec5508570
--- /dev/null
+++ b/devel/gitlist/pkg-descr
@@ -0,0 +1,3 @@
+GitList is a web based git repository browser written in PHP similar to GitHub
+
+WWW: http://gitlist.org