aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-07-02 16:25:06 +0800
committervanilla <vanilla@FreeBSD.org>2014-07-02 16:25:06 +0800
commitb993511531abbdbce1e2f43c685c8b228a920e35 (patch)
treec272969e0946170013c7b5ee597e6a4bf99f755d
parent8fa99e7953821ae065dcec1eb4bc4fac847c1f31 (diff)
downloadfreebsd-ports-gnome-b993511531abbdbce1e2f43c685c8b228a920e35.tar.gz
freebsd-ports-gnome-b993511531abbdbce1e2f43c685c8b228a920e35.tar.zst
freebsd-ports-gnome-b993511531abbdbce1e2f43c685c8b228a920e35.zip
1: Stagify.
2: use options helper. Approved by: portmgr@ (blanket approval)
-rw-r--r--www/tinytinyhttpd/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/www/tinytinyhttpd/Makefile b/www/tinytinyhttpd/Makefile
index 36dcc6f45052..8df84b68129e 100644
--- a/www/tinytinyhttpd/Makefile
+++ b/www/tinytinyhttpd/Makefile
@@ -15,16 +15,18 @@ HAS_CONFIGURE= yes
PLIST_FILES= bin/tthttpd
SUB_FILES= example.conf
PORTDOCS= README example.conf ChangeLog
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/tthttpd ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/tthttpd ${STAGEDIR}${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKDIR}/example.conf ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/example.conf ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>