aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-03-01 01:49:15 +0800
committermarino <marino@FreeBSD.org>2015-03-01 01:49:15 +0800
commitba1a4bfc8bb30a0c826aba9aa0b6a8f8d971aed3 (patch)
tree551d2777710a6475f619619d97254ebb1d7e9c3d
parent9223a7ca6ec3d44828578713c78ed5b21b152748 (diff)
downloadfreebsd-ports-gnome-ba1a4bfc8bb30a0c826aba9aa0b6a8f8d971aed3.tar.gz
freebsd-ports-gnome-ba1a4bfc8bb30a0c826aba9aa0b6a8f8d971aed3.tar.zst
freebsd-ports-gnome-ba1a4bfc8bb30a0c826aba9aa0b6a8f8d971aed3.zip
lang/gnustep-base: Remove empty directories from stagedir
Two empty directories weren't listed in pkg-plist, causing this port not to pass poudriere QA checks. My interpretation is that these directories were never packaged, and they should not be packaged, so let's simply remove them from stagedir. This alse means we don't have to bump the port. Approved by: just fix it
-rw-r--r--lang/gnustep-base/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/lang/gnustep-base/Makefile b/lang/gnustep-base/Makefile
index fbcd9c1a183c..7194f12592d3 100644
--- a/lang/gnustep-base/Makefile
+++ b/lang/gnustep-base/Makefile
@@ -53,6 +53,7 @@ CFLAGS+= -I${LOCALBASE}/include/libxml2/libxml -DHAVE_DLADDR=1
BREAKS_IF_PEDANTIC= yes
PLIST_SUB+= LOCALBASE=${LOCALBASE}
ETCDIR= ${LOCALBASE}/etc
+STAGEHEADER= ${STAGEDIR}${PREFIX}/GNUstep/System/Library/Headers
PLIST_SUB+= BASEVERSION=${PORTVERSION:C/[.][0-9]*$//1}
@@ -74,5 +75,7 @@ post-extract:
post-install:
${INSTALL_DATA} ${FILESDIR}/gdomap_if ${STAGEDIR}${ETCDIR}
+ ${RMDIR} ${STAGEHEADER}/gnustep/base
+ ${RMDIR} ${STAGEHEADER}/GNUstepBase/unicode
.include <bsd.port.mk>