aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-02-17 23:48:59 +0800
committerpgj <pgj@FreeBSD.org>2012-02-17 23:48:59 +0800
commitba2c507bcf4afd33c100ea4f78df032a9c481741 (patch)
tree71278c347919daa60ed124e7773308fb19fc2664
parentfa7769ed5a3159ed465dad8946e7c5404849d0de (diff)
downloadfreebsd-ports-gnome-ba2c507bcf4afd33c100ea4f78df032a9c481741.tar.gz
freebsd-ports-gnome-ba2c507bcf4afd33c100ea4f78df032a9c481741.tar.zst
freebsd-ports-gnome-ba2c507bcf4afd33c100ea4f78df032a9c481741.zip
This package defines the type class MonadBaseControl, a subset of
MonadBase into which generic control operations such as catch can be lifted from IO or any other base monad. Instances are based on monad transformers in MonadTransControl, which includes all standard monad transformers in the transformers library except ContT. WWW: https://github.com/basvandijk/monad-control/ Obtained from: FreeBSD Haskell
-rw-r--r--devel/Makefile1
-rw-r--r--devel/hs-monad-control/Makefile22
-rw-r--r--devel/hs-monad-control/distinfo2
-rw-r--r--devel/hs-monad-control/pkg-descr7
-rw-r--r--lang/ghc/bsd.hackage.mk1
5 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6e4c2915ecea..64abfd0d6a28 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -644,6 +644,7 @@
SUBDIR += hs-lazysmallcheck
SUBDIR += hs-logict
SUBDIR += hs-mmap
+ SUBDIR += hs-monad-control
SUBDIR += hs-monad-par
SUBDIR += hs-mtl
SUBDIR += hs-mtl-docs
diff --git a/devel/hs-monad-control/Makefile b/devel/hs-monad-control/Makefile
new file mode 100644
index 000000000000..b4811058fb2b
--- /dev/null
+++ b/devel/hs-monad-control/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: hs-monad-control
+# Date created: September 24, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= monad-control
+PORTVERSION= 0.3.1
+CATEGORIES= devel haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Lift control operations through monad transformers
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+USE_CABAL= base-unicode-symbols>=0.1.1 transformers>=0.2 \
+ transformers-base>=0.4.1
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/devel/hs-monad-control/distinfo b/devel/hs-monad-control/distinfo
new file mode 100644
index 000000000000..73e0a7bbc303
--- /dev/null
+++ b/devel/hs-monad-control/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/monad-control-0.3.1.tar.gz) = 85dc00104fd41ec2d9e48b01edc9d8b995f40affb6f5e5736fccb520edda5851
+SIZE (cabal/monad-control-0.3.1.tar.gz) = 10269
diff --git a/devel/hs-monad-control/pkg-descr b/devel/hs-monad-control/pkg-descr
new file mode 100644
index 000000000000..4cf98c34ac7c
--- /dev/null
+++ b/devel/hs-monad-control/pkg-descr
@@ -0,0 +1,7 @@
+This package defines the type class MonadBaseControl, a subset of
+MonadBase into which generic control operations such as catch can be
+lifted from IO or any other base monad. Instances are based on monad
+transformers in MonadTransControl, which includes all standard monad
+transformers in the transformers library except ContT.
+
+WWW: https://github.com/basvandijk/monad-control/
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index bfb279749398..5cee7a9162cf 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -139,6 +139,7 @@ MemoTrie_port= devel/hs-MemoTrie
mime_port= mail/hs-mime
MissingH_port= devel/hs-MissingH
mmap_port= devel/hs-mmap
+monad-control_port= devel/hs-monad-control
monad-par_port= devel/hs-monad-par
MonadCatchIO-mtl_port= devel/hs-MonadCatchIO-mtl
MonadCatchIO-transformers_port= devel/hs-MonadCatchIO-transformers