aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2002-09-12 19:03:09 +0800
committertobez <tobez@FreeBSD.org>2002-09-12 19:03:09 +0800
commitbbc5f51fe3ec6c3521f75c5c87f60c1c5c89c5db (patch)
tree2e820604af1ea5dd27ba9d8a22ab094bab5b5b1c
parent3815bed3b4f5a2aa9da177dfdc48f3c5b8887cde (diff)
downloadfreebsd-ports-gnome-bbc5f51fe3ec6c3521f75c5c87f60c1c5c89c5db.tar.gz
freebsd-ports-gnome-bbc5f51fe3ec6c3521f75c5c87f60c1c5c89c5db.tar.zst
freebsd-ports-gnome-bbc5f51fe3ec6c3521f75c5c87f60c1c5c89c5db.zip
Add p5-Test-Inline 0.15, Test::Inline - inlining your tests next to the
code being tested. PR: 42687 Submitted by: Erwin Lansing <erwin@lansing.dk>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-Inline/Makefile28
-rw-r--r--devel/p5-Test-Inline/distinfo1
-rw-r--r--devel/p5-Test-Inline/pkg-comment1
-rw-r--r--devel/p5-Test-Inline/pkg-descr11
-rw-r--r--devel/p5-Test-Inline/pkg-plist12
6 files changed, 54 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 3238bbe4efd3..12168985f665 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -571,6 +571,7 @@
SUBDIR += p5-Term-Screen
SUBDIR += p5-Term-Size
SUBDIR += p5-Test-Harness
+ SUBDIR += p5-Test-Inline
SUBDIR += p5-Test-Simple
SUBDIR += p5-Tie-Cache
SUBDIR += p5-Tie-DB_FileLock
diff --git a/devel/p5-Test-Inline/Makefile b/devel/p5-Test-Inline/Makefile
new file mode 100644
index 000000000000..af2816c9d678
--- /dev/null
+++ b/devel/p5-Test-Inline/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Test-Inline
+# Date created: Mon Sep 12
+# Whom: Erwin Lansing <erwin@lansing.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Inline
+PORTVERSION= 0.15
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= erwin@lansing.dk
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Harness.pm:${PORTSDIR}/devel/p5-Test-Harness \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= pod2test.1
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Pod::Tests.3 Pod::Tests::Tutorial.3 Test::Inline.3 Test::Inline::Tutorial.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Inline/distinfo b/devel/p5-Test-Inline/distinfo
new file mode 100644
index 000000000000..42fd2647bc57
--- /dev/null
+++ b/devel/p5-Test-Inline/distinfo
@@ -0,0 +1 @@
+MD5 (Test-Inline-0.15.tar.gz) = 8b1128b4102578c093a01ad0b86f6616
diff --git a/devel/p5-Test-Inline/pkg-comment b/devel/p5-Test-Inline/pkg-comment
new file mode 100644
index 000000000000..c79257d59feb
--- /dev/null
+++ b/devel/p5-Test-Inline/pkg-comment
@@ -0,0 +1 @@
+Test::Inline - Inlining your tests next to the code being tested
diff --git a/devel/p5-Test-Inline/pkg-descr b/devel/p5-Test-Inline/pkg-descr
new file mode 100644
index 000000000000..8eda9ccbc4b6
--- /dev/null
+++ b/devel/p5-Test-Inline/pkg-descr
@@ -0,0 +1,11 @@
+Embedding tests allows tests to be placed near the code its testing.
+This is a nice supplement to the traditional .t files.
+It's like XUnit, Perl-style.
+
+Test::Tutorial is just documentation. To actually get anything done you
+use pod2test. Read the Test::Inline::Tutoral, really.
+
+Author: Michael G Schwern <schwern@pobox.com>
+WWW: http://search.cpan.org/search?dist=Test-Inline
+
+--Erwin Lansing <erwin@lansing.dk>
diff --git a/devel/p5-Test-Inline/pkg-plist b/devel/p5-Test-Inline/pkg-plist
new file mode 100644
index 000000000000..25e0eb2450a9
--- /dev/null
+++ b/devel/p5-Test-Inline/pkg-plist
@@ -0,0 +1,12 @@
+bin/pod2test
+lib/perl5/site_perl/%%PERL_VER%%/Test/Inline/Tutorial.pod
+lib/perl5/site_perl/%%PERL_VER%%/Test/Inline.pm
+lib/perl5/site_perl/%%PERL_VER%%/Pod/Tests.pm
+lib/perl5/site_perl/%%PERL_VER%%/Pod/Tests/Tutorial.pod
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Test/Inline/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Test/Inline
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Test 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Test/Inline
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Test 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Pod/Tests
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Pod 2>/dev/null || true