aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-06-24 14:02:21 +0800
committerbapt <bapt@FreeBSD.org>2013-06-24 14:02:21 +0800
commitbca18e741eb1faf1682dfa535033a533d66ed8e8 (patch)
treebe6f45bb5da42fa6117d21011ee1e5eb1016791b
parent4d5dd252c9fceb0d1260c6f33d59f8c661283a17 (diff)
downloadfreebsd-ports-gnome-bca18e741eb1faf1682dfa535033a533d66ed8e8.tar.gz
freebsd-ports-gnome-bca18e741eb1faf1682dfa535033a533d66ed8e8.tar.zst
freebsd-ports-gnome-bca18e741eb1faf1682dfa535033a533d66ed8e8.zip
Update to 1.1 final
Changes since 1.0.X: - new simpler and more reliable solver - shared libraries are now always tracked - ssh:// is supported as a protocol to distribute packages (needs pkg 1.1+ on the server hosting the packages) - multirepository is no longer considered experimental and works by default. - incremental update of the catalog (only if the repository was created by pkg 1.1+) - simplification of the public API - stabilisation of the public API (we will now try to keep it stable and if change are needed there will be deprecation time before removal of some old functions) - new experimental pkg convert (can convert from and to legacy pkg database) pkg2ng now uses pkg convert (still recommanded to use pkg2ng) - new pkg lock/unlock to prevent any manipulation of a given package (no upgrade,delete,etc) - improved UI (now you can see the progress of an upgrade what is left to be done) - new pkg annotation to allow one to add annotations (free form key/value) to a package) - pkg audit is now able to directly parse the vuxml native format and not only the compact version - pkg -vv now shows all available options and their current settings - pkg -vvv now shows a description of all the available options - pkg info now automatically considers the query as globbing if * is in the requested pattern - new hook plugin interface (allows users to create hooks that get called at anytime during and upgrade/installation/deletion of a package) - new cmd plugin interface (allows users to create new sub command available for pkg) - pkg register can now register a port installation in the legacy database format - repository can be defined in simple yaml files - Explain why a package is being reinstalled - A package can now be marked to only be upgraded from a given repository via annotations - install and upgrade will show from which repository packages are taken from - old/unused 'informations' field has been removed in favor of using annotations - pkg repo produce a repo.txz in pkg 1.0 (legacy) fromat Internal: - massive usage of hash tables (uthash), which simplifies a lot of the code, and improves performances - lots of optimisation in plist and manifest parsing - lots of optimisation in loading packages (mmap used when possible) - lots of cleanup in memory usage - regression test framework is now ready (using atf) regression test are slowly being added and populated.
-rw-r--r--ports-mgmt/pkg/Makefile32
-rw-r--r--ports-mgmt/pkg/distinfo4
-rw-r--r--ports-mgmt/pkg/pkg-plist2
3 files changed, 11 insertions, 27 deletions
diff --git a/ports-mgmt/pkg/Makefile b/ports-mgmt/pkg/Makefile
index 83900c1e5665..42eeea7740eb 100644
--- a/ports-mgmt/pkg/Makefile
+++ b/ports-mgmt/pkg/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= pkg
-DISTVERSION= 1.0.14
+DISTVERSION= 1.1
CATEGORIES= ports-mgmt
MASTER_SITES= LOCAL/portmgr \
http://files.etoilebsd.net/pkg/ \
@@ -30,16 +30,19 @@ USE_SUBMAKE= yes
MAN8= pkg.8 \
pkg-add.8 \
+ pkg-annotate.8 \
pkg-autoremove.8 \
pkg-audit.8 \
pkg-backup.8 \
pkg-check.8 \
pkg-clean.8 \
+ pkg-convert.8 \
pkg-create.8 \
pkg-delete.8 \
pkg-fetch.8 \
pkg-info.8 \
pkg-install.8 \
+ pkg-lock.8 \
pkg-query.8 \
pkg-register.8 \
pkg-repo.8 \
@@ -54,8 +57,11 @@ MAN8= pkg.8 \
pkg-upgrade.8 \
pkg-version.8 \
pkg-which.8
-MAN5= pkg.conf.5
+MAN5= pkg.conf.5 \
+ pkg-repository.5
+MAN3= pkg_printf.3
MLINKS= pkg-delete.8 pkg-remove.8 \
+ pkg-lock.8 pkg-unlock.8 \
pkg.8 pkg-static.8
.include <bsd.port.pre.mk>
@@ -106,34 +112,12 @@ PKG_BIN= ${WRKSRC}/pkg-static/pkg-static
.endif
.endif
-.if ${OSVERSION} < 800505
-IGNORE= not supported on 7.x or early 8.0
-.endif
-
PERIODIC_DAILY= 400.status-pkg 411.pkg-backup 490.status-pkg-changes
PERIODIC_SECURITY= 410.pkg-audit 460.pkg-checksum
PERIODIC_ALL= ${PERIODIC_DAILY} ${PERIODIC_SECURITY}
post-install:
-.for periodic in ${PERIODIC_ALL}
- @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' ${WRKSRC}/scripts/periodic/${periodic}
-.endfor
- @${MKDIR} ${PREFIX}/etc/periodic/security
- @${MKDIR} ${PREFIX}/etc/periodic/daily
-.for periodic in ${PERIODIC_DAILY}
- @${INSTALL_SCRIPT} ${WRKSRC}/scripts/periodic/${periodic} ${PREFIX}/etc/periodic/daily
-.endfor
-.for periodic in ${PERIODIC_SECURITY}
- @${INSTALL_SCRIPT} ${WRKSRC}/scripts/periodic/${periodic} ${PREFIX}/etc/periodic/security
-.endfor
- @${INSTALL_SCRIPT} ${WRKSRC}/ports/pkg2ng ${PREFIX}/sbin
- @${INSTALL_SCRIPT} ${WRKSRC}/ports/pkg2ng ${PREFIX}/sbin
@${INSTALL_DATA} ${WRKSRC}/pkg/pkg.conf.sample ${PREFIX}/etc
- @${INSTALL_DATA} ${WRKSRC}/libpkg/pkg.pc ${PREFIX}/libdata/pkgconfig/
- @${MKDIR} ${PREFIX}/share/zsh/site-functions
- @${INSTALL_DATA} ${WRKSRC}/scripts/zsh/_pkg ${PREFIX}/share/zsh/site-functions/
- @${MKDIR} ${PREFIX}/etc/bash_completion.d
- @${INSTALL_DATA} ${WRKSRC}/scripts/bash/_pkg.bash ${PREFIX}/etc/bash_completion.d/
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/ports-mgmt/pkg/distinfo b/ports-mgmt/pkg/distinfo
index ad2302ca4484..e0d233a13fb6 100644
--- a/ports-mgmt/pkg/distinfo
+++ b/ports-mgmt/pkg/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pkg-1.0.14.tar.xz) = ded2c91b0e13fb34da36868328e9b5f3700c634c1fa4962ce3910f20d66a0a53
-SIZE (pkg-1.0.14.tar.xz) = 1458472
+SHA256 (pkg-1.1.tar.xz) = c97b22061ffefc47c6697f97089d292d212d0cacda1a41bb162d051d15b80d7e
+SIZE (pkg-1.1.tar.xz) = 1554488
diff --git a/ports-mgmt/pkg/pkg-plist b/ports-mgmt/pkg/pkg-plist
index 37561e13976e..b1260d5b5c3e 100644
--- a/ports-mgmt/pkg/pkg-plist
+++ b/ports-mgmt/pkg/pkg-plist
@@ -3,7 +3,7 @@ sbin/pkg
sbin/pkg-static
sbin/pkg2ng
include/pkg.h
-lib/libpkg.so.0
+lib/libpkg.so.1
lib/libpkg.so
lib/libpkg.a
etc/periodic/daily/400.status-pkg