aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordaichi <daichi@FreeBSD.org>2003-07-30 14:16:41 +0800
committerdaichi <daichi@FreeBSD.org>2003-07-30 14:16:41 +0800
commitbccb87c6adb8f16722b87b3fe5941233ec0b6d01 (patch)
tree23e2dfb5c54e92043f5cfc92b6071783fb58b5e4
parent54b5e661dcc4ca32e4fb740f1213cf1c5d6aade2 (diff)
downloadfreebsd-ports-gnome-bccb87c6adb8f16722b87b3fe5941233ec0b6d01.tar.gz
freebsd-ports-gnome-bccb87c6adb8f16722b87b3fe5941233ec0b6d01.tar.zst
freebsd-ports-gnome-bccb87c6adb8f16722b87b3fe5941233ec0b6d01.zip
update security/isakmpd: Enable use of keynote
PR: 43892 Submitted by: Daniel C. Sobral <dcs@tcoip.com.br>
-rw-r--r--security/isakmpd/Makefile5
-rw-r--r--security/isakmpd/files/patch-ab10
2 files changed, 15 insertions, 0 deletions
diff --git a/security/isakmpd/Makefile b/security/isakmpd/Makefile
index 88cbde6de2b2..00bdcfce18b3 100644
--- a/security/isakmpd/Makefile
+++ b/security/isakmpd/Makefile
@@ -22,6 +22,11 @@ COMMENT= OpenBSD IKE daemon
BROKEN= "requires IPsec support"
.endif
+# If keynote is in use, bring the dependency
+.if defined(USE_KEYNOTE)
+BUILD_DEPENDS+= keynote:${PORTSDIR}/security/keynote
+.endif
+
USE_OPENSSL= yes
USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/isakmpd
diff --git a/security/isakmpd/files/patch-ab b/security/isakmpd/files/patch-ab
index 516941d79013..d60ab0e995c1 100644
--- a/security/isakmpd/files/patch-ab
+++ b/security/isakmpd/files/patch-ab
@@ -9,3 +9,13 @@
# The mkdir below is for installation on OpenBSD pre 2.7
install:
+--- Makefile.orig Wed Oct 9 17:15:53 2002
++++ Makefile Wed Oct 9 17:16:26 2002
+@@ -164,6 +164,7 @@
+ USE_LIBDES= yes
+ LDADD+= -lkeynote -lm
+ DPADD+= ${LIBKEYNOTE} ${LIBM}
++POLICY= policy.c
+ CFLAGS+= -DUSE_KEYNOTE
+ .endif
+