aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-07-27 23:29:02 +0800
committerdanfe <danfe@FreeBSD.org>2013-07-27 23:29:02 +0800
commitbd873c14f3adb85f8c16b0d12bd118706178dfaa (patch)
tree838dd4cf105dc49965ae0f326222efe793c9f3f1
parent9cb2219c0097a87b77b5591ba22d137b80357da6 (diff)
downloadfreebsd-ports-gnome-bd873c14f3adb85f8c16b0d12bd118706178dfaa.tar.gz
freebsd-ports-gnome-bd873c14f3adb85f8c16b0d12bd118706178dfaa.tar.zst
freebsd-ports-gnome-bd873c14f3adb85f8c16b0d12bd118706178dfaa.zip
- Employ USES for gmake and pkgconfig
- Enable verbose build commands for build farms - Fix BUILD_DEPENDS assignment (= should be +=) - Add an XXX comment about DOCS option logic - Improve on option knobs descriptions a bit - Tighten BROKEN statement, fix pkg-descr Reported by: pointyhat-west
-rw-r--r--textproc/groonga/Makefile28
-rw-r--r--textproc/groonga/pkg-descr2
2 files changed, 17 insertions, 13 deletions
diff --git a/textproc/groonga/Makefile b/textproc/groonga/Makefile
index d3f1cdaa1ed0..1b134d16908d 100644
--- a/textproc/groonga/Makefile
+++ b/textproc/groonga/Makefile
@@ -9,28 +9,32 @@ MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Open-source fulltext search engine and column store
LICENSE= LGPL21
+
+USES= gmake pkgconfig
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_GNOME= pkgconfig
-USE_GMAKE= yes
-CONFIGURE_ARGS= --with-munin-plugins
-CONFIGURE_ARGS+= --with-log-path=/var/log/groonga.log \
- --localstatedir=/var
-
-OPTIONS_DEFINE= MECAB SUGGEST
-MECAB_DESC= use mecab for morphological analysis
-SUGGEST_DESC= use suggest for suggest
+CONFIGURE_ARGS= --with-munin-plugins --localstatedir=/var \
+ --with-log-path=/var/log/groonga.log
+
+.if defined(BATCH) || defined(PACKAGE_BUILDING)
+CONFIGURE_ARGS+= --disable-silent-rules
+.endif
+
+OPTIONS_DEFINE= MECAB SUGGEST DOCS
+MECAB_DESC= Enable morphological analysis
+SUGGEST_DESC= Enable suggestions
OPTIONS_DEFAULT=MECAB SUGGEST
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= Does not compile on ia64, powerpc, or sparc64
+BROKEN= does not compile on ${ARCH}
.endif
-# We cannot enable this document option until textproc/py-sphinx be upgraded to 1.2.
+# We cannot enable this option until textproc/py-sphinx be upgraded to 1.2
+# XXX: but it is enabled now as DOCS are on by default, so what's going on?
.if ${PORT_OPTIONS:MDOCS}
-BUILD_DEPENDS= sphinx-build:${PORTSDIR}/textproc/py-sphinx
+BUILD_DEPENDS+= sphinx-build:${PORTSDIR}/textproc/py-sphinx
MAN1= groonga.1
.else
CONFIGURE_ARGS+= --disable-document
diff --git a/textproc/groonga/pkg-descr b/textproc/groonga/pkg-descr
index 17435399aed8..f038c823b44c 100644
--- a/textproc/groonga/pkg-descr
+++ b/textproc/groonga/pkg-descr
@@ -1,4 +1,4 @@
-groonga is an open-source fulltext search engine and column store.
+Groonga is an open-source fulltext search engine and column store.
It lets you write high-performance applications that requires fulltext
search.