aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2008-06-10 07:55:20 +0800
committergarga <garga@FreeBSD.org>2008-06-10 07:55:20 +0800
commitbe30c0cb88d79f360124691e4554f5e3188264ab (patch)
treef8df79f65ce88960ec8c70169ebe8b8d706bf74a
parentfa1f20a55161ba396db90c70d3c349a8d88a5e85 (diff)
downloadfreebsd-ports-gnome-be30c0cb88d79f360124691e4554f5e3188264ab.tar.gz
freebsd-ports-gnome-be30c0cb88d79f360124691e4554f5e3188264ab.tar.zst
freebsd-ports-gnome-be30c0cb88d79f360124691e4554f5e3188264ab.zip
- Forgot to remove one conditional about PTHREAD_LIB on last commit
-rw-r--r--security/clamav-devel/Makefile12
-rw-r--r--security/clamav/Makefile12
2 files changed, 8 insertions, 16 deletions
diff --git a/security/clamav-devel/Makefile b/security/clamav-devel/Makefile
index bfb38e60a431..fd7935b4156c 100644
--- a/security/clamav-devel/Makefile
+++ b/security/clamav-devel/Makefile
@@ -59,6 +59,10 @@ CPPFLAGS+= -I${LOCALBASE}/include \
LDFLAGS+= -L${LOCALBASE}/lib \
${PTHREAD_LIBS}
+# This port has a problem with -pthread,
+# force to use -lthr until it's not fixed.
+PTHREAD_LIBS= -lthr
+
MAN1= clamconf.1 \
clamscan.1 \
freshclam.1 \
@@ -103,14 +107,6 @@ PLIST_SUB+= CLAMAVUSER=${CLAMAVUSER} \
.include <bsd.port.pre.mk>
-# This port has a problem with -pthread,
-# force to use -lthr until it's not fixed.
-.if ${OSVERSION} >= 601000
-PTHREAD_LIBS= -lthr
-.else
-PTHREAD_LIBS= -lpthread
-.endif
-
.if defined(WITH_ARC)
RUN_DEPENDS+= arc:${PORTSDIR}/archivers/arc
.endif
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 0af57b9282a7..f740f14150ff 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -54,6 +54,10 @@ CPPFLAGS+= -I${LOCALBASE}/include \
LDFLAGS+= -L${LOCALBASE}/lib \
${PTHREAD_LIBS}
+# This port has a problem with -pthread,
+# force to use -lthr until it's not fixed.
+PTHREAD_LIBS= -lthr
+
MAN1= clamconf.1 \
clamscan.1 \
freshclam.1 \
@@ -98,14 +102,6 @@ PLIST_SUB+= CLAMAVUSER=${CLAMAVUSER} \
.include <bsd.port.pre.mk>
-# This port has a problem with -pthread,
-# force to use -lthr until it's not fixed.
-.if ${OSVERSION} >= 601000
-PTHREAD_LIBS= -lthr
-.else
-PTHREAD_LIBS= -lpthread
-.endif
-
.if defined(WITH_ARC)
RUN_DEPENDS+= arc:${PORTSDIR}/archivers/arc
.endif