aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorashish <ashish@FreeBSD.org>2011-07-11 05:26:42 +0800
committerashish <ashish@FreeBSD.org>2011-07-11 05:26:42 +0800
commitc15d0c164d6135c3177abfcb6a172698d302801d (patch)
tree12d20de615af194213baf76c2a5d4da97ffb0972
parentfce24fe232a2f6abaac7cce38c203ae8fe346cad (diff)
downloadfreebsd-ports-gnome-c15d0c164d6135c3177abfcb6a172698d302801d.tar.gz
freebsd-ports-gnome-c15d0c164d6135c3177abfcb6a172698d302801d.tar.zst
freebsd-ports-gnome-c15d0c164d6135c3177abfcb6a172698d302801d.zip
The module Data.CaseInsensitive provides the 'CI' type constructor which can
be parameterised by a string-like type like: 'String', 'ByteString', 'Text', etc. Comparisons of values of the resulting type will be insensitive to cases. WWW: http://hackage.haskell.org/package/case-insensitive Obtained from: FreeBSD Haskell
-rw-r--r--lang/ghc/bsd.hackage.mk1
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/hs-case-insensitive/Makefile21
-rw-r--r--textproc/hs-case-insensitive/distinfo2
-rw-r--r--textproc/hs-case-insensitive/pkg-descr6
5 files changed, 31 insertions, 0 deletions
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index ece4bcf36a62..9aad6a5cd594 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -29,6 +29,7 @@ bsd-sysctl_port= devel/hs-bsd-sysctl
c2hs_port= devel/hs-c2hs # executable
cabal-install_port= devel/hs-cabal-install # executable
cairo_port= graphics/hs-cairo
+case-insensitive_port= textproc/hs-case-insensitive
category-extras_port= math/hs-category-extras # BROKEN
cgi_port= www/hs-cgi
checkers_port= devel/hs-checkers # BROKEN
diff --git a/textproc/Makefile b/textproc/Makefile
index 19e7c905ea65..78e4ee7d4415 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -223,6 +223,7 @@
SUBDIR += hs-Diff
SUBDIR += hs-HaXml
SUBDIR += hs-bytestring-csv
+ SUBDIR += hs-case-insensitive
SUBDIR += hs-citeproc-hs
SUBDIR += hs-feed
SUBDIR += hs-highlighting-kate
diff --git a/textproc/hs-case-insensitive/Makefile b/textproc/hs-case-insensitive/Makefile
new file mode 100644
index 000000000000..b6733a7ad1ab
--- /dev/null
+++ b/textproc/hs-case-insensitive/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: hs-case-insensitive
+# Date created: May 24, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= case-insensitive
+PORTVERSION= 0.2.0.1
+CATEGORIES= textproc haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Case insensitive string comparison
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+USE_CABAL= text>=0.3
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/textproc/hs-case-insensitive/distinfo b/textproc/hs-case-insensitive/distinfo
new file mode 100644
index 000000000000..f2bb542bf12f
--- /dev/null
+++ b/textproc/hs-case-insensitive/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/case-insensitive-0.2.0.1.tar.gz) = d9ec23a2b793e95558c6aa079933c0395b08976f1059a4078ffb28b3ce9e61e5
+SIZE (cabal/case-insensitive-0.2.0.1.tar.gz) = 2982
diff --git a/textproc/hs-case-insensitive/pkg-descr b/textproc/hs-case-insensitive/pkg-descr
new file mode 100644
index 000000000000..2c357a8e0fd5
--- /dev/null
+++ b/textproc/hs-case-insensitive/pkg-descr
@@ -0,0 +1,6 @@
+The module Data.CaseInsensitive provides the 'CI' type constructor which can
+be parameterised by a string-like type like: 'String', 'ByteString', 'Text',
+etc. Comparisons of values of the resulting type will be insensitive to
+cases.
+
+WWW: http://hackage.haskell.org/package/case-insensitive