aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2017-12-07 01:30:06 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 06:05:04 +0800
commitc310074fabdb6c6c5ac149bdec4767ff0432fd8c (patch)
treed3e22874e8874ce87868d8cf93ec97bd886c571b
parentf7b7c18053ddf3d631c9ba66dc49a2233058cd9d (diff)
downloadfreebsd-ports-gnome-c310074fabdb6c6c5ac149bdec4767ff0432fd8c.tar.gz
freebsd-ports-gnome-c310074fabdb6c6c5ac149bdec4767ff0432fd8c.tar.zst
freebsd-ports-gnome-c310074fabdb6c6c5ac149bdec4767ff0432fd8c.zip
audio/zynaddsubfx: fix build on cur, 10.x by force llvm40
PR: 220958 Submitted by: hselasky (maintainer)
-rw-r--r--audio/zynaddsubfx/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/audio/zynaddsubfx/Makefile b/audio/zynaddsubfx/Makefile
index b1bc04653761..48998111a95f 100644
--- a/audio/zynaddsubfx/Makefile
+++ b/audio/zynaddsubfx/Makefile
@@ -41,8 +41,8 @@ GUI_LIB_DEPENDS= libfltk.so:x11-toolkits/fltk \
libfontconfig.so:x11-fonts/fontconfig
GUI_ON= -DGuiModule:STRING=fltk
GUI_CMAKE_OFF= -DGuiModule:STRING=OFF
-GUI_USE+= XORG=x11,xext,xfixes,xcursor,ice,sm,xpm,xinerama,xft
-GUI_USE+= GL=glu
+GUI_USE+= XORG=x11,xext,xfixes,xcursor,xrender,ice,sm,xpm,xinerama,xft
+GUI_USE+= GL=gl,glu
GUI_USES= jpeg
OSS_CMAKE_ON= -DOssEnable:BOOL=ON
@@ -77,6 +77,13 @@ PORTEXAMPLES= *
CMAKE_ARGS+= -DZYN_DATADIR:STRING=${DATADIR}
CMAKE_ARGS+= -DZYN_EXAMPLESDIR:STRING=${EXAMPLESDIR}
+.include <bsd.port.options.mk>
+
+# Build fix for ZynAddSubFx
+BUILD_DEPENDS+= clang40:devel/llvm40
+CC= clang40
+CXX= clang++40
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386" || ${ARCH} == "amd64"