aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2005-08-31 19:50:26 +0800
committergarga <garga@FreeBSD.org>2005-08-31 19:50:26 +0800
commitc3a4c78911274159b508231811972e013bbd1496 (patch)
tree3a2102ec64f8b59cd1d2d7cb8ee3f79f33c5d48a
parent7227c0593d38ba29f020750723051ab9c5d444ee (diff)
downloadfreebsd-ports-gnome-c3a4c78911274159b508231811972e013bbd1496.tar.gz
freebsd-ports-gnome-c3a4c78911274159b508231811972e013bbd1496.tar.zst
freebsd-ports-gnome-c3a4c78911274159b508231811972e013bbd1496.zip
Add p5-Games-AlphaBeta 0.4.5, game-tree search with object oriented
interface. PR: ports/84165 Submitted by: Aaron Dalton <aaron@daltons.ca>
-rw-r--r--games/Makefile1
-rw-r--r--games/p5-Games-AlphaBeta/Makefile26
-rw-r--r--games/p5-Games-AlphaBeta/distinfo2
-rw-r--r--games/p5-Games-AlphaBeta/pkg-descr18
-rw-r--r--games/p5-Games-AlphaBeta/pkg-plist8
5 files changed, 55 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 5aa1f111c047..2aca8d419ec3 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -374,6 +374,7 @@
SUBDIR += openmortal
SUBDIR += openttd
SUBDIR += orbital_eunuchs_sniper
+ SUBDIR += p5-Games-AlphaBeta
SUBDIR += p5-Games-Bingo
SUBDIR += p5-Games-Bingo-Bot
SUBDIR += p5-Games-Bingo-Print
diff --git a/games/p5-Games-AlphaBeta/Makefile b/games/p5-Games-AlphaBeta/Makefile
new file mode 100644
index 000000000000..93e2c391cd35
--- /dev/null
+++ b/games/p5-Games-AlphaBeta/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Games-AlphaBeta
+# Date created: 27 July 2005
+# Whom: Aaron Dalton <aaron@daltons.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Games-AlphaBeta
+PORTVERSION= 0.4.5
+CATEGORIES= games perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Games
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@daltons.ca
+COMMENT= Game-tree search with object oriented interface
+
+BUILD_DEPENDS= ${SITE_PERL}/Games/Sequential.pm:${PORTSDIR}/games/p5-Games-Sequential
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Games::AlphaBeta.3 Games::AlphaBeta::Position.3 \
+ Games::AlphaBeta::Reversi.3
+
+.include <bsd.port.mk>
diff --git a/games/p5-Games-AlphaBeta/distinfo b/games/p5-Games-AlphaBeta/distinfo
new file mode 100644
index 000000000000..ada2eb52ee9b
--- /dev/null
+++ b/games/p5-Games-AlphaBeta/distinfo
@@ -0,0 +1,2 @@
+MD5 (Games-AlphaBeta-0.4.5.tar.gz) = a6a6b18960cced47f12747e26dd18271
+SIZE (Games-AlphaBeta-0.4.5.tar.gz) = 8952
diff --git a/games/p5-Games-AlphaBeta/pkg-descr b/games/p5-Games-AlphaBeta/pkg-descr
new file mode 100644
index 000000000000..1a153ab716eb
--- /dev/null
+++ b/games/p5-Games-AlphaBeta/pkg-descr
@@ -0,0 +1,18 @@
+Games::AlphaBeta provides a generic implementation of the AlphaBeta
+game-tree search algorithm (also known as MiniMax search with alpha beta
+pruning). This algorithm can be used to find the best move at a particular
+position in any two-player, zero-sum game with perfect information.
+Examples of such games include Chess, Othello, Connect4, Go, Tic-Tac-Toe
+and many, many other boardgames.
+
+Users must pass an object representing the initial state of the game as the
+first argument to new(). This object must provide the following methods:
+copy(), apply(), endpos(), evaluate() and findmoves(). This is explained
+more carefully in Games::AlphaBeta::Position which is a base class you can
+use to implement your position object.
+
+WWW: http://search.cpan.org/dist/Games-AlphaBeta
+Author: Stig Brautaset <stig@brautaset.org>
+
+- Aaron Dalton
+aaron@daltons.ca
diff --git a/games/p5-Games-AlphaBeta/pkg-plist b/games/p5-Games-AlphaBeta/pkg-plist
new file mode 100644
index 000000000000..1a7b60a81efb
--- /dev/null
+++ b/games/p5-Games-AlphaBeta/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Games/AlphaBeta.pm
+%%SITE_PERL%%/Games/AlphaBeta/Position.pm
+%%SITE_PERL%%/Games/AlphaBeta/Reversi.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/AlphaBeta/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/AlphaBeta
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Games 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Games/AlphaBeta
+@unexec rmdir %D/%%SITE_PERL%%/Games 2>/dev/null || true