aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-04-22 03:02:18 +0800
committermarino <marino@FreeBSD.org>2014-04-22 03:02:18 +0800
commitc3f67b5bfe878be4d83b236de45737060a06f0f2 (patch)
treeebe8ef1c636ebb00c583206f3dd68ea3607d25dc
parent6e5c829f49596a0ce3b346fcdf8e76bf166775e3 (diff)
downloadfreebsd-ports-gnome-c3f67b5bfe878be4d83b236de45737060a06f0f2.tar.gz
freebsd-ports-gnome-c3f67b5bfe878be4d83b236de45737060a06f0f2.tar.zst
freebsd-ports-gnome-c3f67b5bfe878be4d83b236de45737060a06f0f2.zip
databases/sqlbuddy: Unbreak and stage
The maintainer actually provided a PR to address the breakage long before it was marked broken. itetcu asked him a valid question: Why is sqlbuddy defaulting to sqlite when it is primarily a mysql tool? The question was never answered and the PR got thrown back on the heap. The SQLite component is what is missing. Let's remove sqlite as an option to restore the build and stage while here. It's bumped because of the change in default options. PR: ports/181708 submitted by: maintainer (Chenguang Li) modified by: marino MFH: 2014Q2
-rw-r--r--databases/sqlbuddy/Makefile27
1 files changed, 6 insertions, 21 deletions
diff --git a/databases/sqlbuddy/Makefile b/databases/sqlbuddy/Makefile
index 825863b6614c..f738c5450b28 100644
--- a/databases/sqlbuddy/Makefile
+++ b/databases/sqlbuddy/Makefile
@@ -3,6 +3,7 @@
PORTNAME= sqlbuddy
PORTVERSION= 1.3.3
+PORTREVISION= 1
CATEGORIES= databases www
MASTER_SITES= http://www.sqlbuddy.com/download/
DISTNAME= ${PORTNAME}_1_3_3
@@ -10,35 +11,20 @@ DISTNAME= ${PORTNAME}_1_3_3
MAINTAINER= horus.li@gmail.com
COMMENT= Web based MySQL administration with a set of PHP scripts
-BROKEN= Fails to check-sanity
-
USES= zip
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_PHP= ctype pcre session
+USE_PHP= ctype pcre session mysql
WANT_PHP_WEB= yes
-OPTIONS_DEFINE= MYSQL SQLITE
-OPTIONS_DEFAULT= SQLITE
-
SUB_FILES= pkg-message
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MMYSQL}
-USE_PHP+= mysql
-.endif
-.if ${PORT_OPTIONS:MSQLITE}
-USE_PHP+= sqlite
-.endif
-
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "NOTE:"
- @${ECHO_MSG} "This port suppose you have already installed one or both of these databases supported, "
+ @${ECHO_MSG} "This port assumes you have already installed a mysql database, "
@${ECHO_MSG} "and you want to use SQL Buddy to manage the server."
@${ECHO_MSG} "If you are planning to install it/them on this machine later, "
@${ECHO_MSG} "you can find it/them at ${PORTSDIR}/databases."
@@ -47,9 +33,8 @@ pre-everything::
do-install:
@${ECHO_MSG} ""
@${ECHO_MSG} "Installing SQL Buddy under ${WWWDIR}/"
- @${MKDIR} ${WWWDIR}
- @cd ${WRKSRC} && ${CP} -R * ${WWWDIR}
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${WWWDIR}
+ @cd ${WRKSRC} && ${CP} -R * ${STAGEDIR}${WWWDIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${STAGEDIR}${WWWDIR}
.include <bsd.port.mk>