aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorstefan <stefan@FreeBSD.org>2009-01-09 01:18:48 +0800
committerstefan <stefan@FreeBSD.org>2009-01-09 01:18:48 +0800
commitc41f1e14d5991424ef823dcb26f19f7f54c395da (patch)
tree6a64b0bb3a6176dd3423311ee2c8aaad9c008179
parentaff052aabd1b88b3c4f728dcccd1055eded10685 (diff)
downloadfreebsd-ports-gnome-c41f1e14d5991424ef823dcb26f19f7f54c395da.tar.gz
freebsd-ports-gnome-c41f1e14d5991424ef823dcb26f19f7f54c395da.tar.zst
freebsd-ports-gnome-c41f1e14d5991424ef823dcb26f19f7f54c395da.zip
Add a fix for warnings emitted every time the module is loaded.
PR: 123313 Submitted by: David Duchscher <daved@tamu.edu>
-rw-r--r--net/ruby-pcap/Makefile2
-rw-r--r--net/ruby-pcap/files/patch-Pcap.c15
2 files changed, 16 insertions, 1 deletions
diff --git a/net/ruby-pcap/Makefile b/net/ruby-pcap/Makefile
index 87fd1c355ac0..946dc59cd859 100644
--- a/net/ruby-pcap/Makefile
+++ b/net/ruby-pcap/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pcap
PORTVERSION= 0.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net ruby
MASTER_SITES= http://www.goto.info.waseda.ac.jp/~fukusima/ruby/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
diff --git a/net/ruby-pcap/files/patch-Pcap.c b/net/ruby-pcap/files/patch-Pcap.c
new file mode 100644
index 000000000000..8460e5d49447
--- /dev/null
+++ b/net/ruby-pcap/files/patch-Pcap.c
@@ -0,0 +1,15 @@
+--- Pcap.c.orig 2008-05-01 15:26:25.000000000 -0500
++++ Pcap.c 2008-05-01 15:27:21.000000000 -0500
+@@ -782,9 +782,9 @@
+ /* define class PcapStat */
+ cPcapStat = rb_funcall(rb_cStruct, rb_intern("new"), 4,
+ Qnil,
+- INT2NUM(rb_intern("recv")),
+- INT2NUM(rb_intern("drop")),
+- INT2NUM(rb_intern("ifdrop")));
++ ID2SYM(rb_intern("recv")),
++ ID2SYM(rb_intern("drop")),
++ ID2SYM(rb_intern("ifdrop")));
+ rb_define_const(mPcap, "Stat", cPcapStat);
+
+ /* define exception classes */