aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2013-06-07 06:03:20 +0800
committermandree <mandree@FreeBSD.org>2013-06-07 06:03:20 +0800
commitc4f7e45e929c7a1ce36eb37d3ef3bd7f62206524 (patch)
tree21ff025406903d41394af412198699168be71de3
parenta365f87137bfbd73455b590674ea1dfb02e66d74 (diff)
downloadfreebsd-ports-gnome-c4f7e45e929c7a1ce36eb37d3ef3bd7f62206524.tar.gz
freebsd-ports-gnome-c4f7e45e929c7a1ce36eb37d3ef3bd7f62206524.tar.zst
freebsd-ports-gnome-c4f7e45e929c7a1ce36eb37d3ef3bd7f62206524.zip
Add a new port devel/lua-lunit, maintained by Sergey V. Dyatko (submitter).
Lunit is a unit testing framework for lua, written in lua. It provides currently 27 assert functions, 8 type checking functions and a few miscellaneous functions for usage as an easy unit testing framework. The PKGNAMEPREFIX= lua- was approved of by Sergey V. Dyatko in private mail. Further changes over his submission are: - LUA_MODLIBDIR= ${PREFIX}/lib/lua/${LUA_VER}/${PORTNAME} removed (shadows lua framework setting) - remove ${MKDIR} ${LUA_MODLIBDIR} - we don't install any files there - change installation destionation from LOCALBASE to PREFIX, and create directory first PR: ports/177541 Submitted by: Sergey V. Dyatko
-rw-r--r--devel/lua-lunit/Makefile56
-rw-r--r--devel/lua-lunit/distinfo2
-rw-r--r--devel/lua-lunit/pkg-descr5
-rw-r--r--devel/lua-lunit/pkg-plist9
4 files changed, 72 insertions, 0 deletions
diff --git a/devel/lua-lunit/Makefile b/devel/lua-lunit/Makefile
new file mode 100644
index 000000000000..5d2063683294
--- /dev/null
+++ b/devel/lua-lunit/Makefile
@@ -0,0 +1,56 @@
+# Created by: Sergey V. Dyatko <sergey.dyatko@gmail.com>
+# $FreeBSD$
+
+PORTNAME= lunit
+PORTVERSION= 0.5
+CATEGORIES= devel
+MASTER_SITES= http://www.mroth.net/${PORTNAME}/
+PKGNAMEPREFIX= lua-
+
+MAINTAINER= sergey.dyatko@gmail.com
+COMMENT= Unit Testing Framework for Lua
+
+LICENSE= MIT
+
+USE_LUA= 5.1
+
+DOCFILES= DOCUMENTATION README
+EXAMPLES= example.lua
+LUNIT_FILES= lunit-console.lua lunit-tests.lua lunit.lua
+
+NO_BUILD= yes
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == "amd64"
+CFLAGS+= -fPIC
+.endif
+
+pre-install:
+ ${REINPLACE_CMD} -e 's|"lua"|"${LUA_CMD}"|g' ${WRKSRC}/lunit
+
+do-install:
+ ${MKDIR} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/lunit ${PREFIX}/bin
+
+.for lunit_part in ${LUNIT_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${lunit_part} ${LUA_MODSHAREDIR}
+.endfor
+
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+.for f in ${DOCFILES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}"
+.endif
+
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/example.lua ${EXAMPLESDIR}
+ @${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}"
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/lua-lunit/distinfo b/devel/lua-lunit/distinfo
new file mode 100644
index 000000000000..b9fbab716238
--- /dev/null
+++ b/devel/lua-lunit/distinfo
@@ -0,0 +1,2 @@
+SHA256 (lunit-0.5.tar.gz) = 36abb8c4f8a3602c7c2b043d5b3612c2836a637ad504b58041acac1ddccb1852
+SIZE (lunit-0.5.tar.gz) = 13528
diff --git a/devel/lua-lunit/pkg-descr b/devel/lua-lunit/pkg-descr
new file mode 100644
index 000000000000..45346fc05231
--- /dev/null
+++ b/devel/lua-lunit/pkg-descr
@@ -0,0 +1,5 @@
+Lunit is a unit testing framework for lua, written in lua. It provides currently
+27 assert functions, 8 type checking functions and a few miscellaneous functions
+for usage as an easy unit testing framework.
+
+WWW: http://www.mroth.net/lunit/
diff --git a/devel/lua-lunit/pkg-plist b/devel/lua-lunit/pkg-plist
new file mode 100644
index 000000000000..aa1705fdb96e
--- /dev/null
+++ b/devel/lua-lunit/pkg-plist
@@ -0,0 +1,9 @@
+bin/lunit
+%%LUA_MODSHAREDIR%%/lunit-tests.lua
+%%LUA_MODSHAREDIR%%/lunit-console.lua
+%%LUA_MODSHAREDIR%%/lunit.lua
+%%PORTDOCS%%%%DOCSDIR%%/DOCUMENTATION
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example.lua
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%