aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2009-11-04 17:13:22 +0800
committernivit <nivit@FreeBSD.org>2009-11-04 17:13:22 +0800
commitc6b696920941cc66e9650a46273f0e9d62960cd2 (patch)
tree20540c2cff838052b610a00f5befd01a947a224b
parent6632777c7eef6628ec0255f1de8a8ffbfe6d5a66 (diff)
downloadfreebsd-ports-gnome-c6b696920941cc66e9650a46273f0e9d62960cd2.tar.gz
freebsd-ports-gnome-c6b696920941cc66e9650a46273f0e9d62960cd2.tar.zst
freebsd-ports-gnome-c6b696920941cc66e9650a46273f0e9d62960cd2.zip
Bottle is a fast and simple micro-framework for small web-applications.
It offers request dispatching (Routes) with url parameter support, Templates, key/value Databases, a build-in HTTP Server and adapters for many third party WSGI/HTTP-server and template engines. All in a single file and with no dependencies other than the Python Standard Library. WWW: http://bottle.paws.de/
-rw-r--r--www/Makefile1
-rw-r--r--www/py-bottle/Makefile22
-rw-r--r--www/py-bottle/distinfo3
-rw-r--r--www/py-bottle/pkg-descr8
-rw-r--r--www/py-bottle/pkg-plist4
5 files changed, 38 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index f035ae0b7b6f..d81297597a61 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1297,6 +1297,7 @@
SUBDIR += py-apachelog
SUBDIR += py-beaker
SUBDIR += py-beautifulsoup
+ SUBDIR += py-bottle
SUBDIR += py-cherrypy
SUBDIR += py-cherrypy-old
SUBDIR += py-clientform
diff --git a/www/py-bottle/Makefile b/www/py-bottle/Makefile
new file mode 100644
index 000000000000..34dba3c754d6
--- /dev/null
+++ b/www/py-bottle/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: bottle
+# Date created: 2009-11-03
+# Whom: Nicola Vitale <nivit@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bottle
+PORTVERSION= 0.6.4
+#PORTREVISION= 0
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP \
+ http://nivi.interfree.it/distfiles/${PORTNAME}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Fast and simple WSGI-framework for small web-applications
+
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-bottle/distinfo b/www/py-bottle/distinfo
new file mode 100644
index 000000000000..921e4640926f
--- /dev/null
+++ b/www/py-bottle/distinfo
@@ -0,0 +1,3 @@
+MD5 (bottle-0.6.4.tar.gz) = fc4603408ab61de55441a0c9192fe488
+SHA256 (bottle-0.6.4.tar.gz) = 02a6007fb28755f89918c156377f5e0a6fbe0ce0260a053dab07b533977bc337
+SIZE (bottle-0.6.4.tar.gz) = 16782
diff --git a/www/py-bottle/pkg-descr b/www/py-bottle/pkg-descr
new file mode 100644
index 000000000000..44a33a00cb06
--- /dev/null
+++ b/www/py-bottle/pkg-descr
@@ -0,0 +1,8 @@
+Bottle is a fast and simple micro-framework for small web-applications.
+It offers request dispatching (Routes) with url parameter support,
+Templates, key/value Databases, a build-in HTTP Server and adapters
+for many third party WSGI/HTTP-server and template engines.
+All in a single file and with no dependencies other than the Python
+Standard Library.
+
+WWW: http://bottle.paws.de/
diff --git a/www/py-bottle/pkg-plist b/www/py-bottle/pkg-plist
new file mode 100644
index 000000000000..653067eb6d6e
--- /dev/null
+++ b/www/py-bottle/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+%%PYTHON_SITELIBDIR%%/bottle.py
+%%PYTHON_SITELIBDIR%%/bottle.pyc
+%%PYTHON_SITELIBDIR%%/bottle.pyo