aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2007-03-29 20:50:00 +0800
committerehaupt <ehaupt@FreeBSD.org>2007-03-29 20:50:00 +0800
commitc815d163bdbb935073043494b80018588d7e63cc (patch)
tree979d61b40359d17c5448a444fd92a36fa2cbafd4
parent5e064fbf6877e8ba8b8ef83382af43eb1fff3512 (diff)
downloadfreebsd-ports-gnome-c815d163bdbb935073043494b80018588d7e63cc.tar.gz
freebsd-ports-gnome-c815d163bdbb935073043494b80018588d7e63cc.tar.zst
freebsd-ports-gnome-c815d163bdbb935073043494b80018588d7e63cc.zip
- Cleanup objformat-removal fallout
- Use USE_LDCONFIG Approved by: portmgr (pav; implicit)
-rw-r--r--audio/xmms-mac/Makefile4
-rw-r--r--audio/xmms-mad/Makefile4
-rw-r--r--audio/xmms-modplug/Makefile4
-rw-r--r--audio/xmms-nas/Makefile4
4 files changed, 16 insertions, 0 deletions
diff --git a/audio/xmms-mac/Makefile b/audio/xmms-mac/Makefile
index 600630fcd030..796d4c412982 100644
--- a/audio/xmms-mac/Makefile
+++ b/audio/xmms-mac/Makefile
@@ -25,9 +25,13 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+= CPPFLAGS="${CPPFLAGS}"
USE_AUTOTOOLS= autoconf:259
CPPFLAGS+= "-I${LOCALBASE}/include"
+USE_LDCONFIG= yes
PLIST_FILES= lib/xmms/Input/libxmms-mac.so
+post-patch:
+ @${REINPLACE_CMD} -e '/objformat=/s|=.*|=elf|' ${WRKSRC}/aclocal.m4
+
do-install:
${INSTALL_DATA} ${WRKSRC}/src/.libs/libxmms-mac.so ${PREFIX}/lib/xmms/Input
diff --git a/audio/xmms-mad/Makefile b/audio/xmms-mad/Makefile
index e1912b91e03b..ffb02035de5c 100644
--- a/audio/xmms-mad/Makefile
+++ b/audio/xmms-mad/Makefile
@@ -25,7 +25,11 @@ USE_X_PREFIX= yes
USE_GNOME= gtk12
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
CONFIGURE_ENV= CFLAGS="${CFLAGS} -L${LOCALBASE}/lib"
+post-patch:
+ @${REINPLACE_CMD} -e '/objformat=/s|=.*|=elf|' ${WRKSRC}/configure
+
.include <bsd.port.mk>
diff --git a/audio/xmms-modplug/Makefile b/audio/xmms-modplug/Makefile
index ca3a1f50c0c9..a03323152dcd 100644
--- a/audio/xmms-modplug/Makefile
+++ b/audio/xmms-modplug/Makefile
@@ -21,6 +21,7 @@ LIB_DEPENDS?= xmms.4:${PORTSDIR}/multimedia/xmms
LIB_DEPENDS+= modplug.0:${PORTSDIR}/audio/libmodplug
USE_X_PREFIX= yes
+USE_LDCONFIG= yes
HAS_CONFIGURE= yes
PLUGDIR?= lib/xmms/Input
PLIST_FILES= ${PLUGDIR}/libmodplugxmms.so
@@ -31,6 +32,9 @@ PLIST_FILES= ${PLUGDIR}/libmodplugxmms.so
BROKEN= Does not compile on FreeBSD 4.x
.endif
+post-patch:
+ @${REINPLACE_CMD} -e '/objformat=/s|=.*|=elf|' ${WRKSRC}/configure
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/modplugxmms/.libs/libmodplugxmms.so ${PREFIX}/${PLUGDIR}/
diff --git a/audio/xmms-nas/Makefile b/audio/xmms-nas/Makefile
index 8f38fdf56286..bd32b46389e8 100644
--- a/audio/xmms-nas/Makefile
+++ b/audio/xmms-nas/Makefile
@@ -20,9 +20,13 @@ LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms \
USE_X_PREFIX= yes
USE_GNOME= gtk12
GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
PLIST_FILES= lib/xmms/Output/libnas.a \
lib/xmms/Output/libnas.la \
lib/xmms/Output/libnas.so
+post-patch:
+ @${REINPLACE_CMD} -e '/objformat=/s|=.*|=elf|' ${WRKSRC}/ltconfig
+
.include <bsd.port.mk>