aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2011-05-23 06:09:29 +0800
committerohauer <ohauer@FreeBSD.org>2011-05-23 06:09:29 +0800
commitc85d64a436fb1291b1a08e851c9af39ee7df207d (patch)
tree49eaf26749cf675719b8bae0525f58c951a4edd0
parenta0cc0a93eb60a6150b12eb41474743ac91e673b8 (diff)
downloadfreebsd-ports-gnome-c85d64a436fb1291b1a08e851c9af39ee7df207d.tar.gz
freebsd-ports-gnome-c85d64a436fb1291b1a08e851c9af39ee7df207d.tar.zst
freebsd-ports-gnome-c85d64a436fb1291b1a08e851c9af39ee7df207d.zip
- p5-Apache-DBI
do not allow to include ports direct, use SLAVE ports instead - aditional test APACHE_VERSION
-rw-r--r--www/p5-Apache-DBI-mp1/Makefile9
-rw-r--r--www/p5-Apache-DBI-mp2/Makefile3
-rw-r--r--www/p5-Apache-DBI/Makefile16
3 files changed, 23 insertions, 5 deletions
diff --git a/www/p5-Apache-DBI-mp1/Makefile b/www/p5-Apache-DBI-mp1/Makefile
index b483956e3692..ca33aef3770b 100644
--- a/www/p5-Apache-DBI-mp1/Makefile
+++ b/www/p5-Apache-DBI-mp1/Makefile
@@ -1,5 +1,5 @@
# New ports collection makefile for: p5-Apache-DBI-mp1
-# Date created: 28 Aug 2008
+# Date created: 28 Aug 2008
# Whom: Philip M. Gollucci <pgollucci@p6m7g8.com>
#
# $FreeBSD$
@@ -8,14 +8,17 @@
PORTNAME= Apache-DBI
PKGNAMESUFFIX= -mp1
-COMMENT= DBI persistent connection, authentication and authorization (mp1)
+COMMENT= DBI persistent connection, authentication and authorization (mp1)
MAKE_JOBS_SAFE= yes
MASTERDIR= ${.CURDIR}/../p5-Apache-DBI
.if defined(WITH_MODPERL2) || defined(WITHOUT_MODPERL)
-IGNORE= This port is only for use with www/mod_perl
+IGNORE= this port is only for use with www/mod_perl
.endif
+WITH_MODPERL= yes
+USE_APACHE= 13
+
.include "${MASTERDIR}/Makefile"
diff --git a/www/p5-Apache-DBI-mp2/Makefile b/www/p5-Apache-DBI-mp2/Makefile
index 9ab74d71c596..d4965dc663f4 100644
--- a/www/p5-Apache-DBI-mp2/Makefile
+++ b/www/p5-Apache-DBI-mp2/Makefile
@@ -15,9 +15,10 @@ MAKE_JOBS_SAFE= yes
MASTERDIR= ${.CURDIR}/../p5-Apache-DBI
.if defined(WITH_MODPERL) || defined(WITHOUT_MODPERL2)
-IGNORE= This port is only for use with www/mod_perl2
+IGNORE= this port is only for use with www/mod_perl2
.endif
WITH_MODPERL2= yes
+USE_APACHE= 20+
.include "${MASTERDIR}/Makefile"
diff --git a/www/p5-Apache-DBI/Makefile b/www/p5-Apache-DBI/Makefile
index eacda6570aef..fdac8f4517c0 100644
--- a/www/p5-Apache-DBI/Makefile
+++ b/www/p5-Apache-DBI/Makefile
@@ -24,6 +24,20 @@ MAKE_JOBS_SAFE= yes
MAN3= Apache::DBI.3 Apache::AuthDBI.3
PERL_CONFIGURE= yes
+USE_APACHE?= 13+
+.include <bsd.port.pre.mk>
+
+# prevent from direct including
+# ports should use one of the SLAVEPORTS
+.if !defined(PKGNAMESUFFIX)
+IGNORE= use ${SLAVEDIRS} instead
+.endif
+
+.if defined(WITH_MODPERL) && ${APACHE_VERSION} > 13
+IGNORE= mod_perl require apache13 but ${APACHE_PORT} is installed
+.elif defined(WITH_MODPERL2) && ${APACHE_VERSION} < 20
+IGNORE= mod_perl2 require at last apache20 but ${APACHE_PORT} is installed
+.endif
.if defined(WITH_MODPERL2)
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2
@@ -41,4 +55,4 @@ PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/DBI \
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache \
%%SITE_PERL%%/Apache
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>