aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-07-27 10:08:17 +0800
committerswills <swills@FreeBSD.org>2011-07-27 10:08:17 +0800
commitcba39c3721f99977c9240a94960070f9c43f37a0 (patch)
tree3a4e675bdd9adc351adb7fb49030509738a73bf4
parentff1667c0b06bf4b6945720383f1c30523692dd4a (diff)
downloadfreebsd-ports-gnome-cba39c3721f99977c9240a94960070f9c43f37a0.tar.gz
freebsd-ports-gnome-cba39c3721f99977c9240a94960070f9c43f37a0.tar.zst
freebsd-ports-gnome-cba39c3721f99977c9240a94960070f9c43f37a0.zip
- Fix build with Ruby 1.9
With hat: ruby@
-rw-r--r--security/metasploit/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/security/metasploit/Makefile b/security/metasploit/Makefile
index 0b7afc7f2290..15cf07a79dcd 100644
--- a/security/metasploit/Makefile
+++ b/security/metasploit/Makefile
@@ -36,10 +36,10 @@ WITH_NCURSES_PORT= yes
.if ${RUBY_VER} == 1.8
RUN_DEPENDS+= ${LOCALBASE}/bin/gem:${PORTSDIR}/devel/ruby-gems
.else
-RUN_DEPENDS+= rubygem-actionpack:${PORTSDIR}/www/rubygem-actionpack \
- rubygem-sqlite3:${PORTSDIR}/databases/rubygem-sqlite3 \
- rubygem-activerecord:${PORTSDIR}/databases/rubygem-activerecord \
- rubygem-activesupport:${PORTSDIR}/devel/rubygem-activesupport \
+RUN_DEPENDS+= rubygem-actionpack>0:${PORTSDIR}/www/rubygem-actionpack \
+ rubygem-sqlite3>0:${PORTSDIR}/databases/rubygem-sqlite3 \
+ rubygem-activerecord>0:${PORTSDIR}/databases/rubygem-activerecord \
+ rubygem-activesupport>0:${PORTSDIR}/devel/rubygem-activesupport \
${RUBY_ARCHLIBDIR}/iconv.so:${PORTSDIR}/converters/ruby-iconv
.endif