aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-03-12 20:59:38 +0800
committermat <mat@FreeBSD.org>2016-03-12 20:59:38 +0800
commitccf36f13d4a4314fcdd81a7517597ba4ac3fd94a (patch)
tree03cb9df59686213cbf3123d219e7486d1be8dfc4
parent7141b5a03d4ccd888bb43ab340b60acf13897fdb (diff)
downloadfreebsd-ports-gnome-ccf36f13d4a4314fcdd81a7517597ba4ac3fd94a.tar.gz
freebsd-ports-gnome-ccf36f13d4a4314fcdd81a7517597ba4ac3fd94a.tar.zst
freebsd-ports-gnome-ccf36f13d4a4314fcdd81a7517597ba4ac3fd94a.zip
Once upon a time, when you ran make package and the ${PACKAGES}
directory did not exist, you ended up with the package in the port directory. Make that true again. PR: 207895 Sponsored by: Absolight
-rw-r--r--Mk/bsd.port.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 472d205756a0..1312907a8d5d 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3520,6 +3520,9 @@ do-package: ${TMPPLIST}
fi ; \
${LN} -sf ../${PKGREPOSITORYSUBDIR}/${PKGNAME}${PKG_SUFX} ${PKGLATESTFILE} ; \
fi; \
+ elif [ ! -d ${PACKAGES} ]; then \
+ ${LN} -f ${WRKDIR_PKGFILE} ${PKGFILE} 2>/dev/null \
+ || ${CP} -f ${WRKDIR_PKGFILE} ${PKGFILE}; \
fi; \
else \
cd ${.CURDIR} && eval ${MAKE} delete-package >/dev/null; \