aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2002-06-28 15:59:02 +0800
committerkevlo <kevlo@FreeBSD.org>2002-06-28 15:59:02 +0800
commitcd72bc6fd7b99f9b8477d200cee5a25209449010 (patch)
treee5b38e53c222346a2d6431fe047396f72a2f3045
parent977c67bf97e08188d2ce87915671b19af4f1da8c (diff)
downloadfreebsd-ports-gnome-cd72bc6fd7b99f9b8477d200cee5a25209449010.tar.gz
freebsd-ports-gnome-cd72bc6fd7b99f9b8477d200cee5a25209449010.tar.zst
freebsd-ports-gnome-cd72bc6fd7b99f9b8477d200cee5a25209449010.zip
Warn of potential exception handling bugs in FreeBSD versions < 4.6.
PR: 39921 Submitted by: MAINTAINER
-rw-r--r--devel/stlport/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/devel/stlport/Makefile b/devel/stlport/Makefile
index 0e9bb4873f8e..e9be2833fb90 100644
--- a/devel/stlport/Makefile
+++ b/devel/stlport/Makefile
@@ -34,6 +34,14 @@ INSTALLS_SHLIB= yes
BROKEN= "Not supported on systems prior to FreeBSD 4.4"
.endif
+.if ${OSVERSION} < 460000
+pre-everything:
+ @${ECHO_MSG}
+ @${ECHO_MSG} "There may be a bug in your version of gcc's exception"
+ @${ECHO_MSG} "handling code. Consider upgrading to FreeBSD 4.6"
+ @${ECHO_MSG} "or above."
+.endif
+
post-install:
${FIND} ${PREFIX}/include/stlport -name \*.orig -delete
.if !defined(NOPORTDOCS)
@@ -43,7 +51,11 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/../doc/images/* ${DOCSDIR}/images
.endif
-post-build test:
+.if ${OSVERSION} >= 46000
+post-build: test
+.endif
+
+test:
cd ${WRKSRC}/../test/eh && ${SETENV} CC=${CC} CXX=${CXX} \
${GMAKE} -f ${MAKEFILE} PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \
PTHREAD_LIBS=${PTHREAD_LIBS} PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \