aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2013-10-15 03:18:17 +0800
committerolivierd <olivierd@FreeBSD.org>2013-10-15 03:18:17 +0800
commitd04020c70d7fccd535a313d08d2ebe36fde16c58 (patch)
tree9110ac4ed4a96eb226a8c32a1e5755970abcbaa4
parent1a5bf43cc9687538cbadca102c6db52024a21479 (diff)
downloadfreebsd-ports-gnome-d04020c70d7fccd535a313d08d2ebe36fde16c58.tar.gz
freebsd-ports-gnome-d04020c70d7fccd535a313d08d2ebe36fde16c58.tar.zst
freebsd-ports-gnome-d04020c70d7fccd535a313d08d2ebe36fde16c58.zip
- Support STAGEDIR
- Switch to USES= gmake - Convert to new LIB_DEPENDS format (sysutils/xfce4-settings)
-rw-r--r--sysutils/garcon/Makefile4
-rw-r--r--sysutils/xfce4-settings/Makefile12
2 files changed, 6 insertions, 10 deletions
diff --git a/sysutils/garcon/Makefile b/sysutils/garcon/Makefile
index b37603846d93..95cf170ceffd 100644
--- a/sysutils/garcon/Makefile
+++ b/sysutils/garcon/Makefile
@@ -13,14 +13,12 @@ COMMENT= Xfce 4 essential utilities and scripts
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USE_GMAKE= yes
USE_GNOME= glib20 intltool intlhack
USE_XFCE= configenv libutil
-USES= pathfix pkgconfig
+USES= pathfix pkgconfig gmake
OPTIONS_DEFINE= DOCS NLS
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/sysutils/xfce4-settings/Makefile b/sysutils/xfce4-settings/Makefile
index d504dfc3561e..74f54c7ea9bd 100644
--- a/sysutils/xfce4-settings/Makefile
+++ b/sysutils/xfce4-settings/Makefile
@@ -11,17 +11,16 @@ DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
COMMENT= Xfce 4 settings application
-LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_BZIP2= yes
-USE_GMAKE= yes
USE_GNOME= glib20 gtk20 intltool intlhack
USE_XFCE= configenv garcon libexo libmenu libutil xfconf
USE_XORG= inputproto x11 xi
-USES= pathfix pkgconfig
+USES= pathfix pkgconfig gmake
CONFIGURE_ARGS= --enable-pluggable-dialogs \
--enable-gio-unix
@@ -30,11 +29,10 @@ OPTIONS_DEFINE= XKLAVIER XCURSOR XRANDR NOTIFY NLS SOUND
OPTIONS_DEFAULT= XKLAVIER XCURSOR XRANDR NOTIFY NLS
SOUND_DESC= Enable sound control
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MXKLAVIER}
-LIB_DEPENDS+= xklavier:${PORTSDIR}/x11/libxklavier
+LIB_DEPENDS+= libxklavier.so:${PORTSDIR}/x11/libxklavier
CONFIGURE_ARGS+=--enable-libxklavier
.else
CONFIGURE_ARGS+=--disable-libxklavier
@@ -57,7 +55,7 @@ PLIST_SUB+= XRANDR="@comment "
.endif
.if ${PORT_OPTIONS:MNOTIFY}
-LIB_DEPENDS+= notify:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS+= libnotify.so:${PORTSDIR}/devel/libnotify
CONFIGURE_ARGS+=--enable-libnotify
.else
CONFIGURE_ARGS+=--disable-libnotify
@@ -73,7 +71,7 @@ PLIST_SUB+= NLS="@comment "
.endif
.if ${PORT_OPTIONS:MSOUND}
-LIB_DEPENDS+= canberra:${PORTSDIR}/audio/libcanberra
+LIB_DEPENDS+= libcanberra.so:${PORTSDIR}/audio/libcanberra
CONFIGURE_ARGS+=--enable-sound-settings
.else
CONFIGURE_ARGS+=--disable-sound-settings