aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2012-11-20 19:12:25 +0800
committerdemon <demon@FreeBSD.org>2012-11-20 19:12:25 +0800
commitd1ec964a692ba7f44eb1a4dd7d8fa030b61aa601 (patch)
treed279b76c7b7172fb334f0221921e873e6a80f7f7
parent19df8fc77371b355187b4654e25f747a1d506224 (diff)
downloadfreebsd-ports-gnome-d1ec964a692ba7f44eb1a4dd7d8fa030b61aa601.tar.gz
freebsd-ports-gnome-d1ec964a692ba7f44eb1a4dd7d8fa030b61aa601.tar.zst
freebsd-ports-gnome-d1ec964a692ba7f44eb1a4dd7d8fa030b61aa601.zip
Unbreak the port for python versions > 3.1.
I verified that this port works with python version 2.6 .. 3.3 now. Approved by: maintainer timeout Feature safe: yes
-rw-r--r--devel/boost-python-libs/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/devel/boost-python-libs/Makefile b/devel/boost-python-libs/Makefile
index 03fe4879bbce..ab32735afab1 100644
--- a/devel/boost-python-libs/Makefile
+++ b/devel/boost-python-libs/Makefile
@@ -9,7 +9,7 @@ PORTNAME= boost-python-libs
COMMENT= Framework for interfacing Python and C++
USE_BZIP2= yes
-USE_PYTHON= 2.5-3.1
+USE_PYTHON= yes
OPTIONS= VERBOSE_BUILD "Show compiler messages" off \
DEBUG "Build debugging symbols" off \
@@ -35,7 +35,7 @@ BUILD_DEPENDS+= ${BJAM}:${PORTSDIR}/devel/boost-jam
post-patch: customize-boost-build
do-build:
- ${ECHO_CMD} "using python : " ${PYTHON_VER} ";" >> ${WRKSRC}/tools/build/v2/site-config.jam
+ ${ECHO_CMD} "using python : " ${PYTHON_VER} " : " ${PYTHON_CMD} " : " ${PYTHON_INCLUDEDIR} ";" >> ${WRKSRC}/tools/build/v2/site-config.jam
# build the library
cd ${WRKSRC} && \
${SETENV} ${MAKE_ENV} ${BJAM} ${BJAM_OPTIONS} --prefix=${PREFIX}\