aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-01-04 13:28:43 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-01-04 13:28:43 +0800
commitd2c61f747d818420921735d46a0087ee34169d93 (patch)
tree4e2ae3d2cf7b15fee415e23fec88147ae41f7107
parentfafcbfb1e86a7e6781f90d7224ce96d3164a755b (diff)
downloadfreebsd-ports-gnome-d2c61f747d818420921735d46a0087ee34169d93.tar.gz
freebsd-ports-gnome-d2c61f747d818420921735d46a0087ee34169d93.tar.zst
freebsd-ports-gnome-d2c61f747d818420921735d46a0087ee34169d93.zip
- OPTIONS += LCLASS
Allow the use of login classes in nss_ldap via a new LDAP attribute (loginClass). Administrators should be able to add this attribute to their schemata easily. PR: ports/14107 Submitted by: Jacob Myers <jacob@whotookspaz.org>
-rw-r--r--net/nss_ldap/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/net/nss_ldap/Makefile b/net/nss_ldap/Makefile
index 222028eeb2f5..61ba5e93cdfb 100644
--- a/net/nss_ldap/Makefile
+++ b/net/nss_ldap/Makefile
@@ -23,6 +23,8 @@ USE_AUTOTOOLS= automake:19 aclocal:19 autoconf:262 autoheader:262
USE_LDCONFIG= yes
USE_OPENLDAP= yes
+OPTIONS= LCLASS "Enable login classes via the loginClass attribute" on
+
PLIST_FILES= etc/nss_ldap.conf.sample \
lib/nss_ldap.so.1
@@ -41,6 +43,10 @@ MAN5= nss_ldap.5
CONFIGURE_ARGS+=--enable-configurable-krb5-ccname-env
.endif
+.if defined(WITH_LCLASS)
+CFLAGS+="-DHAVE_LOGIN_CLASSES"
+.endif
+
post-extract:
${CP} ${FILESDIR}/bsdnss.c ${WRKSRC}