aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2013-09-06 04:18:30 +0800
committerbsam <bsam@FreeBSD.org>2013-09-06 04:18:30 +0800
commitd4be7ebb16af8657e516c12bf0574fb925a3f26f (patch)
tree3b1d1321b78dcf4a659d95ca332649d8253316c1
parentd17cc05291e2481f97fd8cd319a6585d4004ffad (diff)
downloadfreebsd-ports-gnome-d4be7ebb16af8657e516c12bf0574fb925a3f26f.tar.gz
freebsd-ports-gnome-d4be7ebb16af8657e516c12bf0574fb925a3f26f.tar.zst
freebsd-ports-gnome-d4be7ebb16af8657e516c12bf0574fb925a3f26f.zip
. introduce ICONV_CONFIGURE_BASE variable at Mk/Uses/iconv.mk. It's value is
"--with-libiconv=${LOCALBASE}" at systems pre OSVERSION 100043 and "" (null) otherwise; . convert all ports which has CONFIGURE_ARGS=--with-libiconv=${LOCALBASE}. Approved by: portmgr (bapt, implicit)
-rw-r--r--Mk/Uses/iconv.mk2
-rw-r--r--devel/tig/Makefile2
-rw-r--r--dns/bind96/Makefile3
-rw-r--r--dns/bind98/Makefile3
-rw-r--r--dns/bind99/Makefile3
-rw-r--r--dns/idnkit/Makefile2
-rw-r--r--dns/idnkit2/Makefile11
-rw-r--r--japanese/chasen-base/Makefile2
-rw-r--r--mail/gmime2/Makefile2
-rw-r--r--net/netatalk/Makefile9
-rw-r--r--net/netatalk3/Makefile9
-rw-r--r--net/samba36/Makefile2
-rw-r--r--net/samba4/Makefile2
-rw-r--r--net/samba4wins/Makefile2
-rw-r--r--palm/pilot-link/Makefile2
-rw-r--r--palm/synce-librapi2/Makefile3
-rw-r--r--palm/synce-vdccm/Makefile2
-rw-r--r--www/dansguardian-devel/Makefile4
-rw-r--r--www/dansguardian/Makefile4
19 files changed, 28 insertions, 41 deletions
diff --git a/Mk/Uses/iconv.mk b/Mk/Uses/iconv.mk
index 0401837b200a..9c115cb4982a 100644
--- a/Mk/Uses/iconv.mk
+++ b/Mk/Uses/iconv.mk
@@ -21,6 +21,7 @@ iconv_ARGS= lib
ICONV_CMD= ${LOCALBASE}/bin/iconv
ICONV_LIB= -liconv
ICONV_CONFIGURE_ARG= --with-libiconv-prefix=${LOCALBASE}
+ICONV_CONFIGURE_BASE= --with-libiconv=${LOCALBASE}
.if ${iconv_ARGS} == "lib"
LIB_DEPENDS+= libiconv.so.3:${PORTSDIR}/converters/libiconv
@@ -35,6 +36,7 @@ PATCH_DEPENDS+= ${ICONV_CMD}:${PORTSDIR}/converters/libiconv
ICONV_CMD= /usr/bin/iconv
ICONV_LIB=
ICONV_CONFIGURE_ARG=
+ICONV_CONFIGURE_BASE=
.endif
diff --git a/devel/tig/Makefile b/devel/tig/Makefile
index fe8b5681a7d9..ce31de5d624d 100644
--- a/devel/tig/Makefile
+++ b/devel/tig/Makefile
@@ -18,7 +18,7 @@ MAN5= tigrc.5
MAN7= tigmanual.7
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-libiconv=${LOCALBASE}
+CONFIGURE_ARGS= ${ICONV_CONFIGURE_BASE}
USE_GMAKE= yes
USES= iconv
diff --git a/dns/bind96/Makefile b/dns/bind96/Makefile
index c42c30305f0e..ebea70cc582c 100644
--- a/dns/bind96/Makefile
+++ b/dns/bind96/Makefile
@@ -69,7 +69,8 @@ CONFIGURE_ARGS+= --without-libxml2
.endif
.if ${PORT_OPTIONS:MIDN}
-CONFIGURE_ARGS+= --with-idn=${LOCALBASE} --with-libiconv=${LOCALBASE}
+USES+= iconv
+CONFIGURE_ARGS+= --with-idn=${LOCALBASE} ${ICONV_CONFIGURE_BASE}
LIB_DEPENDS+= idnkit.1:${PORTSDIR}/dns/idnkit
.else
CONFIGURE_ARGS+= --without-idn
diff --git a/dns/bind98/Makefile b/dns/bind98/Makefile
index 5e0bfd918b73..37fdb310a51f 100644
--- a/dns/bind98/Makefile
+++ b/dns/bind98/Makefile
@@ -72,7 +72,8 @@ CONFIGURE_ARGS+= --without-libxml2
.endif
.if ${PORT_OPTIONS:MIDN}
-CONFIGURE_ARGS+= --with-idn=${LOCALBASE} --with-libiconv=${LOCALBASE}
+USES+= iconv
+CONFIGURE_ARGS+= --with-idn=${LOCALBASE} ${ICONV_CONFIGURE_BASE}
LIB_DEPENDS+= idnkit.1:${PORTSDIR}/dns/idnkit
.else
CONFIGURE_ARGS+= --without-idn
diff --git a/dns/bind99/Makefile b/dns/bind99/Makefile
index 9a21b1de4c81..370218e1d622 100644
--- a/dns/bind99/Makefile
+++ b/dns/bind99/Makefile
@@ -81,7 +81,8 @@ CONFIGURE_ARGS+= --without-libxml2
.endif
.if ${PORT_OPTIONS:MIDN}
-CONFIGURE_ARGS+= --with-idn=${LOCALBASE} --with-libiconv=${LOCALBASE}
+USES+= iconv
+CONFIGURE_ARGS+= --with-idn=${LOCALBASE} ${ICONV_CONFIGURE_BASE}
LIB_DEPENDS+= idnkit.1:${PORTSDIR}/dns/idnkit
.else
CONFIGURE_ARGS+= --without-idn
diff --git a/dns/idnkit/Makefile b/dns/idnkit/Makefile
index eb63b3346b32..ce39ae91466a 100644
--- a/dns/idnkit/Makefile
+++ b/dns/idnkit/Makefile
@@ -18,7 +18,7 @@ COMMENT= A library to handle internationalized domain names
USE_AUTOTOOLS= libtool
USES= iconv
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-libiconv=${LOCALBASE} \
+CONFIGURE_ARGS= ${ICONV_CONFIGURE_BASE} \
--enable-runidn \
--enable-extra-ace
diff --git a/dns/idnkit2/Makefile b/dns/idnkit2/Makefile
index 9b27efe4ae79..83326e48d29b 100644
--- a/dns/idnkit2/Makefile
+++ b/dns/idnkit2/Makefile
@@ -20,6 +20,7 @@ USE_AUTOTOOLS= libtool
USES= iconv
USE_BZIP2= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= ${ICONV_CONFIGURE_BASE}
USE_LDCONFIG= yes
@@ -32,16 +33,8 @@ MAN3= idn_checkname.3 idn_comparenames.3 idn_comparenames2.3 \
MAN5= idn2.conf.5 idn2rc.5 idnalias.conf.5 idnlang.conf.5
MANCOMPRESSED= no
-.include <bsd.port.pre.mk>
-
-.if empty(ICONV_LIB)
-CONFIGURE_ARGS= --with-libiconv=/usr
-.else
-CONFIGURE_ARGS= --with-libiconv=${LOCALBASE}
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|-liconv|${ICONV_LIB}|' \
${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/japanese/chasen-base/Makefile b/japanese/chasen-base/Makefile
index 5227d1f28aff..6314ec929f07 100644
--- a/japanese/chasen-base/Makefile
+++ b/japanese/chasen-base/Makefile
@@ -20,7 +20,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/darts.h:${PORTSDIR}/devel/darts
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-darts=${LOCALBASE}/include --with-libiconv=${LOCALBASE}
+CONFIGURE_ARGS= --with-darts=${LOCALBASE}/include ${ICONV_CONFIGURE_BASE}
USES= iconv
USE_LDCONFIG= yes
diff --git a/mail/gmime2/Makefile b/mail/gmime2/Makefile
index 9eb1b57db2ec..c720f1bb891e 100644
--- a/mail/gmime2/Makefile
+++ b/mail/gmime2/Makefile
@@ -22,7 +22,7 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
# www.freebsd.org/cgi/query-pr.cgi?pr=118092
# Rename uudecode and uuencode to gmime-* to not conflict with userland
-CONFIGURE_ARGS?= --with-libiconv=${LOCALBASE} \
+CONFIGURE_ARGS?= ${ICONV_CONFIGURE_BASE} \
--with-html-dir=${PREFIX}/share/doc \
--enable-mono=no \
--program-transform-name="s/uuencode/gmime-uuencode/;s/uudecode/gmime-uudecode/;"
diff --git a/net/netatalk/Makefile b/net/netatalk/Makefile
index 4997ce4b4db6..85e04c8079ea 100644
--- a/net/netatalk/Makefile
+++ b/net/netatalk/Makefile
@@ -21,6 +21,7 @@ USE_RC_SUBR= netatalk
CONFIGURE_ARGS+= --with-tcp-wrappers \
--with-pkgconfdir=${PREFIX}/etc \
+ ${ICONV_CONFIGURE_BASE} \
--with-libgcrypt-dir=${LOCALBASE} \
--with-uams-path=${PREFIX}/libexec/netatalk-uams \
--with-bdb=${LOCALBASE}
@@ -119,12 +120,6 @@ CONFIGURE_ARGS+= --enable-sendfile
CONFIGURE_ARGS+= --disable-sendfile
.endif
-.include <bsd.port.pre.mk>
-
-.if !empty(ICONV_LIB)
-CONFIGURE_ARGS+= --with-libiconv=${LOCALBASE}
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|%%DB_NAME%%|${BDB_INCLUDE_DIR:T}| ; \
s|%%DB_LIB%%|-l${BDB_LIB_NAME}|g ; \
@@ -146,4 +141,4 @@ post-install:
.endfor
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/netatalk3/Makefile b/net/netatalk3/Makefile
index eece000a2f69..a2252901e495 100644
--- a/net/netatalk3/Makefile
+++ b/net/netatalk3/Makefile
@@ -27,6 +27,7 @@ CONFIGURE_ARGS+= --enable-tcp-wrappers \
--with-libgcrypt-dir=${LOCALBASE} \
--with-uams-path=${PREFIX}/libexec/netatalk-uams \
--with-bdb=${LOCALBASE} \
+ ${ICONV_CONFIGURE_BASE} \
--localstatedir=/var \
--disable-bundled-libevent \
--with-libevent-header=${LOCALBASE}/include \
@@ -116,12 +117,6 @@ PLIST_SUB+= ATFUNCS="@comment "
PLIST_SUB+= ATFUNCS=""
.endif
-.include <bsd.port.pre.mk>
-
-.if !empty(ICONV_LIB)
-CONFIGURE_ARGS+= --with-libiconv=${LOCALBASE}
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|%%DB_NAME%%|${BDB_INCLUDE_DIR:T}| ; \
s|%%DB_LIB%%|-l${BDB_LIB_NAME}|g ; \
@@ -137,4 +132,4 @@ post-install:
${INSTALL_DATA} -c ${PREFIX}/etc/extmap.conf.dist ${PREFIX}/etc/extmap.conf
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/samba36/Makefile b/net/samba36/Makefile
index 86bc05593943..595cf99c3d63 100644
--- a/net/samba36/Makefile
+++ b/net/samba36/Makefile
@@ -95,7 +95,7 @@ BUILD_DEPENDS+= tevent>=0.9.11:${PORTSDIR}/devel/tevent
RUN_DEPENDS+= tevent>=0.9.11:${PORTSDIR}/devel/tevent
CONFIGURE_ARGS+= --without-libtevent --enable-external-libtevent
# These options are common for all (sub)ports
-CONFIGURE_ARGS+= --with-libiconv="${LOCALBASE}" \
+CONFIGURE_ARGS+= ${ICONV_CONFIGURE_BASE} \
--disable-as-needed
.if !defined(SAMBA_SUBPORT)
diff --git a/net/samba4/Makefile b/net/samba4/Makefile
index ba9fb279bc8e..a83277ccdcc9 100644
--- a/net/samba4/Makefile
+++ b/net/samba4/Makefile
@@ -159,7 +159,7 @@ CONFIGURE_ARGS+= \
--with-iconv \
--with-sendfile-support \
--builtin-libraries=smbclient \
- --with-libiconv="${LOCALBASE}" \
+ ${ICONV_CONFIGURE_BASE} \
--with-gettext="${LOCALBASE}"
# for libexecinfo: (so that __builtin_frame_address() finds the top of the stack)
diff --git a/net/samba4wins/Makefile b/net/samba4wins/Makefile
index 804b758c43bb..cab0e50fd753 100644
--- a/net/samba4wins/Makefile
+++ b/net/samba4wins/Makefile
@@ -43,7 +43,7 @@ CONFIGURE_ARGS+= --exec-prefix=${PREFIX} \
CONFIGURE_ARGS+= --disable-reg-gconf --disable-socket-wrapper \
--with-readline=/usr --with-included-popt \
- --with-libiconv=${LOCALBASE} --without-sqlite3 \
+ ${ICONV_CONFIGURE_BASE} --without-sqlite3 \
--without-pthreads --without-python
USE_RC_SUBR= smbd4wins
diff --git a/palm/pilot-link/Makefile b/palm/pilot-link/Makefile
index 9e6b8477816b..5095a119e2e4 100644
--- a/palm/pilot-link/Makefile
+++ b/palm/pilot-link/Makefile
@@ -17,7 +17,7 @@ USES= pathfix pkgconfig iconv
USE_BZIP2= yes
GNU_CONFIGURE= yes
CFLAGS+= -I${WRKSRC}/popt -I${LOCALBASE}/include
-CONFIGURE_ARGS+=--with-libiconv=${LOCALBASE} --with-included-popt --enable-conduits --enable-xsltproc
+CONFIGURE_ARGS+=${ICONV_CONFIGURE_BASE} --with-included-popt --enable-conduits --enable-xsltproc
USE_LDCONFIG= yes
OPTIONS_DEFINE= PNG THREADS USB
diff --git a/palm/synce-librapi2/Makefile b/palm/synce-librapi2/Makefile
index 26fa61905cdd..0dade463a536 100644
--- a/palm/synce-librapi2/Makefile
+++ b/palm/synce-librapi2/Makefile
@@ -21,8 +21,7 @@ GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool
USES= pathfix iconv pkgconfig
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --with-libiconv="${LOCALBASE}" \
- --with-libsynce="${LOCALBASE}"
+CONFIGURE_ARGS= ${ICONV_CONFIGURE_BASE} --with-libsynce="${LOCALBASE}"
.include <bsd.port.pre.mk>
diff --git a/palm/synce-vdccm/Makefile b/palm/synce-vdccm/Makefile
index 4bc3bcc18ba7..fea3754098e0 100644
--- a/palm/synce-vdccm/Makefile
+++ b/palm/synce-vdccm/Makefile
@@ -20,7 +20,7 @@ DESKTOP_DESC= Desktop integration
GNU_CONFIGURE= yes
WANT_GNOME= yes
USES= iconv pkgconfig
-CONFIGURE_ARGS= --with-libiconv=${LOCALBASE} \
+CONFIGURE_ARGS= ${ICONV_CONFIGURE_BASE} \
--with-libsynce=${LOCALBASE}
MAN1= triggerconnection.1 ${PORTNAME}.1
diff --git a/www/dansguardian-devel/Makefile b/www/dansguardian-devel/Makefile
index 44458aa9f065..50d74a59ccef 100644
--- a/www/dansguardian-devel/Makefile
+++ b/www/dansguardian-devel/Makefile
@@ -23,7 +23,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var \
--with-logdir=/var/log \
--with-piddir=/var/run \
- --with-libiconv=${LOCALBASE} \
+ ${ICONV_CONFIGURE_BASE} \
--enable-fancydm
MAN8= dansguardian.8
@@ -96,7 +96,7 @@ PLIST_SUB+= SCANNERS="@comment "
.endif
.if ${PORT_OPTIONS:MNTLM}
-CONFIGURE_ARGS+= --enable-ntlm --with-libiconv=${LOCALBASE}
+CONFIGURE_ARGS+= --enable-ntlm ${ICONV_CONFIGURE_BASE}
USES+= iconv
PLIST_SUB+= NTLMCONF=""
.else
diff --git a/www/dansguardian/Makefile b/www/dansguardian/Makefile
index 6d451cb16d15..76589ef57b92 100644
--- a/www/dansguardian/Makefile
+++ b/www/dansguardian/Makefile
@@ -23,7 +23,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var \
--with-logdir=/var/log \
--with-piddir=/var/run \
- --with-libiconv=${LOCALBASE} \
+ ${ICONV_CONFIGURE_BASE} \
--enable-fancydm
MAN8= dansguardian.8
@@ -96,7 +96,7 @@ PLIST_SUB+= SCANNERS="@comment "
.endif
.if ${PORT_OPTIONS:MNTLM}
-CONFIGURE_ARGS+= --enable-ntlm --with-libiconv=${LOCALBASE}
+CONFIGURE_ARGS+= --enable-ntlm ${ICONV_CONFIGURE_BASE}
USES+= iconv
PLIST_SUB+= NTLMCONF=""
.else