aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-05-27 23:33:43 +0800
committerlinimon <linimon@FreeBSD.org>2017-05-27 23:33:43 +0800
commitd503867e5ad7b55ae5c95905ce34cbb6a3afcbb7 (patch)
tree22acc2e90158c53739d59d3a842854e86c477307
parenta9f045f0c19175998a59c5ba4afa6c319df430a3 (diff)
downloadfreebsd-ports-gnome-d503867e5ad7b55ae5c95905ce34cbb6a3afcbb7.tar.gz
freebsd-ports-gnome-d503867e5ad7b55ae5c95905ce34cbb6a3afcbb7.tar.zst
freebsd-ports-gnome-d503867e5ad7b55ae5c95905ce34cbb6a3afcbb7.zip
Mark some ports failing on armv6: implicit declaration of function
'cp15_pmccntr_get' is invalid in C99. While here, pet portlint. Approved by: portmgr (tier-2 blanket)
-rw-r--r--comms/uartlirc/Makefile5
-rw-r--r--multimedia/cuse4bsd-kmod/Makefile1
-rw-r--r--net/aoe/Makefile10
-rw-r--r--net/intel-em-kmod/Makefile6
-rw-r--r--sysutils/mbgtools/Makefile11
-rw-r--r--sysutils/pefs-kmod/Makefile8
6 files changed, 22 insertions, 19 deletions
diff --git a/comms/uartlirc/Makefile b/comms/uartlirc/Makefile
index 2c722336d37f..c1ff65b8d2d5 100644
--- a/comms/uartlirc/Makefile
+++ b/comms/uartlirc/Makefile
@@ -13,8 +13,9 @@ EXTRACT_SUFX= .shar
MAINTAINER= ports@FreeBSD.org
COMMENT= Driver for "homebrew" serial LIRC receivers
-BROKEN_powerpc64= Does not build: error: uart.h: No such file or directory
-BROKEN_sparc64= Does not build
+BROKEN_armv6= fails to compile: implicit declaration of function 'cp15_pmccntr_get' is invalid in C99
+BROKEN_powerpc64= fails to compile: uart.h: No such file or directory
+BROKEN_sparc64= fails to build
USES= kmod
diff --git a/multimedia/cuse4bsd-kmod/Makefile b/multimedia/cuse4bsd-kmod/Makefile
index 6032600ff2be..5ed327210c38 100644
--- a/multimedia/cuse4bsd-kmod/Makefile
+++ b/multimedia/cuse4bsd-kmod/Makefile
@@ -11,6 +11,7 @@ COMMENT= Cuse4BSD character device loopback driver for userspace
CONFLICTS= video4bsd-kmod*
+BROKEN_armv6= fails to compile: implicit declaration of function 'cp15_pmccntr_get' is invalid in C99
BROKEN_powerpc64= fails to compile: pcpu.h: error: size of array '__assert_0' is negative
KMODNAME= cuse4bsd
diff --git a/net/aoe/Makefile b/net/aoe/Makefile
index d71523c0afbf..a0d02a708e94 100644
--- a/net/aoe/Makefile
+++ b/net/aoe/Makefile
@@ -11,6 +11,11 @@ DISTNAME= ${PORTNAME}-freebsd-${PORTVERSION}
MAINTAINER= fjoe@FreeBSD.org
COMMENT= FreeBSD driver for ATA over Ethernet (AoE)
+BROKEN_aarch64= fails to compile: redefinition of frame
+BROKEN_armv6= fails to compile: implicit declaration of function 'cp15_pmccntr_get' is invalid in C99
+BROKEN_powerpc64= fails to compile: pcpu.h: size of array '__assert_0' is negative
+BROKEN_sparc64= fails to compile: redefinition of frame
+
USES= kmod
WRKSRC= ${WRKDIR}/dev/aoe
@@ -18,11 +23,6 @@ KMODDIR= ${PREFIX}/lib/aoe
USE_RC_SUBR= aoe
-BROKEN_aarch64= fails to compile: error: redefinition of frame
-BROKEN_armv6= fails to compile: error: redefinition of frame
-BROKEN_powerpc64= fails to compile: pcpu.h: size of array '__assert_0' is negative
-BROKEN_sparc64= fails to compile: error: redefinition of frame
-
do-install:
${INSTALL_KLD} ${WRKSRC}/aoe.ko ${STAGEDIR}${PREFIX}/lib/aoe
${INSTALL_MAN} ${WRKDIR}/aoe.4 ${STAGEDIR}${PREFIX}/man/man4/
diff --git a/net/intel-em-kmod/Makefile b/net/intel-em-kmod/Makefile
index fa65f50e1bbf..62c7ba7bdb3a 100644
--- a/net/intel-em-kmod/Makefile
+++ b/net/intel-em-kmod/Makefile
@@ -8,11 +8,11 @@ MASTER_SITE_SUBDIR= 17509/eng
MAINTAINER= franco@opnsense.org
COMMENT= Gigabit FreeBSD Base Drivers for Intel(R) Ethernet
+BROKEN_armv6= fails to compile: implicit declaration of function 'cp15_pmccntr_get' is invalid in C99
+BROKEN_powerpc64= fails to compile: pcpu.h: size of array '__assert_0' is negative
+
MASTERDIR= ${.CURDIR}/../intel-ixl-kmod
PKGDIR= ${.CURDIR}
DISTINFO_FILE= ${.CURDIR}/distinfo
-BROKEN_armv6= fails to compile: implicit declaration of function 'cp15_pmccntr_get' is invalid in C99
-BROKEN_powerpc64= fails to compile: pcpu.h: size of array '__assert_0' is negative
-
.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/mbgtools/Makefile b/sysutils/mbgtools/Makefile
index 0175badc201f..ca6c6d38aab4 100644
--- a/sysutils/mbgtools/Makefile
+++ b/sysutils/mbgtools/Makefile
@@ -11,13 +11,14 @@ COMMENT= Drivers and tools for Meinberg PTP/GPS cards
LICENSE= BSD
+BROKEN_aarch64= fails to compile: unused variables
+BROKEN_armv6= fails to compile: implicit declaration of function 'cp15_pmccntr_get' is invalid in C99
+BROKEN_mips64= fails to compile: unused variables
+BROKEN_powerpc64= fails to compile: warning: mbg_dbg_data defined but not used
+BROKEN_sparc64= fails to compile: error in structure definitions
+
USE_RC_SUBR= mbgsvcd
USES= kmod uidfix
-BROKEN_aarch64= cannot compile: unused variables
-BROKEN_mips64= cannot compile: unused variables
-BROKEN_powerpc64= cannot compile: warning: mbg_dbg_data defined but not used
-BROKEN_sparc64= cannot compile: error in structure definitions
-
.include <bsd.port.mk>
diff --git a/sysutils/pefs-kmod/Makefile b/sysutils/pefs-kmod/Makefile
index 7da33e54d40f..b0fc496dc1ba 100644
--- a/sysutils/pefs-kmod/Makefile
+++ b/sysutils/pefs-kmod/Makefile
@@ -16,10 +16,10 @@ MAKE_JOBS_UNSAFE=yes
MAKE_ENV= BINDIR="${PREFIX}/sbin" MANDIR="${MANPREFIX}/man/man" \
NO_MANCOMPRESS=
-ONLY_FOR_ARCHS= i386 amd64 armv6
-ONLY_FOR_ARCHS_REASON= untested on any other arch
-
-BROKEN_DragonFly= does not build: don't know how to make vnode_if.h
+BROKEN_armv6= fails to compile: implicit declaration of function 'cp15_pmccntr_get' is invalid in C99
+BROKEN_DragonFly= fails to build: don't know how to make vnode_if.h
+ONLY_FOR_ARCHS= i386 amd64 armv6
+ONLY_FOR_ARCHS_REASON= untested on any other arch
USES= kmod uidfix