aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2014-06-18 03:19:53 +0800
committermva <mva@FreeBSD.org>2014-06-18 03:19:53 +0800
commitd51a5943da51ca32accedfba7400c7b40effceb6 (patch)
tree9955385bffd9efcccd4b050cc043413199ef7771
parent70376ab1eedd0a640c2fa16a3ce96ba6309746ab (diff)
downloadfreebsd-ports-gnome-d51a5943da51ca32accedfba7400c7b40effceb6.tar.gz
freebsd-ports-gnome-d51a5943da51ca32accedfba7400c7b40effceb6.tar.zst
freebsd-ports-gnome-d51a5943da51ca32accedfba7400c7b40effceb6.zip
- Add a trac/plugin.mk to allow plugins to use the same build and installation
environment in order to avoid polluting non-stage directories on build and installation www/trac-wikitopdf: - Remove easy_install dependency Convert to PYDISTUTILS_AUTOPLIST - Bump PORTREVISION to enforce a cleanup for the easy_install references With hat: python@ Approved by: portmgr (implicit) Thanks to: bdrewery@
-rw-r--r--www/trac-wikitopdf/Makefile12
-rw-r--r--www/trac/plugin.mk6
2 files changed, 12 insertions, 6 deletions
diff --git a/www/trac-wikitopdf/Makefile b/www/trac-wikitopdf/Makefile
index 8ad1eb29644f..97decc3b9f8b 100644
--- a/www/trac-wikitopdf/Makefile
+++ b/www/trac-wikitopdf/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD$
-PORTNAME= ${PYDISTUTILS_PKGNAME:S;^Trac;;S;Plugin$;;:tl}
+PORTNAME= wikitopdf
PORTVERSION= 2.2.2
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www devel python
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= brooks
@@ -15,10 +15,10 @@ COMMENT= Plugin to generate PDF documents from the Wiki
RUN_DEPENDS+= htmldoc:${PORTSDIR}/textproc/htmldoc \
tracd:${PORTSDIR}/www/trac
-USE_PYTHON= 2
-USE_PYDISTUTILS= easy_install
-PYDISTUTILS_PKGNAME= TracWikiToPdfPlugin
-PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+USE_PYTHON= 2
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
WRKSRC= ${WRKDIR}/${PORTNAME}plugin
+.include "${.CURDIR}/../../www/trac/plugin.mk"
.include <bsd.port.mk>
diff --git a/www/trac/plugin.mk b/www/trac/plugin.mk
new file mode 100644
index 000000000000..c60c45462562
--- /dev/null
+++ b/www/trac/plugin.mk
@@ -0,0 +1,6 @@
+# needed to avoid polluting /root with .subversion/ leftovers,
+# which will cause package builders to complain on staging.
+#
+# www/trac issues some svn command on installing certain plugins,
+# if it was built with the SVN option enabled
+MAKE_ENV+= HOME=/dev/null