aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2004-03-22 21:32:40 +0800
committerarved <arved@FreeBSD.org>2004-03-22 21:32:40 +0800
commitd5b28fe07b892596135a69e5165e9f9abbec7876 (patch)
treeb83f4322b73d3f2333a6aa30bf7834ba4886d959
parent54aeca30d09a801ba813a3321affc688b35e8526 (diff)
downloadfreebsd-ports-gnome-d5b28fe07b892596135a69e5165e9f9abbec7876.tar.gz
freebsd-ports-gnome-d5b28fe07b892596135a69e5165e9f9abbec7876.tar.zst
freebsd-ports-gnome-d5b28fe07b892596135a69e5165e9f9abbec7876.zip
Only the shared library needs to be built with -fPIC
-rw-r--r--editors/led/Makefile4
-rw-r--r--editors/led/files/patch-src-modules-perlapi-Makefile11
2 files changed, 11 insertions, 4 deletions
diff --git a/editors/led/Makefile b/editors/led/Makefile
index 52b88653c417..bb7a2249ab1d 100644
--- a/editors/led/Makefile
+++ b/editors/led/Makefile
@@ -17,8 +17,4 @@ COMMENT= A tiny text editor, with a number of useful programming features
GNU_CONFIGURE= yes
USE_PERL5= yes
-.if ${MACHINE_ARCH:L} == "amd64"
-CFLAGS+= "-fPIC"
-.endif
-
.include <bsd.port.mk>
diff --git a/editors/led/files/patch-src-modules-perlapi-Makefile b/editors/led/files/patch-src-modules-perlapi-Makefile
new file mode 100644
index 000000000000..c3e4cc52bb53
--- /dev/null
+++ b/editors/led/files/patch-src-modules-perlapi-Makefile
@@ -0,0 +1,11 @@
+--- src/modules/perlapi/Makefile.orig Mon Mar 22 14:29:51 2004
++++ src/modules/perlapi/Makefile Mon Mar 22 14:29:59 2004
+@@ -8,7 +8,7 @@
+
+ include ../Makefile.module
+
+-CFLAGS+= `perl -MExtUtils::Embed -e ccopts`
++CFLAGS+= `perl -MExtUtils::Embed -e ccopts` -fPIC
+ XSUBPPDIR= `perl -MConfig -e 'print $$Config{privlib}'`/ExtUtils
+ XSUBPP= $(XSUBPPDIR)/xsubpp
+