aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2008-05-20 04:46:13 +0800
committersat <sat@FreeBSD.org>2008-05-20 04:46:13 +0800
commitd684a701428d9f399de30b2107c941f2f1cff4de (patch)
tree94570c265e145fd877f908ec8d9e90fc671e780d
parentc1943d3d997cada1cfabb023fe0a3ac2d628a9db (diff)
downloadfreebsd-ports-gnome-d684a701428d9f399de30b2107c941f2f1cff4de.tar.gz
freebsd-ports-gnome-d684a701428d9f399de30b2107c941f2f1cff4de.tar.zst
freebsd-ports-gnome-d684a701428d9f399de30b2107c941f2f1cff4de.zip
Add a couple of new xpi extensions,
- www/xpi-new-diggler - URL-related actions through menu button - www/xpi-speed-dial - Access websites through custom thumbnail views PR: ports/123641, ports/123642 (with corrections) Submitted by: Harald Schmalzbauer <harry@omnisec.de>
-rw-r--r--www/Makefile2
-rw-r--r--www/xpi-neo-diggler/Makefile24
-rw-r--r--www/xpi-neo-diggler/distinfo3
-rw-r--r--www/xpi-neo-diggler/pkg-descr12
-rw-r--r--www/xpi-speed-dial/Makefile25
-rw-r--r--www/xpi-speed-dial/distinfo3
-rw-r--r--www/xpi-speed-dial/pkg-descr16
-rw-r--r--www/xpi-speed-dial/pkg-plist10
8 files changed, 95 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 57f4b47480c6..ddf99c7c5432 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1456,6 +1456,7 @@
SUBDIR += xpi-mousegestures
SUBDIR += xpi-mozex
SUBDIR += xpi-mrtech-local-install
+ SUBDIR += xpi-neo-diggler
SUBDIR += xpi-no-referrer
SUBDIR += xpi-noscript
SUBDIR += xpi-num2web
@@ -1470,6 +1471,7 @@
SUBDIR += xpi-searchstatus
SUBDIR += xpi-server_switcher
SUBDIR += xpi-sessionmanager
+ SUBDIR += xpi-speed-dial
SUBDIR += xpi-statusbarclock
SUBDIR += xpi-stumbleupon
SUBDIR += xpi-stylish
diff --git a/www/xpi-neo-diggler/Makefile b/www/xpi-neo-diggler/Makefile
new file mode 100644
index 000000000000..f69881363609
--- /dev/null
+++ b/www/xpi-neo-diggler/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: xpi-neo-diggler
+# Date created: 12 May 2008
+# Whom: Harald Schmalzbauer <h.schmalzbauer@omnisec.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= neo-diggler
+PORTVERSION= 1.0.5
+DISTVERSIONSUFFIX= -fx
+CATEGORIES= www
+
+MAINTAINER= h.schmalzbauer@omnisec.de
+COMMENT= URL-related actions through menu button
+
+XPI_DISTNAME= neo_diggler
+XPI_ID= {9b84cce7-a817-45d7-865e-9e6e8da1c388}
+XPI_NUM= 3763
+XPI_FILES= chrome.manifest install.rdf \
+ chrome/diggler.jar defaults/preferences/diggler.js
+XPI_DIRS= chrome defaults/preferences defaults
+
+.include "${.CURDIR}/../xpi-adblock/Makefile.xpi"
+.include <bsd.port.mk>
diff --git a/www/xpi-neo-diggler/distinfo b/www/xpi-neo-diggler/distinfo
new file mode 100644
index 000000000000..a6e280dbcf8e
--- /dev/null
+++ b/www/xpi-neo-diggler/distinfo
@@ -0,0 +1,3 @@
+MD5 (xpi/neo_diggler-1.0.5-fx.xpi) = 351cf7f5c4699a0e226e82cdb2a63580
+SHA256 (xpi/neo_diggler-1.0.5-fx.xpi) = 385ed76990775eac9800b294dad6c28303dca3a366fb6e912bd725171fee0aea
+SIZE (xpi/neo_diggler-1.0.5-fx.xpi) = 42045
diff --git a/www/xpi-neo-diggler/pkg-descr b/www/xpi-neo-diggler/pkg-descr
new file mode 100644
index 000000000000..032c2cc37423
--- /dev/null
+++ b/www/xpi-neo-diggler/pkg-descr
@@ -0,0 +1,12 @@
+This extension adds a menu button next to the address bar with actions
+relevant to the current URL. The button's menu allows you navigate up
+through the current URL's parents, to visit the equivalent ftp URL, or
+to visit the site in archive.org. A single click on the menu button
+also easily clears the location bar (much like the one in Konqueror) -
+useful for keyboard free browsing.
+
+It also has a few security control tick-boxes (popups, tabbing,
+images) and the ability to add custom URL conversions/manipulations.
+
+WWW: https://addons.mozilla.org/en-US/firefox/addon/3763
+Author: Neil Bird <mozilla@fnxweb.com>
diff --git a/www/xpi-speed-dial/Makefile b/www/xpi-speed-dial/Makefile
new file mode 100644
index 000000000000..7e84e0c01270
--- /dev/null
+++ b/www/xpi-speed-dial/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: xpi-speed-dial
+# Date created: 12 May 2008
+# Whom: Harald Schmalzbauer <h.schmalzbauer@omnisec.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= speed-dial
+PORTVERSION= 0.7.0.8
+DISTVERSIONSUFFIX= -fx
+CATEGORIES= www
+
+MAINTAINER= h.schmalzbauer@omnisec.de
+COMMENT= Access websites through custom thumbnail views
+
+XPI_DISTNAME= speed_dial
+XPI_ID= {64161300-e22b-11db-8314-0800200c9a66}
+XPI_NUM= 4810
+
+post-patch:
+ @${REINPLACE_CMD} -i "" -e '/loadInNewTab/s|false|true|' \
+ ${WRKSRC}/defaults/preferences/speeddial.js
+
+.include "${.CURDIR}/../xpi-adblock/Makefile.xpi"
+.include <bsd.port.mk>
diff --git a/www/xpi-speed-dial/distinfo b/www/xpi-speed-dial/distinfo
new file mode 100644
index 000000000000..c58f46206922
--- /dev/null
+++ b/www/xpi-speed-dial/distinfo
@@ -0,0 +1,3 @@
+MD5 (xpi/speed_dial-0.7.0.8-fx.xpi) = 7a571a07be1244cf4a68eefa4902d852
+SHA256 (xpi/speed_dial-0.7.0.8-fx.xpi) = 688ae319077df300a07f08d2f975f85ef19bc51aef0539260375625d3bb32a3c
+SIZE (xpi/speed_dial-0.7.0.8-fx.xpi) = 156959
diff --git a/www/xpi-speed-dial/pkg-descr b/www/xpi-speed-dial/pkg-descr
new file mode 100644
index 000000000000..ffd6cb5caa84
--- /dev/null
+++ b/www/xpi-speed-dial/pkg-descr
@@ -0,0 +1,16 @@
+With Speed Dial, you can easily access your most used websites. To
+show the Speed Dial tab, use the Speed Dial button (which can be added
+to the toolbar), or enter "chrome://speeddial/content" in your
+location bar.
+
+Speed Dial will be automatically loaded in blank new windows. It can
+also load in blank new tabs. To configure this, and other options, use
+the extension settings panel.
+
+To assign one website to Speed Dial, use the new "Set as Speed Dial"
+option in the bookmarks menu, or right click on the tab you want to
+add, and choose "Set as Speed Dial". That option is also available in
+the contextual area menu.
+
+WWW: http://speeddial.uworks.net/
+Author: Josep del Rio <josep.rio@uworks.net>
diff --git a/www/xpi-speed-dial/pkg-plist b/www/xpi-speed-dial/pkg-plist
new file mode 100644
index 000000000000..a7c8a6ade6ce
--- /dev/null
+++ b/www/xpi-speed-dial/pkg-plist
@@ -0,0 +1,10 @@
+%%XPI_XPIDIR%%/LICENSE
+%%XPI_XPIDIR%%/chrome/speeddial.jar
+%%XPI_XPIDIR%%/chrome.manifest
+%%XPI_XPIDIR%%/components/speeddialcache.js
+%%XPI_XPIDIR%%/defaults/preferences/speeddial.js
+%%XPI_XPIDIR%%/install.rdf
+@dirrm %%XPI_XPIDIR%%/chrome
+@dirrm %%XPI_XPIDIR%%/components
+@dirrm %%XPI_XPIDIR%%/defaults/preferences
+@dirrm %%XPI_XPIDIR%%/defaults