aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2013-07-22 05:42:59 +0800
committermarino <marino@FreeBSD.org>2013-07-22 05:42:59 +0800
commitd76a2056b080c1d33c3755846ee9c632852b8db5 (patch)
tree01539fd8edf6435f7a308cbcea712de20f994218
parent271655302938b4ae144e5d19b9a9dc292842ece7 (diff)
downloadfreebsd-ports-gnome-d76a2056b080c1d33c3755846ee9c632852b8db5.tar.gz
freebsd-ports-gnome-d76a2056b080c1d33c3755846ee9c632852b8db5.tar.zst
freebsd-ports-gnome-d76a2056b080c1d33c3755846ee9c632852b8db5.zip
net-mgmt/macroscope: unbreak
The initial problem was that the default database support was MySQL 5.0 which has been removed. Upon inspection of the source, it appears that it could be hardcoded for MySQL 5.0.33. At this point, I commented out the MySQL option and changed the default to Firebird version 2.0. According to Redports, the port built on i386 but was broken on amd64. The specified version of Firebird was changed to 2.5 and now the port builds on both i386 and amd64. The unnecessary inclusion of bsd.database.mk was also removed and the redundant option descriptions were also removed. The maintainer should investigate Macroscope builds with current versions of MySQL and restore the option appropriately if it does. PR: ports/179708 Submitted by: marino Approved by: bapt (mentor), maintainer timeout (>4 weeks)
-rw-r--r--net-mgmt/macroscope/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/net-mgmt/macroscope/Makefile b/net-mgmt/macroscope/Makefile
index ed3cff99939e..c55d5f543ddd 100644
--- a/net-mgmt/macroscope/Makefile
+++ b/net-mgmt/macroscope/Makefile
@@ -21,10 +21,8 @@ USE_BZIP2= yes
USE_DOS2UNIX= yes
USES= cmake
-OPTIONS_DEFINE= MYSQL FIREBIRD DOCS
-MYSQL_DESC= With MySQL support
-FIREBIRD_DESC= With Firebird support
-OPTIONS_DEFAULT= MYSQL
+OPTIONS_DEFINE= FIREBIRD DOCS #MYSQL
+OPTIONS_DEFAULT= FIREBIRD
.include <bsd.port.pre.mk>
@@ -32,18 +30,19 @@ OPTIONS_DEFAULT= MYSQL
CMAKE_ARGS+= -DCMAKE_NOT_INSTALL_DOC:BOOL=ON
.endif
-.if ${PORT_OPTIONS:MMYSQL}
-WANT_MYSQL_VER= 50
-USE_MYSQL= yes
-.endif
+# ${WRKSRC}/include/adicpp/myapi appears to be hardcoded for MySQL 5.0
+# Disable option completely until support for later versions added
+# Firebird 2.0 support doesn't build on amd64, so version 2.5 is required
+#.if ${PORT_OPTIONS:MMYSQL}
+#WANT_MYSQL_VER= 50
+#USE_MYSQL= yes
+#.endif
.if ${PORT_OPTIONS:MFIREBIRD}
-WITH_FIREBIRD_VER= 2
+WITH_FIREBIRD_VER= 25
USE_FIREBIRD= yes
.endif
-.include "${PORTSDIR}/Mk/bsd.database.mk"
-
.if ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
BROKEN= Does not compile on this architecture
.endif