aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordhn <dhn@FreeBSD.org>2009-03-21 21:14:28 +0800
committerdhn <dhn@FreeBSD.org>2009-03-21 21:14:28 +0800
commitd9c54b3ae49d9dfe02cae2a902c634271c7caf3c (patch)
tree3a299e2dc59e685940fc5d9991531d98a5b5bb1c
parent9f635985d9653f7e02c176064256bf6d3e05bc84 (diff)
downloadfreebsd-ports-gnome-d9c54b3ae49d9dfe02cae2a902c634271c7caf3c.tar.gz
freebsd-ports-gnome-d9c54b3ae49d9dfe02cae2a902c634271c7caf3c.tar.zst
freebsd-ports-gnome-d9c54b3ae49d9dfe02cae2a902c634271c7caf3c.zip
- Add vpopmail support
- Pass maintainership to submitter - Bump PORTREVISION PR: ports/132727 Submitted by: Alex Povolotsky <tarkhil@over.ru> Approved by: miwi (mentor)
-rw-r--r--security/cvm/Makefile19
-rw-r--r--security/cvm/files/patch-Makefile15
-rw-r--r--security/cvm/pkg-plist1
3 files changed, 33 insertions, 2 deletions
diff --git a/security/cvm/Makefile b/security/cvm/Makefile
index 809d07bdf3ef..6cbd4a626ffe 100644
--- a/security/cvm/Makefile
+++ b/security/cvm/Makefile
@@ -7,11 +7,12 @@
PORTNAME= cvm
PORTVERSION= 0.95
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://untroubled.org/${PORTNAME}/ \
http://untroubled.org/${PORTNAME}/archive/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= tarkhil@over.ru
COMMENT= Credential Validation Modules
LIB_DEPENDS= bg.2:${PORTSDIR}/devel/bglibs
@@ -27,6 +28,20 @@ BGLIBS_LIB= ${LOCALBASE}/lib/bglibs
DOCS= NEWS README TODO *.html
+OPTIONS= VCHKPW "Compile cvm-vchkpw" off
+
+.include <bsd.port.pre.mk>
+
+ALL_TARGET=all
+
+.if defined(WITH_VCHKPW)
+BUILD_DEPENDS+= ${LOCALBASE}/vpopmail/lib/libvpopmail.a:${PORTSDIR}/mail/vpopmail
+ALL_TARGET+= cvm-vchkpw
+PLIST_SUB= VCHKPW=""
+.else
+PLIST_SUB= VCHKPW="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|libtool|${LIBTOOL}|g' ${WRKSRC}/Makefile
@@ -46,4 +61,4 @@ post-install:
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/cvm/files/patch-Makefile b/security/cvm/files/patch-Makefile
new file mode 100644
index 000000000000..60af115d1b35
--- /dev/null
+++ b/security/cvm/files/patch-Makefile
@@ -0,0 +1,15 @@
+--- ./Makefile.orig 2009-03-17 14:53:54.000000000 +0300
++++ ./Makefile 2009-03-17 14:55:41.000000000 +0300
+@@ -155,10 +155,10 @@
+ ./compile cvm-v1testclient.c
+
+ cvm-vchkpw: cvm-vchkpw.o ltload libcvm-module.la crypt.lib shadow.lib s.lib socket.lib
+- ./ltload cvm-vchkpw libcvm-module.la -L/usr/local/vpopmail/lib -L/var/vpopmail/lib -L/usr/local/lib/mysql -lbg -lvpopmail -lmysqlclient `cat crypt.lib` `cat shadow.lib` `cat s.lib` `cat socket.lib`
++ ./ltload cvm-vchkpw libcvm-module.la `cat /usr/local/vpopmail/etc/lib_deps` -lbg `cat crypt.lib` `cat shadow.lib` `cat s.lib` `cat socket.lib`
+
+ cvm-vchkpw.o: compile cvm-vchkpw.c module.h credentials.h errors.h facts.h
+- ./compile cvm-vchkpw.c
++ ./compile cvm-vchkpw.c `cat /usr/local/vpopmail/etc/inc_deps`
+
+ cvm-vmailmgr: cvm-vmailmgr.o ltload vmautoconvert.o vmlookup.o getpwnam.o libcvm-module.la libcvm-qmail.la socket.lib crypt.lib
+ ./ltload cvm-vmailmgr vmautoconvert.o vmlookup.o getpwnam.o libcvm-module.la libcvm-qmail.la -lbg `cat socket.lib` `cat crypt.lib`
diff --git a/security/cvm/pkg-plist b/security/cvm/pkg-plist
index 30d006d0b91c..d916d94eef28 100644
--- a/security/cvm/pkg-plist
+++ b/security/cvm/pkg-plist
@@ -11,6 +11,7 @@ bin/cvm-v1testclient
bin/cvm-vmailmgr
bin/cvm-vmailmgr-local
bin/cvm-vmailmgr-udp
+%%VCHKPW%%bin/cvm-vchkpw
include/cvm-sasl.h
include/cvm/client.h
include/cvm/credentials.h