aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2012-07-04 05:25:09 +0800
committerthierry <thierry@FreeBSD.org>2012-07-04 05:25:09 +0800
commitdaf5f418029a9b01787c29c9b59cc387f5907cad (patch)
tree1cbefdf6a55e3366691ec17e602927ec3d809a52
parentdcddee0b1ac79d176dbf78fc49ab8c41bc273692 (diff)
downloadfreebsd-ports-gnome-daf5f418029a9b01787c29c9b59cc387f5907cad.tar.gz
freebsd-ports-gnome-daf5f418029a9b01787c29c9b59cc387f5907cad.tar.zst
freebsd-ports-gnome-daf5f418029a9b01787c29c9b59cc387f5907cad.zip
Upgrade to 1.0.
Changelog at <http://code.google.com/p/pinot-search/source/browse/trunk/NEWS>.
-rw-r--r--deskutils/pinot/Makefile22
-rw-r--r--deskutils/pinot/distinfo4
-rw-r--r--deskutils/pinot/pkg-plist37
3 files changed, 32 insertions, 31 deletions
diff --git a/deskutils/pinot/Makefile b/deskutils/pinot/Makefile
index 6fddeca408b0..c96256a31863 100644
--- a/deskutils/pinot/Makefile
+++ b/deskutils/pinot/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pinot
-PORTVERSION= 0.98
-PORTREVISION= 3
+PORTVERSION= 1.0
CATEGORIES= deskutils
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
#MASTER_SITES= http://colinf.chez.com/pinot/
@@ -21,7 +20,7 @@ LICENSE= GPLv2
BUILD_DEPENDS= update-desktop-database:${PORTSDIR}/devel/desktop-file-utils
LIB_DEPENDS= xapian.26:${PORTSDIR}/databases/xapian-core \
gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24 \
- textcat.0:${PORTSDIR}/textproc/libtextcat \
+ exttextcat.0:${PORTSDIR}/textproc/libexttextcat \
dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
xml\\+\\+-2.6:${PORTSDIR}/textproc/libxml++26 \
boost_thread.4:${PORTSDIR}/devel/boost-libs \
@@ -44,10 +43,12 @@ PROJECTHOST= ${PORTNAME}-search
LDFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-http=curl --with-ssl=${OPENSSLBASE} --enable-libarchive
+CONFIGURE_ARGS= --with-http=curl --with-ssl=${OPENSSLBASE} --enable-libarchive \
+ --enable-mempool=no
CONFIGURE_ENV= MKDIR_P="${MKDIR}"
CPPFLAGS+= -I${LOCALBASE}/include
+USE_DOS2UNIX= textcat32_conf.txt
USE_XORG= pixman
USE_GETTEXT= yes
USE_SQLITE= 3
@@ -68,19 +69,14 @@ PLIST_SUB+= CHMLIB="@comment "
INSTALLS_ICONS= yes
-PLIST_SUB+= DESKBAR_MOD="${LDESKBAR_MOD}"
-
MAN1= pinot-dbus-daemon.1 pinot-index.1 pinot-label.1 pinot-search.1 pinot.1
PORTDOCS= AUTHORS ChangeLog ChangeLog-dijon INSTALL NEWS README TODO
-LM2FIX= textcat_conf.txt textcat3_conf.txt textcat31_conf.txt
+LM2FIX= textcat_conf.txt textcat3_conf.txt textcat31_conf.txt textcat32_conf.txt
SHR2FIX= Core/pinot-search.1 README
UL2FIX= Utils/xdgmime/xdgmime.c
-LDESKBAR_MOD= libexec/deskbar-applet/modules-2.20-compatible
-DESKBAR_MOD= ${PREFIX}/${LDESKBAR_MOD}
-
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 700041
@@ -112,12 +108,6 @@ pre-configure:
post-install:
${TOUCH} ${DATADIR}/stopwords/.empty_file
- @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${DESKBAR_MOD}
- @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${DESKBAR_MOD}
- @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py \
- ${PREFIX}/lib/deskbar-applet/handlers
- @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py \
- ${PREFIX}/lib/deskbar-applet/handlers
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
diff --git a/deskutils/pinot/distinfo b/deskutils/pinot/distinfo
index 1952bafcea9b..804dd2ba7b95 100644
--- a/deskutils/pinot/distinfo
+++ b/deskutils/pinot/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pinot-0.98.tar.gz) = 8a89a73a48344074aa8f4534ce68fd18e3d84553645cef864c137ab21d8d341c
-SIZE (pinot-0.98.tar.gz) = 1100996
+SHA256 (pinot-1.0.tar.gz) = d1f5ac17022014c5a29ba1e6d95fc39bcf254338a4e0bfe84bf16558d219e2e2
+SIZE (pinot-1.0.tar.gz) = 1117465
diff --git a/deskutils/pinot/pkg-plist b/deskutils/pinot/pkg-plist
index 2510c448f609..c689c1d612ca 100644
--- a/deskutils/pinot/pkg-plist
+++ b/deskutils/pinot/pkg-plist
@@ -6,17 +6,33 @@ bin/pinot-prefs
bin/pinot-search
etc/pinot/external-filters.xml
etc/pinot/globalconfig.xml
-etc/pinot/textcat3_conf.txt
etc/pinot/textcat31_conf.txt
+etc/pinot/textcat32_conf.txt
+etc/pinot/textcat3_conf.txt
etc/pinot/textcat_conf.txt
etc/xdg/autostart/pinot-dbus-daemon.desktop
-%%DESKBAR_MOD%%/pinot-module.py
-%%DESKBAR_MOD%%/pinot-module.pyc
-%%DESKBAR_MOD%%/pinot-module.pyo
-lib/deskbar-applet/handlers/pinot-live.py
-lib/deskbar-applet/handlers/pinot-live.pyc
-lib/deskbar-applet/handlers/pinot-live.pyo
lib/pinot/backends/libxapianbackend.so
+lib/pinot/backends/libxapianbackend.so.1
+lib/pinot/libBasicUtils.a
+lib/pinot/libBasicUtils.la
+lib/pinot/libCollect.a
+lib/pinot/libCollect.la
+lib/pinot/libCore.a
+lib/pinot/libCore.la
+lib/pinot/libFilter.a
+lib/pinot/libFilter.la
+lib/pinot/libIndex.a
+lib/pinot/libIndex.la
+lib/pinot/libIndexSearch.a
+lib/pinot/libIndexSearch.la
+lib/pinot/libMonitor.a
+lib/pinot/libMonitor.la
+lib/pinot/libSQL.a
+lib/pinot/libSQL.la
+lib/pinot/libTokenize.a
+lib/pinot/libTokenize.la
+lib/pinot/libUtils.a
+lib/pinot/libUtils.la
lib/pinot/filters/libarchivefilter.so
%%CHMLIB%%lib/pinot/filters/libchmfilter.so
lib/pinot/filters/libexiv2imagefilter.so
@@ -47,8 +63,7 @@ share/locale/zh_TW/LC_MESSAGES/pinot.mo
%%DATADIR%%/engines/AmazonAPI.src
%%DATADIR%%/engines/Bing.src
%%DATADIR%%/engines/Clusty.src
-%%DATADIR%%/engines/DuckDuckGo.xml
-%%DATADIR%%/engines/Freshmeat.src
+%%DATADIR%%/engines/Freecode.src
%%DATADIR%%/engines/Google.src
%%DATADIR%%/engines/KodersDescription.xml
%%DATADIR%%/engines/OmegaDescription.xml
@@ -74,10 +89,6 @@ share/locale/zh_TW/LC_MESSAGES/pinot.mo
@dirrm lib/pinot/filters
@dirrm lib/pinot/backends
@dirrm lib/pinot
-@dirrmtry libexec/deskbar-applet/modules-2.20-compatible
-@dirrmtry libexec/deskbar-applet
-@dirrmtry lib/deskbar-applet/handlers
-@dirrmtry lib/deskbar-applet
@dirrmtry etc/xdg/autostart
@dirrmtry etc/xdg
@dirrm etc/pinot
ommit/ftp?h=gstreamer&id=6496a48e3db8f96d35fc6409043426c57f1eda3b'>- Bump portrevisions on all ocaml libraries, as it appears that compiledstas2011-04-061-0/+1 * Garbage collect expired portsrene2011-04-053-42/+0 * - update to 0.17bapt2011-03-252-3/+3 * - update to 0.32bapt2011-03-252-3/+3 * - Add LICENSE knob(s)mm2011-03-231-0/+3 * Update to 4.2.0martymac2011-03-222-3/+3 * - Get Rid MD5 supportmiwi2011-03-1996-109/+0 * - update to 2.6lwhsu2011-03-182-3/+3 * Deprecate unmaintained ports from ftp where upstream disapear and/orbapt2011-03-1610-0/+30 * Add optional dependency to libidnvd2011-03-151-2/+10 * - Bump PORTREVISION to chase the update of dns/libidnwen2011-03-142-2/+4 * - Update to 0.6.0lwhsu2011-03-053-14/+29 * - update to 2.5lwhsu2011-03-054-28/+15 * Add a more reliable mirrors for fc4 and f10 linux emulation ports.ehaupt2011-03-031-0/+1 * Take maintainershipbeech2011-03-031-1/+1 * Return these ports to the pool.linimon2011-03-032-2/+2 * Deprecate all non-default Fedora based linux_base respectively linux-fx-*netchild2011-02-281-0/+3 * - Update to 0.7.12wen2011-02-282-3/+3 * - Kick ftp/junglemoneky to fix the index aftermiwi2011-02-287-109/+0 * - Mark as DEPRECATED and set EXPIRATION_DATE due it's no longer maintained si...araujo2011-02-271-0/+3 * - Reassign ports to heaptabthorpe2011-02-273-3/+3 * Chase after net/openldap24-server update.delphij2011-02-251-0/+1 * Update to version 3.4.1.demon2011-02-222-3/+3 * - update to 2.3.4dinoex2011-02-182-4/+3 * - Update to 4.1.3martymac2011-02-142-13/+10 * - Update to 3.1sylvio2011-02-102-4/+3 * Fix my last commitkevlo2011-02-091-3/+3 * - Update to 0.7.9miwi2011-01-302-4/+3 * Since atftpd uses signals, check for EINTR and continuekevlo2011-01-302-13/+26 * - Update to 2.8.7dhn2011-01-292-19/+13 * Remove NO_SIZE line.mandree2011-01-112-2/+0 * Fix extraction when using clamav option.wxs2011-01-081-1/+0 * Update to 4.1.2martymac2011-01-042-3/+3 * Update to 0.3.7makc2011-01-024-9/+12 * Garbage-collect expired ports:rene2011-01-017-76/+0 * Reset ijliao@FreeBSD.org due to maintainer-timeouts and long absence.linimon2010-12-281-1/+1 * - Update to 1.3.3dmm2010-12-242-4/+3 * Update to version 3.4.demon2010-12-202-3/+3 * Update cURL to 7.21.3 and fix its librtmp detection. In the process:roam2010-12-207-30/+118 * Update to 4.1.1martymac2010-12-092-5/+3 * Drop maintainership and remove MD5 checksumsahil2010-12-052-2/+1 * Sync to new bsd.autotools.mkade2010-12-0413-13/+13 * Net::FTPSSL is a class implementing a simple FTP client over a Securewen2010-12-025-0/+38 * - Revert to old distinfo and SAVE US FROM THE DOOM!mm2010-12-012-3/+3 * - Update distfile to match upstream sourcemm2010-12-012-3/+3 * - Remove PERL_SITELIBDIRsunpoet2010-12-012-5/+3 * Update to version 3.3.3.demon2010-11-292-3/+3 * Use MASTER_SITE_SUBDIR instead of rolling my own.uqs2010-11-261-1/+2 * Fix remaining MASTER_SITE_LOCAL abuses for my ports.uqs2010-11-261-1/+1 * Update to 3.3.5.1.jsa2010-11-252-3/+3 * - Stop removing shared dbus directories that are owned by dbus and kdehierpav2010-11-231-2/+0 * Update to version 3.3.2.demon2010-11-162-5/+4 * Update filezilla to 3.3.5.jsa2010-11-153-4/+15 * - Update mod_sql_tds to 4.13mm2010-11-152-4/+5 * Cleanup MASTER_SITES and since i'm here, remove MD5garga2010-11-122-8/+0 * - Install configuration files as *.sample to avoid overriding existing onessunpoet2010-11-093-7/+11 * - Update to 0.28.culot2010-11-092-9/+7 * Rename old ncftp port to "ncftp1".obrien2010-11-088-101/+2 * - Update to 1.3.3cmm2010-11-053-25/+7 * Remove expired ports:garga2010-11-046-77/+0 * Maintainer change. Returned to beech@beech2010-11-031-1/+1 * Pass maintainership back to Chris Petrik.makc2010-10-312-2/+1 * Mark as deprecated and set expiration date to 2010-12-30 for unmaintainedbapt2010-10-301-0/+2 * - Update to 1.3.3bmm2010-10-292-5/+4 * - Pass maintainership to submitterwen2010-10-271-1/+1 * Upgrade to 1.1.2.thierry2010-10-243-5/+9 * - Mass fixup of WWW: lines pkg-descr based on rubygems.org Homepage meta infopgollucci2010-10-20c5c2df0dfe92f5fe5'>Fix warnings.Dan Winship2000-07-112-3/+8 * Update message_list_select_next to do either next or previous.Dan Winship2000-07-111-1/+8 * Update message_list_select_next to do either next or previous.Dan Winship2000-07-114-35/+58 * Fix an unitialized variable error.Ettore Perazzoli2000-07-112-0/+8 * Get rid of the ESelectNames test menu entry.Ettore Perazzoli2000-07-112-38/+5 * Fix a typbraino in the ETableScrolled header file.Ettore Perazzoli2000-07-113-2/+6 * Fixed broken POP fetchingJeffrey Stedfast2000-07-112-0/+14 * Removed some useless debugging messages.Ettore Perazzoli2000-07-113-2/+7 * Make the wm close button in the message composer work the same asEttore Perazzoli2000-07-112-14/+45 * Add FIXME comment.Ettore Perazzoli2000-07-111-0/+2 * Fix syncing of the mailbox on exit so that it's done on destruction ofEttore Perazzoli2000-07-113-16/+14 * Fix the address entry box for more than one address being specifiedPeter Williams2000-07-102-19/+27 * updated pt_BR translationsJorge Godoy2000-07-101-404/+339 * Switched from ETable to ETableScrolled.Christopher James Lahey2000-07-108-19/+30 * Switched from ETable to ETableScrolled.Christopher James Lahey2000-07-103-13/+18 * Add e-table-scrolled.c and e-table-scrolled.h.Christopher James Lahey2000-07-1014-82/+937 * As a quasi-hack, do a gdk_flush() when the shell view is unrealized soFederico Mena Quintero2000-07-106-2/+41 * Fixed movemail so that it too would deliver to Inbox.Jeffrey Stedfast2000-07-102-38/+31 * Implemented.Jeffrey Stedfast2000-07-106-0/+124 * Removed calendar/gui/evolution-calendar-control.cFederico Mena Quintero2000-07-102-1/+4 * Don't load "" into the editor, because it will cause the editor componentDan Winship2000-07-102-1/+9 * add a "string" typeDan Winship2000-07-109-69/+46 * New function to copy a header_references structure.Dan Winship2000-07-106-81/+145 * Fix a bug in previous commit that could cause infinite loopsDan Winship2000-07-101-3/+1 * Remove unused file - FedericoFederico Mena Quintero2000-07-101-200/+0 * Don't g_warn if the user selects a fake tree parent.Dan Winship2000-07-103-78/+85 * Added a field that gives the name if it exists and the company nameChristopher James Lahey2000-07-107-11/+66 * Put back e_cell_event sometimes when we're not editing.Christopher James Lahey2000-07-103-6/+11 * Don't draw quite as large a "flat_box". If draw_borders is TRUE, cause theChristopher James Lahey2000-07-093-16/+22 * Fixed a small off by one error that was causing an extra character to getChristopher James Lahey2000-07-092-1/+8 * What is 'Refile'? Is it lamer word?Valek Frob2000-07-092-150/+121 * Remove setting of dnd_code since that's handled internally to ETable.Christopher James Lahey2000-07-092-3/+5 * Set the dnd_code to something non-null for the ETableHeaderItem.Christopher James Lahey2000-07-093-0/+7 * Stab at complete German translationMatthias Warkus2000-07-092-207/+3481 * Removed some border padding and set the "draw_borders" argument of theChristopher James Lahey2000-07-097-54/+251 * Set header canvas scroll region correctly.Christopher James Lahey2000-07-093-2/+6 * Removed the extra frame here.Christopher James Lahey2000-07-092-14/+5 * Several contacts list bugfixes.Anders Carlsson2000-07-0910-50/+109 * Removed unused do_nothing_cb function.Christopher James Lahey2000-07-099-36/+177 * Don't draw drop markers when the layout won't be changed by the drop.Anders Carlsson2000-07-093-4/+23 * updated icons that work better on the gray background /tigertTuomas Kuosmanen2000-07-093-0/+8 * Return "" instead of NULL.Christopher James Lahey2000-07-093-2/+13 * Added e_list_duplicate.Christopher James Lahey2000-07-093-0/+23 * Fix up the pageup/pagedown increment a bit.Dan Winship2000-07-092-4/+10 * Link the toolbar print button to the print callback.Not Zed2000-07-092-1/+6 * Add a "Threaded Message List" item to the "View" menu.Dan Winship2000-07-094-25/+69 * fix a "Re:" parsing bugDan Winship2000-07-092-1/+5 * Get rid of an unused variable.Ettore Perazzoli2000-07-093-0/+13 * Always dump incoming messages to Inbox (assuming not filtered to anotherJeffrey Stedfast2000-07-092-25/+63 * Don't display the annoying "Cannot display..." view in the shell whenEttore Perazzoli2000-07-092-39/+15 * When inserting a root node, only call e_table_model_row_inserted ifDan Winship2000-07-093-8/+16 * Hitting OK or Cancel at least closes the dialog now.Christopher James Lahey2000-07-092-0/+7 * Set the returned entry to use the ellipsis.Christopher James Lahey2000-07-092-0/+7 * Don't call e_cell_event if we're not editing.Christopher James Lahey2000-07-093-6/+11 * Remove "Close calendar" command, which does not make much sense.Ettore Perazzoli2000-07-092-8/+5 * Include e-select-names-factory.h.Christopher James Lahey2000-07-098-8/+86 * Commented out some unnecessary and buggy code.Christopher James Lahey2000-07-093-0/+9 * Move the "Expunge" command to the "Actions" menu.Ettore Perazzoli2000-07-092-2/+8 * Some menu cleanup.Ettore Perazzoli2000-07-092-31/+14 * Create an empty "Edit" menu for the editor control to insert itself into.Dan Winship2000-07-092-0/+10 * Update to reflect past changes in the Camel API. Use gtk macro castsJeffrey Stedfast2000-07-098-74/+101 * Remove conflict markers - FedericoFederico Mena Quintero2000-07-091-1/+0 * Deal with having multiple selected messages.Dan Winship2000-07-094-51/+63 * Translations from KeldKenneth Christiansen2000-07-091-424/+336 * Ignore dynamically created source filesJeffrey Stedfast2000-07-092-0/+9 * Ignore dynamically created source filesJeffrey Stedfast2000-07-092-0/+9 * Small fix to stop uid data from being set on a message-list tree node whenJeffrey Stedfast2000-07-092-1/+8 * comment out true but confused warning about non-scrollable widgets untilDan Winship2000-07-092-2/+16 * Fix Jeff's FIXME: This does get called with out-of-range data sometimes,Dan Winship2000-07-092-14/+7 * Added code for initializing the values of the fields in the messageEttore Perazzoli2000-07-08