aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-01-28 09:11:01 +0800
committermiwi <miwi@FreeBSD.org>2010-01-28 09:11:01 +0800
commitdb44e038e0bb484df7bee3d16b1eb7885a9d461a (patch)
treed6c18352df67ca8b6322781409807a547553da8d
parentc7fd61049e400a10a6266f7bd21e3d72f3ab48b3 (diff)
downloadfreebsd-ports-gnome-db44e038e0bb484df7bee3d16b1eb7885a9d461a.tar.gz
freebsd-ports-gnome-db44e038e0bb484df7bee3d16b1eb7885a9d461a.tar.zst
freebsd-ports-gnome-db44e038e0bb484df7bee3d16b1eb7885a9d461a.zip
read multiple hunks of data out of your DATA section
WWW: http://search.cpan.org/dist/Data-Section PR: ports/142057 Submitted by: Andrey Kostenko <andrey at kostenko.name>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Data-Section/Makefile24
-rw-r--r--devel/p5-Data-Section/distinfo3
-rw-r--r--devel/p5-Data-Section/pkg-descr3
-rw-r--r--devel/p5-Data-Section/pkg-plist5
5 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index cfb0e01cf566..fddaa13b352e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1296,6 +1296,7 @@
SUBDIR += p5-Data-Recursive-Encode
SUBDIR += p5-Data-Remember
SUBDIR += p5-Data-RoundRobin
+ SUBDIR += p5-Data-Section
SUBDIR += p5-Data-Serializer
SUBDIR += p5-Data-ShowTable
SUBDIR += p5-Data-Stag
diff --git a/devel/p5-Data-Section/Makefile b/devel/p5-Data-Section/Makefile
new file mode 100644
index 000000000000..19c62a11046e
--- /dev/null
+++ b/devel/p5-Data-Section/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: Data-Section
+# Date created: 27 December 2009
+# Whom: Andrey Kostenko <andrey@kostenko.name>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Section
+PORTVERSION= 0.093410
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= andrey@kostenko.name
+COMMENT= Read multiple hunks of data out of your DATA section
+
+BUILD_DEPENDS= p5-Class-ISA>=0:${PORTSDIR}/devel/p5-Class-ISA \
+ p5-Sub-Exporter>=0.979:${PORTSDIR}/devel/p5-Sub-Exporter
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+MAN3= Data::Section.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Data-Section/distinfo b/devel/p5-Data-Section/distinfo
new file mode 100644
index 000000000000..e91cbb3d2b64
--- /dev/null
+++ b/devel/p5-Data-Section/distinfo
@@ -0,0 +1,3 @@
+MD5 (Data-Section-0.093410.tar.gz) = f9c39e6d85fb035e9d509b4fe2b2859b
+SHA256 (Data-Section-0.093410.tar.gz) = e565011cf887db27c6ed41ccfe33fda495207425ef6cac42ab3b5fcc0877aa92
+SIZE (Data-Section-0.093410.tar.gz) = 12323
diff --git a/devel/p5-Data-Section/pkg-descr b/devel/p5-Data-Section/pkg-descr
new file mode 100644
index 000000000000..7fcd400ac75a
--- /dev/null
+++ b/devel/p5-Data-Section/pkg-descr
@@ -0,0 +1,3 @@
+read multiple hunks of data out of your DATA section
+
+WWW: http://search.cpan.org/dist/Data-Section
diff --git a/devel/p5-Data-Section/pkg-plist b/devel/p5-Data-Section/pkg-plist
new file mode 100644
index 000000000000..238d60b17c47
--- /dev/null
+++ b/devel/p5-Data-Section/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Data/Section.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Section/.packlist
+@dirrmtry %%SITE_PERL%%/Data
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Section
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data