aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoravl <avl@FreeBSD.org>2009-11-05 22:40:07 +0800
committeravl <avl@FreeBSD.org>2009-11-05 22:40:07 +0800
commitdb8aed3662b2b5d1147d9abc3b3097d612b13644 (patch)
tree48273aae456dd39e294ff7a188a75d610d5103a9
parent1313f116c3f529d50c63c36b0f4c2cae8f92ab2b (diff)
downloadfreebsd-ports-gnome-db8aed3662b2b5d1147d9abc3b3097d612b13644.tar.gz
freebsd-ports-gnome-db8aed3662b2b5d1147d9abc3b3097d612b13644.tar.zst
freebsd-ports-gnome-db8aed3662b2b5d1147d9abc3b3097d612b13644.zip
- Update to 0.5.2
Changes: http://gbirthday.sourceforge.net/gbchangelog.html
-rw-r--r--deskutils/gbirthday/Makefile82
-rw-r--r--deskutils/gbirthday/distinfo6
-rw-r--r--deskutils/gbirthday/pkg-descr10
-rw-r--r--deskutils/gbirthday/pkg-plist42
4 files changed, 96 insertions, 44 deletions
diff --git a/deskutils/gbirthday/Makefile b/deskutils/gbirthday/Makefile
index ab0483238fa2..96b51b83ae37 100644
--- a/deskutils/gbirthday/Makefile
+++ b/deskutils/gbirthday/Makefile
@@ -6,34 +6,84 @@
#
PORTNAME= gbirthday
-PORTVERSION= 0.4.1
-PORTREVISION= 1
+PORTVERSION= 0.5.2
CATEGORIES= deskutils gnome
-MASTER_SITES= SF
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
MAINTAINER= avl@FreeBSD.org
-COMMENT= A birthday reminder for Evolution contacts
+COMMENT= A birthday reminder for Evolution and some others
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_bsddb.so:${PORTSDIR}/databases/py-bsddb
+OPTIONS= EVO "Evolution support" on \
+ THUNDER "Thunderbird/Sunbird support" off \
+ MYSQL "MySQL database support" off
-NO_BUILD= yes
NO_WRKSUBDIR= yes
USE_PYTHON_RUN= yes
-USE_GNOME= pygtk2 evolutiondataserver
+USE_GNOME= pygtk2 desktopfileutils
+
+.if defined(WITHOUT_NLS)
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+USE_GNOME+= intltool
+LANGUAGES= de en es fr gl it pl pt ru sk
+PLIST_SUB+= NLS=""
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_EVO)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_bsddb.so:${PORTSDIR}/databases/py-bsddb
+USE_GNOME+= evolutiondataserver
+.endif
+
+.if defined(WITH_THUNDER)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
+.endif
+
+.if defined(WITH_MYSQL)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/MySQLdb/__init__.py:${PORTSDIR}/databases/py-MySQLdb
+.endif
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/share/${PORTNAME}|${DATADIR}|g' \
- ${WRKSRC}/${PORTNAME}.py ${WRKSRC}/${PORTNAME}.desktop
- @${RM} ${WRKSRC}/languages/*.orig
+ @${REINPLACE_CMD} -e 's|/usr/share/${PORTNAME}|${DATADIR}|g ; \
+ s|/usr/share/pixmaps|${PREFIX}/share/pixmaps|g ; \
+ s|.mozilla-thunderbird|.thunderbird|g' \
+ ${WRKSRC}/src/${PORTNAME}.py ${WRKSRC}/gbirthday.desktop.in
+.if defined(WITHOUT_NLS)
+ @${REINPLACE_CMD} -e 's|_Comment|Comment|' ${WRKSRC}/gbirthday.desktop.in
+.endif
+
+do-build:
+.if !defined(WITHOUT_NLS)
+ @-intltool-merge -d ${WRKSRC}/po ${WRKSRC}/gbirthday.desktop.in \
+ ${WRKSRC}/gbirthday.desktop
+ @(for lang in ${LANGUAGES} ; do \
+ cd ${WRKSRC}/po ; \
+ ${LOCALBASE}/bin/msgfmt $$lang.po -o $$lang.mo ; \
+ done)
+.endif
do-install:
-.for dir in pics languages
- @${MKDIR} ${DATADIR}/${dir}
- ${INSTALL_DATA} ${WRKSRC}/${dir}/* ${DATADIR}/${dir}/
-.endfor
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.py ${DATADIR}
+ @${MKDIR} ${DATADIR}
+ @${MKDIR} ${PREFIX}/share/pixmaps/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/pics/* ${PREFIX}/share/pixmaps/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/${PORTNAME}.py ${DATADIR}
${LN} -fs ${DATADIR}/${PORTNAME}.py ${PREFIX}/bin/${PORTNAME}
@${MKDIR} ${PREFIX}/share/applications
+.if !defined(WITHOUT_NLS)
+ @(for lang in ${LANGUAGES} ; do \
+ ${MKDIR} ${PREFIX}/share/locale/$$lang/LC_MESSAGES ; \
+ ${INSTALL_DATA} ${WRKSRC}/po/$$lang.mo \
+ ${PREFIX}/share/locale/$$lang/LC_MESSAGES/${PORTNAME}.mo ; \
+ done)
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${PREFIX}/share/applications
+.else
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop.in \
+ ${PREFIX}/share/applications/${PORTNAME}.desktop
+.endif
+
+post-install:
+ @-update-desktop-database
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/deskutils/gbirthday/distinfo b/deskutils/gbirthday/distinfo
index 8a36183e40ac..088be9cdc533 100644
--- a/deskutils/gbirthday/distinfo
+++ b/deskutils/gbirthday/distinfo
@@ -1,3 +1,3 @@
-MD5 (gbirthday-0.4.1.tar.gz) = d2a028ab886d05702152386e6e2978c7
-SHA256 (gbirthday-0.4.1.tar.gz) = 22094bc69a0ab1490875988bd485ac07be8eeab436d394ec2e0d5250f4ca12ff
-SIZE (gbirthday-0.4.1.tar.gz) = 38572
+MD5 (gbirthday-0.5.2.tar.gz) = d4774395d0f6a6cf7f7a880fb279ccb1
+SHA256 (gbirthday-0.5.2.tar.gz) = c35488c055260b53ded54be843f8ed9d4c2641527c2fa8d4e580845c1e3ed44f
+SIZE (gbirthday-0.5.2.tar.gz) = 55726
diff --git a/deskutils/gbirthday/pkg-descr b/deskutils/gbirthday/pkg-descr
index b7e0dd13a37e..205e0fe09524 100644
--- a/deskutils/gbirthday/pkg-descr
+++ b/deskutils/gbirthday/pkg-descr
@@ -1,6 +1,8 @@
-GBirthday is a birthday reminder application that helps you to remember your
-evolution contacts' birthdays. It puts an icon on notification area which will
-blink when there is any of your contacts' birthday today. You can also check if
-there is any of your contacs' birhday on next days.
+GBirthday is a birthday reminder application that helps you to remember
+your Evolution, Thunderbird, Sunbird contacts' birthdays or from a MySQL
+Server or a CSV File.
+It puts an icon on notification area which will blink when there is any
+of your contacts' birthday today. You can also check if there is any of
+your contacs' birthday on next days.
WWW: http://gbirthday.sourceforge.net/
diff --git a/deskutils/gbirthday/pkg-plist b/deskutils/gbirthday/pkg-plist
index 74bfda12d174..f59f71f2669d 100644
--- a/deskutils/gbirthday/pkg-plist
+++ b/deskutils/gbirthday/pkg-plist
@@ -1,26 +1,26 @@
bin/gbirthday
share/applications/gbirthday.desktop
%%DATADIR%%/gbirthday.py
-%%DATADIR%%/languages/de.lang
-%%DATADIR%%/languages/en.lang
-%%DATADIR%%/languages/es.lang
-%%DATADIR%%/languages/es_AR.lang
-%%DATADIR%%/languages/es_ES.lang
-%%DATADIR%%/languages/fr.lang
-%%DATADIR%%/languages/gl.lang
-%%DATADIR%%/languages/it.lang
-%%DATADIR%%/languages/ru.lang
-%%DATADIR%%/languages/pt.lang
-%%DATADIR%%/languages/sk.lang
-%%DATADIR%%/pics/birthday.png
-%%DATADIR%%/pics/birthdaylost.png
-%%DATADIR%%/pics/birthdaynext.png
-%%DATADIR%%/pics/birthdaytoday.png
-%%DATADIR%%/pics/gbirthday.png
-%%DATADIR%%/pics/gbirthday.svg
-%%DATADIR%%/pics/nobirthday.png
-%%DATADIR%%/pics/pie.svg
-@dirrmtry %%DATADIR%%/languages
-@dirrmtry %%DATADIR%%/pics
+share/pixmaps/gbirthday/birthday.png
+share/pixmaps/gbirthday/birthdaylost.png
+share/pixmaps/gbirthday/birthdaynext.png
+share/pixmaps/gbirthday/birthdaytoday.png
+share/pixmaps/gbirthday/gbirthday.png
+share/pixmaps/gbirthday/gbirthday.svg
+share/pixmaps/gbirthday/nobirthday.png
+share/pixmaps/gbirthday/pie.svg
+%%NLS%%share/locale/de/LC_MESSAGES/gbirthday.mo
+%%NLS%%share/locale/en/LC_MESSAGES/gbirthday.mo
+%%NLS%%share/locale/es/LC_MESSAGES/gbirthday.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/gbirthday.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/gbirthday.mo
+%%NLS%%share/locale/it/LC_MESSAGES/gbirthday.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/gbirthday.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/gbirthday.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/gbirthday.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/gbirthday.mo
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@dirrmtry %%DATADIR%%
+@dirrmtry share/pixmaps/gbirthday
@dirrmtry share/applications