aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-09-08 23:21:06 +0800
committerdanfe <danfe@FreeBSD.org>2015-09-08 23:21:06 +0800
commitdc5c7243190a2087ad8e6871cf5196ce45d0a157 (patch)
tree8c98159e58f04e9ce8ada525afc5a8cf93a5bd92
parent6de9e85ef5c53ca9f60a584f8a971a860b4d1669 (diff)
downloadfreebsd-ports-gnome-dc5c7243190a2087ad8e6871cf5196ce45d0a157.tar.gz
freebsd-ports-gnome-dc5c7243190a2087ad8e6871cf5196ce45d0a157.tar.zst
freebsd-ports-gnome-dc5c7243190a2087ad8e6871cf5196ce45d0a157.zip
- Remove "BROKEN on powerpc" statement, the port builds fine
- Install documentation files in `do-install-DOCS-on' target - Clean up Makefile and port description text while I'm here
-rw-r--r--japanese/ne/Makefile25
-rw-r--r--japanese/ne/pkg-descr30
2 files changed, 22 insertions, 33 deletions
diff --git a/japanese/ne/Makefile b/japanese/ne/Makefile
index f4b6d28aa915..b8b60fcb7c93 100644
--- a/japanese/ne/Makefile
+++ b/japanese/ne/Makefile
@@ -7,36 +7,31 @@ CATEGORIES= japanese editors
MASTER_SITES= http://hp.vector.co.jp/authors/VA018758/archive/
MAINTAINER= ports@FreeBSD.org
-COMMENT= VZ like full-screen text editor with Japanese support
+COMMENT= VZ-like full-screen text editor with Japanese support
LICENSE= GPLv2
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
GNU_CONFIGURE= yes
-CFLAGS+= -Wno-error=return-type
+CFLAGS+= -Wno-error=return-type # required for Clang
-BROKEN_powerpc= Does not compile on powerpc
+WRKSRC= ${WRKDIR}/${PORTNAME}
OPTIONS_DEFINE= DOCS
do-install:
- (cd ${WRKSRC}/src && ${INSTALL_PROGRAM} ne \
- ${STAGEDIR}${PREFIX}/bin)
- (cd ${WRKSRC}/src && ${INSTALL_MAN} ne_en.1 \
- ${STAGEDIR}${MANPREFIX}/man/man1/ne.1)
- (cd ${WRKSRC}/src && ${INSTALL_MAN} ne.1 \
- ${STAGEDIR}${MANPREFIX}/man/ja/man1/ne.1)
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/ne ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/src/ne_en.1 ${STAGEDIR}${PREFIX}/man/man1/ne.1
+ ${INSTALL_MAN} ${WRKSRC}/src/ne.1 ${STAGEDIR}${PREFIX}/man/ja/man1
@${MKDIR} ${STAGEDIR}${ETCDIR}
.for i in key* nerc* term*
- (cd ${WRKSRC}/etc && ${INSTALL_DATA} ${i} \
- ${STAGEDIR}${ETCDIR})
+ ${INSTALL_DATA} ${WRKSRC}/etc/${i} ${STAGEDIR}${ETCDIR}
.endfor
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in BUGS.jp CHANGES.jp HISTORY.jp INSTALL.jp README.jp TODO.jp
- (cd ${WRKSRC} && ${INSTALL_DATA} ${i} \
- ${STAGEDIR}${DOCSDIR})
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
.include <bsd.port.mk>
diff --git a/japanese/ne/pkg-descr b/japanese/ne/pkg-descr
index 2452aecb6b58..63eb3e2ea3d0 100644
--- a/japanese/ne/pkg-descr
+++ b/japanese/ne/pkg-descr
@@ -1,21 +1,15 @@
-NxEdit(ne) is a modeless full-screen text editor expected to be
-compatible with 'VZ Editor', which has been a popular editor among
-MS-DOS users in Japan.
+NxEdit (ne) is modeless full-screen text editor expected to be compatible
+with VZ Editor, which has been popular editor among MS-DOS users in Japan.
-Features:
+NxEdit provides most features of VZ Editor, such as:
-o NxEdit provides most features of 'VZ Editor', such as:
- o Stackable delete buffer
- o Stackable cut buffer
- o Less cursor movement
- o Static line buffer
- o Keyboard macro
- o Built-in two-window file manager
- o Profile management
+ - Stackable cut and delete buffers
+ - Less cursor movement
+ - Static line buffer
+ - Keyboard macros
+ - Built-in two-window file manager
+ - Profile management
+ - Automatic profile saving on emergency-like signals
+ - Automatic detection of Japanese code sets (EUC/SJIS/JIS)
-o Auto profile saving on emergency like signals
-
-o Auto detection of Japanese code sets (EUC/SJIS/JIS)
-
-
-WWW: http://hp.vector.co.jp/authors/VA018758/
+WWW: http://hp.vector.co.jp/authors/VA018758/ne/