aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2005-06-19 20:50:39 +0800
committersobomax <sobomax@FreeBSD.org>2005-06-19 20:50:39 +0800
commitdcc76c884b25c0e7a04626041a3001a10e6d0d7a (patch)
tree00ed63bf57cadf99b26280916728b3af3f5143fe
parentb9dbc97b5bc2ab490d351e3e7fe7ccb47a7305ad (diff)
downloadfreebsd-ports-gnome-dcc76c884b25c0e7a04626041a3001a10e6d0d7a.tar.gz
freebsd-ports-gnome-dcc76c884b25c0e7a04626041a3001a10e6d0d7a.tar.zst
freebsd-ports-gnome-dcc76c884b25c0e7a04626041a3001a10e6d0d7a.zip
o Fix patch in default musiconhold.conf file;
o use USE_MYSQL instead of manually specifying MySQL dependency. PR: 79253 Submitted by: Ari Maniatis <ari@ish.com.au>
-rw-r--r--net/asterisk-bristuff/Makefile7
-rw-r--r--net/asterisk-devel/Makefile7
-rw-r--r--net/asterisk/Makefile7
-rw-r--r--net/asterisk10/Makefile7
-rw-r--r--net/asterisk12/Makefile7
-rw-r--r--net/asterisk14/Makefile7
-rw-r--r--net/asterisk16/Makefile7
7 files changed, 28 insertions, 21 deletions
diff --git a/net/asterisk-bristuff/Makefile b/net/asterisk-bristuff/Makefile
index a89c6518acd3..9de27aaa038a 100644
--- a/net/asterisk-bristuff/Makefile
+++ b/net/asterisk-bristuff/Makefile
@@ -7,7 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.0.7
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -33,6 +33,7 @@ CONFIGURE_WRKSRC= ${WRKSRC}/editline
USE_GMAKE= yes
USE_BISON= yes
USE_RC_SUBR= asterisk.sh
+USE_REINPLACE= yes
MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
MKDIR="${MKDIR}" \
@@ -70,11 +71,11 @@ PLIST_SUB+= WITH_ZAPTEL=""
.endif
.if !defined(WITHOUT_MYSQL)
-BUILD_DEPENDS+= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client
-RUN_DEPENDS+= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client
+USE_MYSQL= yes
.endif
post-patch:
${CP} ${FILESDIR}/chan_oss.c ${WRKSRC}/channels
+ ${REINPLACE_CMD} -e 's|/var/lib|${PREFIX}/share|g' ${WRKSRC}/configs/musiconhold.conf.sample
.include <bsd.port.post.mk>
diff --git a/net/asterisk-devel/Makefile b/net/asterisk-devel/Makefile
index a89c6518acd3..9de27aaa038a 100644
--- a/net/asterisk-devel/Makefile
+++ b/net/asterisk-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.0.7
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -33,6 +33,7 @@ CONFIGURE_WRKSRC= ${WRKSRC}/editline
USE_GMAKE= yes
USE_BISON= yes
USE_RC_SUBR= asterisk.sh
+USE_REINPLACE= yes
MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
MKDIR="${MKDIR}" \
@@ -70,11 +71,11 @@ PLIST_SUB+= WITH_ZAPTEL=""
.endif
.if !defined(WITHOUT_MYSQL)
-BUILD_DEPENDS+= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client
-RUN_DEPENDS+= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client
+USE_MYSQL= yes
.endif
post-patch:
${CP} ${FILESDIR}/chan_oss.c ${WRKSRC}/channels
+ ${REINPLACE_CMD} -e 's|/var/lib|${PREFIX}/share|g' ${WRKSRC}/configs/musiconhold.conf.sample
.include <bsd.port.post.mk>
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index a89c6518acd3..9de27aaa038a 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -7,7 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.0.7
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -33,6 +33,7 @@ CONFIGURE_WRKSRC= ${WRKSRC}/editline
USE_GMAKE= yes
USE_BISON= yes
USE_RC_SUBR= asterisk.sh
+USE_REINPLACE= yes
MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
MKDIR="${MKDIR}" \
@@ -70,11 +71,11 @@ PLIST_SUB+= WITH_ZAPTEL=""
.endif
.if !defined(WITHOUT_MYSQL)
-BUILD_DEPENDS+= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client
-RUN_DEPENDS+= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client
+USE_MYSQL= yes
.endif
post-patch:
${CP} ${FILESDIR}/chan_oss.c ${WRKSRC}/channels
+ ${REINPLACE_CMD} -e 's|/var/lib|${PREFIX}/share|g' ${WRKSRC}/configs/musiconhold.conf.sample
.include <bsd.port.post.mk>
diff --git a/net/asterisk10/Makefile b/net/asterisk10/Makefile
index a89c6518acd3..9de27aaa038a 100644
--- a/net/asterisk10/Makefile
+++ b/net/asterisk10/Makefile
@@ -7,7 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.0.7
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -33,6 +33,7 @@ CONFIGURE_WRKSRC= ${WRKSRC}/editline
USE_GMAKE= yes
USE_BISON= yes
USE_RC_SUBR= asterisk.sh
+USE_REINPLACE= yes
MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
MKDIR="${MKDIR}" \
@@ -70,11 +71,11 @@ PLIST_SUB+= WITH_ZAPTEL=""
.endif
.if !defined(WITHOUT_MYSQL)
-BUILD_DEPENDS+= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client
-RUN_DEPENDS+= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client
+USE_MYSQL= yes
.endif
post-patch:
${CP} ${FILESDIR}/chan_oss.c ${WRKSRC}/channels
+ ${REINPLACE_CMD} -e 's|/var/lib|${PREFIX}/share|g' ${WRKSRC}/configs/musiconhold.conf.sample
.include <bsd.port.post.mk>
diff --git a/net/asterisk12/Makefile b/net/asterisk12/Makefile
index a89c6518acd3..9de27aaa038a 100644
--- a/net/asterisk12/Makefile
+++ b/net/asterisk12/Makefile
@@ -7,7 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.0.7
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -33,6 +33,7 @@ CONFIGURE_WRKSRC= ${WRKSRC}/editline
USE_GMAKE= yes
USE_BISON= yes
USE_RC_SUBR= asterisk.sh
+USE_REINPLACE= yes
MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
MKDIR="${MKDIR}" \
@@ -70,11 +71,11 @@ PLIST_SUB+= WITH_ZAPTEL=""
.endif
.if !defined(WITHOUT_MYSQL)
-BUILD_DEPENDS+= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client
-RUN_DEPENDS+= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client
+USE_MYSQL= yes
.endif
post-patch:
${CP} ${FILESDIR}/chan_oss.c ${WRKSRC}/channels
+ ${REINPLACE_CMD} -e 's|/var/lib|${PREFIX}/share|g' ${WRKSRC}/configs/musiconhold.conf.sample
.include <bsd.port.post.mk>
diff --git a/net/asterisk14/Makefile b/net/asterisk14/Makefile
index a89c6518acd3..9de27aaa038a 100644
--- a/net/asterisk14/Makefile
+++ b/net/asterisk14/Makefile
@@ -7,7 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.0.7
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -33,6 +33,7 @@ CONFIGURE_WRKSRC= ${WRKSRC}/editline
USE_GMAKE= yes
USE_BISON= yes
USE_RC_SUBR= asterisk.sh
+USE_REINPLACE= yes
MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
MKDIR="${MKDIR}" \
@@ -70,11 +71,11 @@ PLIST_SUB+= WITH_ZAPTEL=""
.endif
.if !defined(WITHOUT_MYSQL)
-BUILD_DEPENDS+= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client
-RUN_DEPENDS+= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client
+USE_MYSQL= yes
.endif
post-patch:
${CP} ${FILESDIR}/chan_oss.c ${WRKSRC}/channels
+ ${REINPLACE_CMD} -e 's|/var/lib|${PREFIX}/share|g' ${WRKSRC}/configs/musiconhold.conf.sample
.include <bsd.port.post.mk>
diff --git a/net/asterisk16/Makefile b/net/asterisk16/Makefile
index a89c6518acd3..9de27aaa038a 100644
--- a/net/asterisk16/Makefile
+++ b/net/asterisk16/Makefile
@@ -7,7 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.0.7
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -33,6 +33,7 @@ CONFIGURE_WRKSRC= ${WRKSRC}/editline
USE_GMAKE= yes
USE_BISON= yes
USE_RC_SUBR= asterisk.sh
+USE_REINPLACE= yes
MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
MKDIR="${MKDIR}" \
@@ -70,11 +71,11 @@ PLIST_SUB+= WITH_ZAPTEL=""
.endif
.if !defined(WITHOUT_MYSQL)
-BUILD_DEPENDS+= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client
-RUN_DEPENDS+= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client
+USE_MYSQL= yes
.endif
post-patch:
${CP} ${FILESDIR}/chan_oss.c ${WRKSRC}/channels
+ ${REINPLACE_CMD} -e 's|/var/lib|${PREFIX}/share|g' ${WRKSRC}/configs/musiconhold.conf.sample
.include <bsd.port.post.mk>