aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjseger <jseger@FreeBSD.org>1998-12-19 22:22:10 +0800
committerjseger <jseger@FreeBSD.org>1998-12-19 22:22:10 +0800
commitde6c07ae27b42465fa6886142486e3c72771b644 (patch)
treef34623f6ae65d4ecb0a205c4203485532d457b37
parent6dd96fdd8556165188fa81b197b26692ab8a0a02 (diff)
downloadfreebsd-ports-gnome-de6c07ae27b42465fa6886142486e3c72771b644.tar.gz
freebsd-ports-gnome-de6c07ae27b42465fa6886142486e3c72771b644.tar.zst
freebsd-ports-gnome-de6c07ae27b42465fa6886142486e3c72771b644.zip
Initial import of xwpl 1.3
XWPL is an X based tool to examine one-dimensional real-valued signals using wavelets and wavelet packets. It has been designed to be as easy to use as possible for beginners. It is intended more as an educational and exploratory tool than as a numerical analysis program, even though it uses fast, optimized wavelet and wavelet packet transforms. PR: ports/5312 Submitted by: giffunip@asme.org
-rw-r--r--math/xwpl/Makefile36
-rw-r--r--math/xwpl/distinfo1
-rw-r--r--math/xwpl/pkg-comment1
-rw-r--r--math/xwpl/pkg-descr13
-rw-r--r--math/xwpl/pkg-plist30
5 files changed, 81 insertions, 0 deletions
diff --git a/math/xwpl/Makefile b/math/xwpl/Makefile
new file mode 100644
index 000000000000..621a4f780817
--- /dev/null
+++ b/math/xwpl/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: xwpl
+# Version required: 1.3
+# Date created: 31 Nov 97
+# Whom: Pedro Giffuni <giffunip@asme.org>
+#
+# $Id$
+#
+
+DISTNAME= xwpl-1.3-freebsd
+PKGNAME= xwpl-1.3
+CATEGORIES= math
+MASTER_SITES= ftp://pascal.math.yale.edu/pub/wavelets/software/xwpl/
+
+MAINTAINER= giffunip@asme.org
+
+NO_CDROM= "Free for Non-Commercial Use Only"
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/xwpl
+STRIP=
+
+MAN1= xwpl.1
+
+do-install:
+ ${INSTALL_PROGRAM} $(WRKSRC)/xwpl $(PREFIX)/bin
+ ${INSTALL_MAN} ${WRKSRC}/xwpl.man ${PREFIX}/man/man1/xwpl.1
+
+post-install:
+ ${MKDIR} $(PREFIX)/share/examples/xwpl
+ ${INSTALL_DATA} ${WRKSRC}/data/* $(PREFIX)/share/examples/xwpl
+.if !defined(NOPORTDOCS)
+ ${MKDIR} $(PREFIX)/share/doc/xwpl
+ ${INSTALL_DATA} ${WRKSRC}/*.ps $(PREFIX)/share/doc/xwpl
+ ${INSTALL_DATA} ${WRKSRC}/README $(PREFIX)/share/doc/xwpl
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/xwpl/distinfo b/math/xwpl/distinfo
new file mode 100644
index 000000000000..23ae2bd36d31
--- /dev/null
+++ b/math/xwpl/distinfo
@@ -0,0 +1 @@
+MD5 (xwpl-1.3-freebsd.tar.gz) = 98f438ace0f44f707ab8691d42834a08
diff --git a/math/xwpl/pkg-comment b/math/xwpl/pkg-comment
new file mode 100644
index 000000000000..010b11fe0be3
--- /dev/null
+++ b/math/xwpl/pkg-comment
@@ -0,0 +1 @@
+the X Wavelet Packet Laboratory
diff --git a/math/xwpl/pkg-descr b/math/xwpl/pkg-descr
new file mode 100644
index 000000000000..fbdf2d639709
--- /dev/null
+++ b/math/xwpl/pkg-descr
@@ -0,0 +1,13 @@
+XWPL is an X based tool to examine one-dimensional real-valued signals using
+wavelets and wavelet packets. It has been designed to be as easy to use as
+possible for beginners. It is intended more as an educational and exploratory
+tool than as a numerical analysis program, even though it uses fast, optimized
+wavelet and wavelet packet transforms.
+
+In short, wavelets are a way to analyze a signal using base functions which
+are localized both in time (as diracs, but unlike sine waves), and in
+frequency (as sine waves, but unlike diracs). They can be used for efficient
+numerical algorithms and many DSP or compression applications.
+
+The mathematical theory behind wavelets (and other related transforms) is
+given in the appendix of the XWPL reference manual.
diff --git a/math/xwpl/pkg-plist b/math/xwpl/pkg-plist
new file mode 100644
index 000000000000..190fab9313d3
--- /dev/null
+++ b/math/xwpl/pkg-plist
@@ -0,0 +1,30 @@
+bin/xwpl
+share/examples/xwpl/bomb.asc
+share/examples/xwpl/car_seg.asc
+share/examples/xwpl/caruso.asc
+share/examples/xwpl/chirp256.asc
+share/examples/xwpl/d.asc
+share/examples/xwpl/f+r.asc
+share/examples/xwpl/fort.asc
+share/examples/xwpl/fort_seg.asc
+share/examples/xwpl/linchirp.asc
+share/examples/xwpl/line.asc
+share/examples/xwpl/long.asc
+share/examples/xwpl/ping.asc
+share/examples/xwpl/quadchrp.asc
+share/examples/xwpl/r.asc
+share/examples/xwpl/s+100d.asc
+share/examples/xwpl/s+d.asc
+share/examples/xwpl/s+r.asc
+share/examples/xwpl/s.asc
+share/examples/xwpl/sgnr.asc
+share/examples/xwpl/spike.asc
+share/examples/xwpl/sxexpr.asc
+share/examples/xwpl/transien.asc
+share/examples/xwpl/twochrp1.asc
+share/examples/xwpl/twochrp2.asc
+share/examples/xwpl/zero.asc
+share/doc/xwpl/manual.ps
+share/doc/xwpl/README
+@dirrm share/examples/xwpl
+@dirrm share/doc/xwpl