aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2012-10-16 15:52:52 +0800
committerjhale <jhale@FreeBSD.org>2012-10-16 15:52:52 +0800
commitde7633c75ad87126004ddd0fff77b176eaa9d29b (patch)
tree2e61f73bc9cd3652fb6c65b204c5c4781231572f
parent6e04cc40b77e71aade3ba3eb74350c71298690f1 (diff)
downloadfreebsd-ports-gnome-de7633c75ad87126004ddd0fff77b176eaa9d29b.tar.gz
freebsd-ports-gnome-de7633c75ad87126004ddd0fff77b176eaa9d29b.tar.zst
freebsd-ports-gnome-de7633c75ad87126004ddd0fff77b176eaa9d29b.zip
- Replace reference to -lpthread in .pc file
- Bump PORTREVISION since installed file will change While here: - Trim Makefile header - Convert to new options framework - Add explict USE_PKGCONFIG (was implied by USE_GNOME) - Drop specific ABI version numbers from LIB_DEPENDS to satisfy portlint(1) PR: ports/170507 Submitted by: myself Approved by: maintainer timeout (5 weeks) makc, avilla (mentors, implicit) Feature safe: yes
-rw-r--r--math/libqalculate/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/math/libqalculate/Makefile b/math/libqalculate/Makefile
index 4c6b4868d402..899a43802831 100644
--- a/math/libqalculate/Makefile
+++ b/math/libqalculate/Makefile
@@ -1,27 +1,26 @@
-# New ports collection makefile for: libqalculate
-# Date created: 03 June 2004
-# Whom: Sergey Akifyev <asa@agava.com>
-#
+# Created by: Sergey Akifyev <asa@agava.com>
# $FreeBSD$
-#
PORTNAME= libqalculate
PORTVERSION= 0.9.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= SF/qalculate/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= sylvio@FreeBSD.org
COMMENT= Multi-purpose desktop calculator (backend library)
-LIB_DEPENDS= cln.6:${PORTSDIR}/math/cln
+LIB_DEPENDS= cln:${PORTSDIR}/math/cln
+USE_PKGCONFIG= build
USE_GNOME= glib20 gnomehack intlhack libxml2
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
@@ -32,6 +31,7 @@ PLIST_SUB+= NLS="@comment "
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS =/s|docs||g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's/^GMSGFMT = @GMSGFMT@/GMSGFMT = msgfmt/' ${WRKSRC}/po/Makefile.in.in
- @${REINPLACE_CMD} -e 's/-pthread/${PTHREAD_LIBS}/' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's/-pthread/${PTHREAD_LIBS}/g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's/-lpthread/${PTHREAD_LIBS}/g' ${WRKSRC}/libqalculate.pc.in
.include <bsd.port.mk>