aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2012-11-09 06:09:33 +0800
committeradamw <adamw@FreeBSD.org>2012-11-09 06:09:33 +0800
commitde89483eed057221d7cc017b2a5afd8279ec7519 (patch)
tree1a9873e8780ebb375d28bba414b31db0817298d9
parent7275a4c40af907471d2a8841980a84a8602e6fa0 (diff)
downloadfreebsd-ports-gnome-de89483eed057221d7cc017b2a5afd8279ec7519.tar.gz
freebsd-ports-gnome-de89483eed057221d7cc017b2a5afd8279ec7519.tar.zst
freebsd-ports-gnome-de89483eed057221d7cc017b2a5afd8279ec7519.zip
- fix NLS support, which was wired backwards
- actually enable NLS in OPTIONS - change LOCALBASE to PREFIX, as it was attempting to create a directory in one, and then install a file into another - this fixes package building Feature safe: yes
-rw-r--r--textproc/bsdgrep/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/textproc/bsdgrep/Makefile b/textproc/bsdgrep/Makefile
index 44d019d5b5f4..28d074570109 100644
--- a/textproc/bsdgrep/Makefile
+++ b/textproc/bsdgrep/Makefile
@@ -7,6 +7,7 @@
PORTNAME= grep
PORTVERSION= 20111002
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= gabor
@@ -37,7 +38,7 @@ MAKE_ENV+= BINDIR="${PREFIX}/bin" \
CATDIR="${MANPREFIX}/man/man" \
NLSDIR="${PREFIX}/share/nls"
-OPTIONS_DEFINE= GNU_COMPAT
+OPTIONS_DEFINE= GNU_COMPAT NLS
OPTIONS_DEFAULT= GNU_COMPAT
GNU_COMPAT_DESC= Use GNU regex library (recommended)
@@ -47,16 +48,16 @@ CONFLICTS= gnugrep-*
.if !(${OSVERSION} >= 900012 || (${OSVERSION} < 900000 && ${OSVERSION} >= 800505))
LIB_DEPENDS+= lzma.5:${PORTSDIR}/archivers/xz
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CFLAGS+= -I${PREFIX}/include
+LDFLAGS+= -L${PREFIX}/lib
BROKEN= overwrites files installed by dependency
.endif
.if ${PORT_OPTIONS:MNLS}
+PLIST_SUB+= NLS=""
+.else
MAKE_ENV+= WITHOUT_NLS=yes
PLIST_SUB+= NLS="@comment "
-.else
-PLIST_SUB+= NLS=""
.endif
.if !${PORT_OPTIONS:MGNU_COMPAT}
@@ -65,7 +66,7 @@ MAKE_ENV+= WITHOUT_GNU_COMPAT=yes
pre-install:
.if ${PORT_OPTIONS:MNLS}
- ${MKDIR} ${LOCALBASE}/share/nls/gl_ES.ISO8859-1
+ ${MKDIR} ${PREFIX}/share/nls/gl_ES.ISO8859-1
.endif
post-install: