aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2013-11-12 11:40:17 +0800
committerdanilo <danilo@FreeBSD.org>2013-11-12 11:40:17 +0800
commitdeff238040256a9e7e40e5d753ab68a81d6982df (patch)
tree521e3fe4eef5f237e8a47d41b81bd5a36649b8b8
parent1d74cb7c8f8c71b0f1aff712e539f4c35cf5ce46 (diff)
downloadfreebsd-ports-gnome-deff238040256a9e7e40e5d753ab68a81d6982df.tar.gz
freebsd-ports-gnome-deff238040256a9e7e40e5d753ab68a81d6982df.tar.zst
freebsd-ports-gnome-deff238040256a9e7e40e5d753ab68a81d6982df.zip
- Convert LIB_DEPENDS to new syntax
- Add LICENSE - Convert USE_GMAKE to USES - Add stage support
-rw-r--r--games/tuxpuck/Makefile27
1 files changed, 11 insertions, 16 deletions
diff --git a/games/tuxpuck/Makefile b/games/tuxpuck/Makefile
index cad5aa1ed277..b6eb1abbe84e 100644
--- a/games/tuxpuck/Makefile
+++ b/games/tuxpuck/Makefile
@@ -10,26 +10,21 @@ MASTER_SITES= http://www.sourcefiles.org/Games/Sports/Miscellaneous/
MAINTAINER= ports@FreeBSD.org
COMMENT= Shufflepuck Cafe Clone
-LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png \
- vorbis:${PORTSDIR}/audio/libvorbis \
- freetype:${PORTSDIR}/print/freetype2
+LICENSE= GPLv2
+
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libvorbis.so:${PORTSDIR}/audio/libvorbis \
+ libfreetype.so:${PORTSDIR}/print/freetype2
USE_SDL= sdl
-USE_GMAKE= yes
+USES= gmake
ALL_TARGET= ${PORTNAME}
MAKE_JOBS_UNSAFE= yes
CFLAGS+= -I${LOCALBASE}/include/libpng15
-MANCOMPRESSED= yes
-
-PLIST_FILES= bin/${PORTNAME}
-
-MAN6= ${PORTNAME}.6
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+PLIST_FILES= bin/${PORTNAME} man/man6/tuxpuck.6.gz
post-patch:
cd ${WRKSRC}; \
@@ -38,7 +33,7 @@ post-patch:
${REINPLACE_CMD} -e 's|sdl-config|$$(SDL_CONFIG)|g' ${WRKSRC}/utils/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/man/${MAN6}.gz ${MAN6PREFIX}/man/man6
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man/tuxpuck.6.gz ${STAGEDIR}${MAN6PREFIX}/man/man6
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>