aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2011-07-20 17:35:28 +0800
committerbapt <bapt@FreeBSD.org>2011-07-20 17:35:28 +0800
commite17388100fa3b20b96e8f9dc9bfdf6e8a7c1322c (patch)
treeabc8d124b8898ab7b6f665a7be21892c9c4c3500
parentd48f58fa31288ebee5762ec3c97c114acc6b108c (diff)
downloadfreebsd-ports-gnome-e17388100fa3b20b96e8f9dc9bfdf6e8a7c1322c.tar.gz
freebsd-ports-gnome-e17388100fa3b20b96e8f9dc9bfdf6e8a7c1322c.tar.zst
freebsd-ports-gnome-e17388100fa3b20b96e8f9dc9bfdf6e8a7c1322c.zip
Add english hunspell dictionnaries
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/en-hunspell/Makefile59
-rw-r--r--textproc/en-hunspell/distinfo6
-rw-r--r--textproc/en-hunspell/pkg-descr4
4 files changed, 70 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 920f87c82e8c..80eb68446b13 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -144,6 +144,7 @@
SUBDIR += el-aspell
SUBDIR += emacs-wiki
SUBDIR += en-aspell
+ SUBDIR += en-hunspell
SUBDIR += enchant
SUBDIR += eo-aspell
SUBDIR += eqe
diff --git a/textproc/en-hunspell/Makefile b/textproc/en-hunspell/Makefile
new file mode 100644
index 000000000000..b82eabd89fb8
--- /dev/null
+++ b/textproc/en-hunspell/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: en-hunspell
+# Date created: 2011-07-20
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= en-hunspell
+PORTVERSION= 7.1
+CATEGORIES= textproc
+MASTER_SITES= SF/wordlist/Hunspell%20en_US/${PORTVERSION}-0/ \
+ SF/wordlist/Hunspell%20en_CA/${PORTVERSION}-0/:CA \
+ http://en-gb.pyxidium.co.uk/dictionary/:GB
+DISTFILES= hunspell-en_US-${PORTVERSION}-0${EXTRACT_SUFX} \
+ hunspell-en_CA-${PORTVERSION}-0${EXTRACT_SUFX}:CA \
+ en_GB.zip:GB
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Hunspell english dictionnaries
+
+USE_ZIP= yes
+NO_BUILD= yes
+
+PLIST_FILES= share/hunspell/en_GB.dic \
+ share/hunspell/en_GB.aff \
+ share/hunspell/en_CA.aff \
+ share/hunspell/en_CA.dic \
+ share/hunspell/en_US.aff \
+ share/hunspell/en_US.dic \
+
+GBALIASES= en_AG en_AU en_BS en_BW en_BZ en_DK en_GH en_HK en_IE en_IN en_JM \
+ en_NA en_NG en_NZ en_SG en_TT en_ZA en_ZW
+USALIASES= en_PH
+
+.for ALIAS in ${GBALIASES}
+PLIST_FILES+= share/hunspell/${ALIAS}.aff \
+ share/hunspell/${ALIAS}.dic
+.endfor
+.for ALIAS in ${USALIASES}
+PLIST_FILES+= share/hunspell/${ALIAS}.aff \
+ share/hunspell/${ALIAS}.dic
+.endfor
+
+PLIST_DIRS= share/hunspell
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/hunspell
+ @${INSTALL_DATA} ${WRKDIR}/*.dic ${WRKDIR}/*.aff ${PREFIX}/share/hunspell
+ @cd ${PREFIX}/share/hunspell; \
+ for alias in ${GBALIASES}; do \
+ ${LN} -s en_GB.aff $${alias}.aff ; \
+ ${LN} -s en_GB.dic $${alias}.dic ; \
+ done; \
+ for alias in ${USALIASES}; do \
+ ${LN} -s en_US.aff $${alias}.aff ; \
+ ${LN} -s en_US.dic $${alias}.dic ; \
+ done; \
+
+.include <bsd.port.mk>
diff --git a/textproc/en-hunspell/distinfo b/textproc/en-hunspell/distinfo
new file mode 100644
index 000000000000..42ee7884b933
--- /dev/null
+++ b/textproc/en-hunspell/distinfo
@@ -0,0 +1,6 @@
+SHA256 (hunspell-en_US-7.1-0.zip) = e1f341803f0aedb1a0d00ca1db988506fd6fe216758367e4bed66e2f2d22a198
+SIZE (hunspell-en_US-7.1-0.zip) = 192842
+SHA256 (hunspell-en_CA-7.1-0.zip) = 9229ffb96f6cdfd72dd03db4477c7416e9b90166498be2a5f487cc42e23f3223
+SIZE (hunspell-en_CA-7.1-0.zip) = 193289
+SHA256 (en_GB.zip) = 5869d8bd80eb2eb328ebe36b356348de4ae2acb1db6df39d1717d33f89f63728
+SIZE (en_GB.zip) = 250182
diff --git a/textproc/en-hunspell/pkg-descr b/textproc/en-hunspell/pkg-descr
new file mode 100644
index 000000000000..cf3be1f14b0f
--- /dev/null
+++ b/textproc/en-hunspell/pkg-descr
@@ -0,0 +1,4 @@
+Hunspell english dictionnaries
+
+WWW: http://wordlist.sourceforge.net/
+WWW: http://en-gb.pyxidium.co.uk/dictionary/