aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2013-06-28 08:02:47 +0800
committercy <cy@FreeBSD.org>2013-06-28 08:02:47 +0800
commite43113e26cc400504208c4a2c514153fa0c11185 (patch)
tree29c18022a5b667097e91efd8e7ea5446badd2c96
parent319c7fb3bb9f9b8a95b5c5ee0c6cd871c83833ab (diff)
downloadfreebsd-ports-gnome-e43113e26cc400504208c4a2c514153fa0c11185.tar.gz
freebsd-ports-gnome-e43113e26cc400504208c4a2c514153fa0c11185.tar.zst
freebsd-ports-gnome-e43113e26cc400504208c4a2c514153fa0c11185.zip
Add File::KeePass::Agent An application agent for working with
File::KeePass objects.
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-File-KeePass-Agent/Makefile28
-rw-r--r--security/p5-File-KeePass-Agent/distinfo2
-rw-r--r--security/p5-File-KeePass-Agent/pkg-descr3
-rw-r--r--security/p5-File-KeePass-Agent/pkg-plist10
5 files changed, 44 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index ce76d59242b3..5e924f169b13 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -545,6 +545,7 @@
SUBDIR += p5-Digest-Tiger
SUBDIR += p5-Digest-Whirlpool
SUBDIR += p5-File-KeePass
+ SUBDIR += p5-File-KeePass-Agent
SUBDIR += p5-File-Scan
SUBDIR += p5-File-Scan-ClamAV
SUBDIR += p5-Filter-CBC
diff --git a/security/p5-File-KeePass-Agent/Makefile b/security/p5-File-KeePass-Agent/Makefile
new file mode 100644
index 000000000000..9604266a48b2
--- /dev/null
+++ b/security/p5-File-KeePass-Agent/Makefile
@@ -0,0 +1,28 @@
+# Created by: Cy Schubert <cy@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= File-KeePass-Agent
+PORTVERSION= 2.01
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= cy@FreeBSD.org
+COMMENT= Application agent for working with File::KeePass objects
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-File-KeePass>=2.03:${PORTSDIR}/security/p5-File-KeePass \
+ p5-Crypt-Rijndael>=1.0:${PORTSDIR}/security/p5-Crypt-Rijndael \
+ p5-MIME-Base64>=1.0:${PORTSDIR}/converters/p5-MIME-Base64
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= fkp-agent.1
+MAN3= File::KeePass::Agent.3 \
+ File::KeePass::Agent::linux.3 \
+ File::KeePass::Agent::unix.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-File-KeePass-Agent/distinfo b/security/p5-File-KeePass-Agent/distinfo
new file mode 100644
index 000000000000..5e0fe08fb35e
--- /dev/null
+++ b/security/p5-File-KeePass-Agent/distinfo
@@ -0,0 +1,2 @@
+SHA256 (File-KeePass-Agent-2.01.tar.gz) = 3b20e67cd032b656bd9e15a776444bb7b3da39e851f32bb93c7244b62a7443bd
+SIZE (File-KeePass-Agent-2.01.tar.gz) = 16043
diff --git a/security/p5-File-KeePass-Agent/pkg-descr b/security/p5-File-KeePass-Agent/pkg-descr
new file mode 100644
index 000000000000..83d950d3560b
--- /dev/null
+++ b/security/p5-File-KeePass-Agent/pkg-descr
@@ -0,0 +1,3 @@
+File::KeePass::Agent - Application agent for working with File::KeePass objects
+
+WWW: http://search.cpan.org/dist/File-KeePass-Agent/
diff --git a/security/p5-File-KeePass-Agent/pkg-plist b/security/p5-File-KeePass-Agent/pkg-plist
new file mode 100644
index 000000000000..de517109270a
--- /dev/null
+++ b/security/p5-File-KeePass-Agent/pkg-plist
@@ -0,0 +1,10 @@
+bin/fkp-agent
+%%SITE_PERL%%/File/KeePass/Agent.pm
+%%SITE_PERL%%/File/KeePass/Agent/linux.pm
+%%SITE_PERL%%/File/KeePass/Agent/unix.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/KeePass/Agent/.packlist
+@dirrm %%SITE_PERL%%/File/KeePass/Agent
+@dirrm %%SITE_PERL%%/File/KeePass
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/KeePass/Agent
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File
+@dirrmtry %%SITE_PERL%%/File