aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-03-21 03:25:22 +0800
committermiwi <miwi@FreeBSD.org>2010-03-21 03:25:22 +0800
commite4528c7d9db37f1c501a4592bf22f1e89b431c94 (patch)
treeef9240ff1430be917e5dc1f62bdfde44126a6288
parent5fa233d7ab80ff985e2f1d983d26a7b0bad99abe (diff)
downloadfreebsd-ports-gnome-e4528c7d9db37f1c501a4592bf22f1e89b431c94.tar.gz
freebsd-ports-gnome-e4528c7d9db37f1c501a4592bf22f1e89b431c94.tar.zst
freebsd-ports-gnome-e4528c7d9db37f1c501a4592bf22f1e89b431c94.zip
Implements a simple Getopt::Std class for command line parsing, as well as a
Getopt::Long class for more advanced command line parsing. WWW: http://www.rubyforge.org/projects/shards PR: ports/144799 Submitted by: Alexey V. Degtyarev <alexey at renatasystems.org>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-getopt/Makefile20
-rw-r--r--devel/rubygem-getopt/distinfo3
-rw-r--r--devel/rubygem-getopt/pkg-descr4
4 files changed, 28 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8b8c9ed4cda2..7a6f0485ea48 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2894,6 +2894,7 @@
SUBDIR += rubygem-gdata
SUBDIR += rubygem-gem_plugin
SUBDIR += rubygem-georuby
+ SUBDIR += rubygem-getopt
SUBDIR += rubygem-git
SUBDIR += rubygem-grit
SUBDIR += rubygem-highline
diff --git a/devel/rubygem-getopt/Makefile b/devel/rubygem-getopt/Makefile
new file mode 100644
index 000000000000..210769d49bff
--- /dev/null
+++ b/devel/rubygem-getopt/Makefile
@@ -0,0 +1,20 @@
+# Ports collection makefile for: getopt
+# Date created: Tue 16 Mar 2010
+# Whom: Alexey V. Degtyarev <alexey@renatasystems.org>
+#
+# $FreeBSD$
+
+PORTNAME= getopt
+PORTVERSION= 1.4.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RF/shards
+
+MAINTAINER= alexey@renatasystems.org
+COMMENT= Command line parsing with Ruby
+
+USE_RUBY= yes
+USE_RAKE= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-getopt/distinfo b/devel/rubygem-getopt/distinfo
new file mode 100644
index 000000000000..362fd715776a
--- /dev/null
+++ b/devel/rubygem-getopt/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/getopt-1.4.0.gem) = db1359bb0344d009568a96aaeb359848
+SHA256 (rubygem/getopt-1.4.0.gem) = 308ee1bc4e7426dd50cac9c0c794298fabfca13a85717f82baffbce121d9f52f
+SIZE (rubygem/getopt-1.4.0.gem) = 14336
diff --git a/devel/rubygem-getopt/pkg-descr b/devel/rubygem-getopt/pkg-descr
new file mode 100644
index 000000000000..df2ffee7bf34
--- /dev/null
+++ b/devel/rubygem-getopt/pkg-descr
@@ -0,0 +1,4 @@
+Implements a simple Getopt::Std class for command line parsing, as well as a
+Getopt::Long class for more advanced command line parsing.
+
+WWW: http://www.rubyforge.org/projects/shards