aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2012-11-06 06:48:07 +0800
committerthierry <thierry@FreeBSD.org>2012-11-06 06:48:07 +0800
commite5815ca863b478c791e2cf0a861decc6b6b492ff (patch)
tree56ba8e93d52fff1f2d5f499d292d65acd57a7764
parent11827c3d1de4f19ac7b792d7ed08018a1cbcfff1 (diff)
downloadfreebsd-ports-gnome-e5815ca863b478c791e2cf0a861decc6b6b492ff.tar.gz
freebsd-ports-gnome-e5815ca863b478c791e2cf0a861decc6b6b492ff.tar.zst
freebsd-ports-gnome-e5815ca863b478c791e2cf0a861decc6b6b492ff.zip
Upgrade to 1.5.2.
Feature safe: yes
-rw-r--r--graphics/cimg/Makefile7
-rw-r--r--graphics/cimg/distinfo4
-rw-r--r--graphics/cimg/files/patch-examples::Makefile32
-rw-r--r--graphics/cimg/files/patch-examples_gmic.cpp20
-rw-r--r--graphics/cimg/pkg-plist43
5 files changed, 75 insertions, 31 deletions
diff --git a/graphics/cimg/Makefile b/graphics/cimg/Makefile
index e54c0fa0e4d7..f6f4e84fa74e 100644
--- a/graphics/cimg/Makefile
+++ b/graphics/cimg/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= cimg
-PORTVERSION= 1.4.9
-PORTREVISION= 3
+PORTVERSION= 1.5.2
PORTEPOCH= 3
CATEGORIES= graphics devel
MASTER_SITES= SF/${PORTNAME} \
@@ -71,7 +70,7 @@ RUN_DEPENDS+= medcon:${PORTSDIR}/graphics/xmedcon
LIB_DEPENDS+= avformat.1:${PORTSDIR}/multimedia/ffmpeg
. endif
-DOCBASE= CHANGES.txt README.txt
+DOCBASE= README.txt
PROGS= CImg_demo gmic use_jpeg_buffer
.else
NO_BUILD= yes
@@ -128,7 +127,7 @@ do-install:
${MKDIR} ${EXAMPLESDIR}
${CP} -R ${WRKSRC}/examples/* ${EXAMPLESDIR}
@(cd ${EXAMPLESDIR} && ${GMAKE} clean)
- @${RM} ${EXAMPLESDIR}/Makefile.orig
+ @${RM} ${EXAMPLESDIR}/*.orig
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
${FIND} ${DOCSDIR} ${EXAMPLESDIR} -type f -exec ${CHMOD} ${SHAREMODE} {} \;
.endif
diff --git a/graphics/cimg/distinfo b/graphics/cimg/distinfo
index 19c17379b866..6b8d4fa529f4 100644
--- a/graphics/cimg/distinfo
+++ b/graphics/cimg/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cimg-1.4.9/CImg-1.4.9.zip) = f2ad5027f3c9030462aceed0f2d1d4be27eb11ec419745a6ec17510361ad32cf
-SIZE (cimg-1.4.9/CImg-1.4.9.zip) = 10447796
+SHA256 (cimg-1.5.2/CImg-1.5.2.zip) = 4c6939d7d3c57752bb347362eca26eafb497571246d0d4c5f22d49721f8bc63f
+SIZE (cimg-1.5.2/CImg-1.5.2.zip) = 12824193
diff --git a/graphics/cimg/files/patch-examples::Makefile b/graphics/cimg/files/patch-examples::Makefile
index 85ee34697378..d38bd8abea3d 100644
--- a/graphics/cimg/files/patch-examples::Makefile
+++ b/graphics/cimg/files/patch-examples::Makefile
@@ -1,17 +1,17 @@
---- examples/Makefile.orig 2011-06-09 13:32:15.000000000 +0200
-+++ examples/Makefile 2011-06-27 22:17:58.000000000 +0200
+--- examples/Makefile.orig 2012-10-15 17:30:59.000000000 +0200
++++ examples/Makefile 2012-11-04 22:25:42.000000000 +0100
@@ -85,8 +85,8 @@
# Set correct variables and paths
#---------------------------------
- CIMG_VERSION = 1.4.9
+ CIMG_VERSION = 1.5.2
-X11PATH = /usr/X11R6
-CC = g++
+#X11PATH = /usr/X11R6
+CC = $(CXX)
- CCVER = `$(CC) -v 2>&1 | tail -n 1`
EXEPFX =
-
-@@ -120,7 +120,7 @@
+ CCVER = $(CC)
+ ifeq ($(CC),g++)
+@@ -126,7 +126,7 @@
ifeq ($(CC),icc)
CIMG_OPT_CFLAGS = -O3 -ipo -no-prec-div
else
@@ -20,7 +20,7 @@
endif
# Flags to enable OpenMP support.
-@@ -131,7 +131,7 @@
+@@ -137,7 +137,7 @@
endif
# Flags to enable OpenCV support.
@@ -29,7 +29,7 @@
CIMG_OPENCV_LDFLAGS = -lcv -lhighgui
# Flags used to disable display capablities of CImg
-@@ -141,7 +141,7 @@
+@@ -147,7 +147,7 @@
# (X11 is used by CImg to handle display windows)
# !!! For 64bits systems : replace -L$(X11PATH)/lib by -L$(X11PATH)/lib64 !!!
CIMG_X11_CFLAGS = -I$(X11PATH)/include
@@ -37,8 +37,8 @@
+CIMG_X11_LDFLAGS = -L$(X11PATH)/lib -lX11 $(PTHREAD_LIBS)
# Flags to enable fast image display, using the XSHM library (when using X11).
- # !!! Seems to randomly crash when used on MacOSX, so do not use it on MacOSX !!!
-@@ -180,12 +180,12 @@
+ # !!! Seems to randomly crash when used on MacOSX and 64bits systems, so use it only when necessary !!!
+@@ -186,12 +186,12 @@
# Flags to enable native support for EXR image files, using the OpenEXR library.
# ( http://www.openexr.com/ )
@@ -53,7 +53,7 @@
CIMG_FFMPEG_LDFLAGS = -lavcodec -lavformat -lswscale
# Flags to enable native support for compressed .cimgz files, using the Zlib library.
-@@ -195,8 +195,8 @@
+@@ -201,8 +201,8 @@
# Flags to enable native support of most classical image file formats, using the Magick++ library.
# ( http://www.imagemagick.org/Magick++/ )
@@ -64,7 +64,7 @@
# Flags to enable faster Discrete Fourier Transform computation, using the FFTW3 library
# ( http://www.fftw.org/ )
-@@ -209,14 +209,17 @@
+@@ -215,14 +215,17 @@
# Flags to enable the use of LAPACK routines for matrix computation
# ( http://www.netlib.org/lapack/ )
@@ -85,7 +85,7 @@
# Flags to compile on Sun Solaris
CIMG_SOLARIS_LDFLAGS = -R$(X11PATH)/lib -lrt -lnsl -lsocket
-@@ -250,6 +253,9 @@
+@@ -256,6 +259,9 @@
@echo " > mlinux : Linus/BSD target, no display, minimal features, optimizations enabled."
@echo " > Mlinux : Linux/BSD target, X11 display, maximal features, optimizations enabled."
@echo
@@ -95,7 +95,7 @@
@echo " > solaris : Sun Solaris target, X11 display, optimizations disabled."
@echo " > dsolaris : Sun Solaris target, X11 display, debug mode."
@echo " > osolaris : Sun Solaris target, X11 display, optimizations enabled."
-@@ -293,7 +299,7 @@
+@@ -292,7 +298,7 @@
$(CC) -o gmic_gimp.o -c gmic.cpp -Dcimg_build -Dgmic_gimp -Dgmic_minimal $(CIMG_OPT_CFLAGS) $(CIMG_FFTW3_CFLAGS) $(CIMG_PNG_CFLAGS)
gmic_gimp: gmic_gimp.o gmic_gimp.cpp
@@ -104,7 +104,7 @@
# Specific targets for 'gmic'.
gmic_def: gmic_def.gmic
-@@ -333,7 +339,7 @@
+@@ -326,7 +332,7 @@
gmic_uint.o gmic_int.o gmic_float.o gmic_double.o $(CFLAGS) $(LDFLAGS) $(CONF_CFLAGS) $(CONF_LDFLAGS)
gmic_minimal:
@@ -113,7 +113,7 @@
ifeq ($(STRIP_EXE),true)
strip $(EXEPFX)gmic
-@@ -421,6 +427,56 @@
+@@ -414,6 +420,56 @@
"STRIP_EXE=true" \
all $(CIMG_EXTRA_FILES)
diff --git a/graphics/cimg/files/patch-examples_gmic.cpp b/graphics/cimg/files/patch-examples_gmic.cpp
new file mode 100644
index 000000000000..de18683e1088
--- /dev/null
+++ b/graphics/cimg/files/patch-examples_gmic.cpp
@@ -0,0 +1,20 @@
+--- examples/gmic.cpp.orig 2012-10-15 17:31:08.000000000 +0200
++++ examples/gmic.cpp 2012-11-05 18:29:29.000000000 +0100
+@@ -10776,7 +10776,7 @@
+ *const command = is_help1?is_help1:is_help2?is_help2:is_help3?is_help3:is_help4;
+ if (!std::strcmp(is_help,command)) gmic("-v - -help",images,images_names); // Global help.
+ else { // Help for a specified command.
+- std::snprintf(command_line,sizeof(command_line),"-v - -help \"%s\",1",command);
++ snprintf(command_line,sizeof(command_line),"-v - -help \"%s\",1",command);
+ gmic(command_line,images,images_names);
+ }
+ std::exit(0);
+@@ -10796,7 +10796,7 @@
+ e.command());
+ images.assign(); images_names.assign();
+ CImg<unsigned char>(data_gmic_def,1,size_data_gmic_def,1,1).move_to(images);
+- std::snprintf(command_line,sizeof(command_line),"-v - -help \"%s\",0",e.command());
++ snprintf(command_line,sizeof(command_line),"-v - -help \"%s\",0",e.command());
+ gmic(command_line,images,images_names);
+ } else { std::fprintf(cimg::output(),"\n\n"); std::fflush(cimg::output()); }
+ return -1;
diff --git a/graphics/cimg/pkg-plist b/graphics/cimg/pkg-plist
index b498caaa6924..ee48e4d60525 100644
--- a/graphics/cimg/pkg-plist
+++ b/graphics/cimg/pkg-plist
@@ -2,11 +2,10 @@
%%PORTDOCS%%bin/gmic
%%PORTDOCS%%bin/use_jpeg_buffer
include/CImg.h
-%%PORTDOCS%%%%DOCSDIR%%/CHANGES.txt
%%PORTDOCS%%%%DOCSDIR%%/CImg.doxygen
%%PORTDOCS%%%%DOCSDIR%%/CImg_documentation.h
+%%PORTDOCS%%%%DOCSDIR%%/CImg_reference.pdf
%%PORTDOCS%%%%DOCSDIR%%/README.txt
-%%PORTDOCS%%%%DOCSDIR%%/chat.shtml
%%PORTDOCS%%%%DOCSDIR%%/download.shtml
%%PORTDOCS%%%%DOCSDIR%%/favicon.ico
%%PORTDOCS%%%%DOCSDIR%%/favicon.png
@@ -14,6 +13,7 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/header.html
%%PORTDOCS%%%%DOCSDIR%%/header_reference.html
%%PORTDOCS%%%%DOCSDIR%%/img/CImgLogo.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/CImgLogo2.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/CImg_flyer.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/curve_editor.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/item_authors.jpg
@@ -78,6 +78,14 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/img/postcard3.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/postcard30.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/postcard31.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard32.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard33.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard34.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard35.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard36.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard37.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard38.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard39.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/postcard4.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/postcard5.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/postcard6.jpg
@@ -87,6 +95,14 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/img/project-support.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_atan2.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_box3d.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_colormap_cool.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_colormap_cube.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_colormap_default.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_colormap_flag.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_colormap_hot.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_colormap_hsv.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_colormap_jet.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_colormap_lines.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_cone3d.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_constructor1.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/reference/ref_constructor2.jpg
@@ -208,6 +224,7 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/reference/closed.png
%%PORTDOCS%%%%DOCSDIR%%/reference/doxygen.css
%%PORTDOCS%%%%DOCSDIR%%/reference/doxygen.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/dynsections.js
%%PORTDOCS%%%%DOCSDIR%%/reference/form_0.png
%%PORTDOCS%%%%DOCSDIR%%/reference/form_1.png
%%PORTDOCS%%%%DOCSDIR%%/reference/form_10.png
@@ -228,7 +245,14 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/reference/form_24.png
%%PORTDOCS%%%%DOCSDIR%%/reference/form_25.png
%%PORTDOCS%%%%DOCSDIR%%/reference/form_26.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/form_27.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/form_28.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/form_29.png
%%PORTDOCS%%%%DOCSDIR%%/reference/form_3.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/form_30.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/form_31.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/form_32.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/form_33.png
%%PORTDOCS%%%%DOCSDIR%%/reference/form_4.png
%%PORTDOCS%%%%DOCSDIR%%/reference/form_5.png
%%PORTDOCS%%%%DOCSDIR%%/reference/form_6.png
@@ -298,12 +322,8 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/reference/group__cimg__options.html
%%PORTDOCS%%%%DOCSDIR%%/reference/group__cimg__overview.html
%%PORTDOCS%%%%DOCSDIR%%/reference/group__cimg__storage.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/group__cimg__structure.html
%%PORTDOCS%%%%DOCSDIR%%/reference/group__cimg__tutorial.html
%%PORTDOCS%%%%DOCSDIR%%/reference/group__cimg__visual2005.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/group__cimgdisplay__structure.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/group__cimgexception__structure.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/group__cimglist__structure.html
%%PORTDOCS%%%%DOCSDIR%%/reference/hierarchy.html
%%PORTDOCS%%%%DOCSDIR%%/reference/index.html
%%PORTDOCS%%%%DOCSDIR%%/reference/modules.html
@@ -316,8 +336,15 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/reference/nav_f.png
%%PORTDOCS%%%%DOCSDIR%%/reference/nav_h.png
%%PORTDOCS%%%%DOCSDIR%%/reference/open.png
-%%PORTDOCS%%%%DOCSDIR%%/reference/ref_atan2.jpg
%%PORTDOCS%%%%DOCSDIR%%/reference/ref_box3d.jpg
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_colormap_cool.jpg
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_colormap_cube.jpg
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_colormap_default.jpg
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_colormap_flag.jpg
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_colormap_hot.jpg
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_colormap_hsv.jpg
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_colormap_jet.jpg
+%%PORTDOCS%%%%DOCSDIR%%/reference/ref_colormap_lines.jpg
%%PORTDOCS%%%%DOCSDIR%%/reference/ref_cone3d.jpg
%%PORTDOCS%%%%DOCSDIR%%/reference/ref_constructor1.jpg
%%PORTDOCS%%%%DOCSDIR%%/reference/ref_constructor2.jpg
@@ -332,7 +359,6 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/reference/ref_isoline3d.jpg
%%PORTDOCS%%%%DOCSDIR%%/reference/ref_isosurface3d.jpg
%%PORTDOCS%%%%DOCSDIR%%/reference/ref_map.jpg
-%%PORTDOCS%%%%DOCSDIR%%/reference/ref_mul.jpg
%%PORTDOCS%%%%DOCSDIR%%/reference/ref_noise.jpg
%%PORTDOCS%%%%DOCSDIR%%/reference/ref_norm.jpg
%%PORTDOCS%%%%DOCSDIR%%/reference/ref_normalize.jpg
@@ -367,7 +393,6 @@ include/CImg.h
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/CImg_demo.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/captcha.cpp
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/check_all_functions.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/curve_editor2d.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dtmri_view3d.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/edge_explorer2d.cpp