aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-07-30 10:13:27 +0800
committerdanfe <danfe@FreeBSD.org>2013-07-30 10:13:27 +0800
commite65377b54dc52c17cf56a7cf5f7ce74fdfb8759c (patch)
tree2b1a6fe0cf33d390f39cc72662727cce090f849e
parent1c20a3aaae789295e34222f52cd7ae07d6949b47 (diff)
downloadfreebsd-ports-gnome-e65377b54dc52c17cf56a7cf5f7ce74fdfb8759c.tar.gz
freebsd-ports-gnome-e65377b54dc52c17cf56a7cf5f7ce74fdfb8759c.tar.zst
freebsd-ports-gnome-e65377b54dc52c17cf56a7cf5f7ce74fdfb8759c.zip
- Fix parallel builds and remove ugly MAKE_JOBS_UNSAFE knob
- Improve formatting, e.g. wrap overly long lines, fix whitespace - NOPORTEXAMPLES -> PORT_OPTIONS:MEXAMPLES (port is already OptionsNG) - Synchronize port description with official website - Use more standard double (even) space padding in pkg-message.in Approved by: lme (maintainer)
-rw-r--r--net-mgmt/icinga/Makefile43
-rw-r--r--net-mgmt/icinga/files/pkg-message.in28
-rw-r--r--net-mgmt/icinga/pkg-descr17
3 files changed, 52 insertions, 36 deletions
diff --git a/net-mgmt/icinga/Makefile b/net-mgmt/icinga/Makefile
index 6b7eb2517c50..4ddd9a834659 100644
--- a/net-mgmt/icinga/Makefile
+++ b/net-mgmt/icinga/Makefile
@@ -1,4 +1,4 @@
-# Created by: chinsan
+# Created by: Chin-San Huang <chinsan@FreeBSD.org>
# $FreeBSD$
PORTNAME= icinga
@@ -19,8 +19,6 @@ USE_PERL5_BUILD= yes
USE_AUTOTOOLS= autoconf libltdl
USE_RC_SUBR= icinga
-MAKE_JOBS_UNSAFE=yes
-
GNU_CONFIGURE= yes
ICINGAUSER?= icinga
@@ -58,7 +56,8 @@ CONFIGURE_ARGS= --with-command-user=${ICINGAUSER} \
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" \
PERL=${PERL}
-INSTALL_TARGET= install install-commandmode install-config install-eventhandlers
+INSTALL_TARGET= install install-commandmode install-config \
+ install-eventhandlers
PLIST_SUB= ICINGADIR=${ICINGADIR} \
ICINGALOGDIR=${ICINGALOGDIR} \
@@ -79,11 +78,11 @@ SUB_FILES= pkg-install \
SUB_LIST= PREFIX=${PREFIX} \
${PLIST_SUB}
-OPTIONS_DEFINE= EMBEDDED_PERL NANOSLEEP UNHANDLED_HACK IDOUTILS APACHE
+OPTIONS_DEFINE= EMBEDDED_PERL NANOSLEEP UNHANDLED_HACK IDOUTILS APACHE EXAMPLES
OPTIONS_DEFAULT= EMBEDDED_PERL IDOUTILS
EMBEDDED_PERL_DESC= Enable embedded Perl
-NANOSLEEP_DESC= Use nanosleep in event timing
+NANOSLEEP_DESC= Use nanosleep(2) in event timing
UNHANDLED_HACK_DESC= Display passive checks in unhandled queries
IDOUTILS_DESC= Enable Icinga Data Objects support
APACHE_DESC= Depend on Apache and install webconfig
@@ -127,30 +126,42 @@ PLIST_SUB+= APACHE="@comment "
.endif
post-patch:
- @${REINPLACE_CMD} -e 's#/bin/ping#/sbin/ping#' ${WRKSRC}/sample-config/cgi.cfg.in
- @${REINPLACE_CMD} -e 's#Linux#FreeBSD#' ${WRKSRC}/sample-config/icinga.cfg.in
- @${REINPLACE_CMD} -e 's#775#755#g; s#664#644#g' ${WRKSRC}/html/Makefile.in
+ @${REINPLACE_CMD} -e 's#/bin/ping#/sbin/ping#' \
+ ${WRKSRC}/sample-config/cgi.cfg.in
+ @${REINPLACE_CMD} -e 's#Linux#${OPSYS}#' \
+ ${WRKSRC}/sample-config/icinga.cfg.in
+ @${REINPLACE_CMD} -e 's#775#755#g; s#664#644#g' \
+ ${WRKSRC}/html/Makefile.in
.if ${PORT_OPTIONS:MUNHANDLED_HACK}
@${REINPLACE_CMD} -e 's#;serviceprops=42\&#;serviceprops=10\&#g' \
- -e 's#;hostprops=42\"#;hostprops=10\"#g' ${WRKSRC}/html/menu.html.in
+ -e 's#;hostprops=42\"#;hostprops=10\"#g' \
+ ${WRKSRC}/html/menu.html.in
.endif
- @${FIND} ${WRKSRC} -name '*.orig' -delete
+# Use correct make(1) syntax to unbreak parallel builds
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} \
+ -E 's#cd (.+) && (make|\$$\(MAKE\))#$$(MAKE) -C \1#'
pre-su-install:
@${SH} ${PKGINSTALL} ${DISTNAME} PRE-INSTALL
post-install:
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${EXAMPLESDIR}/idoutils/
${MKDIR} ${EXAMPLESDIR}/idoutils/config/
${MKDIR} ${EXAMPLESDIR}/idoutils/db
- cd ${WRKSRC}/module/idoutils/config && ${COPYTREE_SHARE} . ${EXAMPLESDIR}/idoutils/config
- cd ${WRKSRC}/module/idoutils/db && ${COPYTREE_SHARE} . ${EXAMPLESDIR}/idoutils/db
+ cd ${WRKSRC}/module/idoutils/config && ${COPYTREE_SHARE} . \
+ ${EXAMPLESDIR}/idoutils/config
+ cd ${WRKSRC}/module/idoutils/db && ${COPYTREE_SHARE} . \
+ ${EXAMPLESDIR}/idoutils/db
.endif
- @${CHMOD} 775 ${ICINGADIR} ${ICINGALOGDIR}/archives ${ICINGADIR}/checkresults ${ICINGADIR}/rw
+ @${CHMOD} 775 ${ICINGADIR} ${ICINGALOGDIR}/archives \
+ ${ICINGADIR}/checkresults ${ICINGADIR}/rw
@${CHMOD} g+s ${ICINGADIR}/rw
- @${CHOWN} ${ICINGAUSER}:${ICINGAGROUP} ${ICINGADIR} ${ICINGALOGDIR}/archives ${ICINGADIR}/checkresults
+ @${CHOWN} ${ICINGAUSER}:${ICINGAGROUP} ${ICINGADIR} \
+ ${ICINGALOGDIR}/archives ${ICINGADIR}/checkresults
@${CHOWN} ${ICINGAUSER}:${WWWGRP} ${ICINGADIR}/rw
+ @${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
.include <bsd.port.mk>
diff --git a/net-mgmt/icinga/files/pkg-message.in b/net-mgmt/icinga/files/pkg-message.in
index 5a56bd870954..209fc54391f5 100644
--- a/net-mgmt/icinga/files/pkg-message.in
+++ b/net-mgmt/icinga/files/pkg-message.in
@@ -1,22 +1,22 @@
*************************************************************************
- Enable Icinga in /etc/rc.conf with the following line:
+ Enable Icinga in /etc/rc.conf with the following line:
- icinga_enable="YES"
+ icinga_enable="YES"
- Configuration templates are available in %%PREFIX%%/etc/icinga as
- *.cfg-sample files. Copy them to *.cfg files where required and
- edit to suit your needs. Documentation is available in HTML form
- in %%PREFIX%%/%%ICINGAWWWDIR%%/docs/.
+ Configuration templates are available in %%PREFIX%%/etc/icinga as
+ *.cfg-sample files. Copy them to *.cfg files where required and
+ edit to suit your needs. Documentation is available in HTML form
+ in %%PREFIX%%/%%ICINGAWWWDIR%%/docs/.
- If you don't already have a web server running, you will need to
- install and configure one to finish off your Icinga installation.
- If you selected APACHE in Icinga's OPTION screen, the configuration
- is already installed as %%LOCALBASE%%/etc/apache22/extra/icinga.conf
- and you only need to source the configuration file in Apache's config.
+ If you don't already have a web server running, you will need to
+ install and configure one to finish off your Icinga installation.
+ If you selected APACHE in Icinga's OPTION screen, the configuration
+ is already installed as %%LOCALBASE%%/etc/apache22/extra/icinga.conf
+ and you only need to source the configuration file in Apache's config.
- If you like to use database backend with IDOutils the SQL scripts to
- setup the database have been installed in
- %%PREFIX%%/%%EXAMPLESDIR%%/idoutils/db/.
+ If you like to use database backend with IDOutils the SQL scripts to
+ setup the database have been installed in
+ %%PREFIX%%/%%EXAMPLESDIR%%/idoutils/db/.
*************************************************************************
diff --git a/net-mgmt/icinga/pkg-descr b/net-mgmt/icinga/pkg-descr
index ab183d52d580..51b18138caa3 100644
--- a/net-mgmt/icinga/pkg-descr
+++ b/net-mgmt/icinga/pkg-descr
@@ -1,8 +1,13 @@
-Icinga is an enterprise grade open source monitoring system which keeps watch
-over networks and any conceivable network resource, notifies the user of
-errors and recoveries and generates performance data for reporting. Scalable
-and extensible, Icinga can monitor complex, large environments across
-dispersed locations.
-Icinga takes open source monitoring to the next level.
+Icinga is an enterprise grade open source monitoring system which keeps
+watch over networks and any conceivable network resource, notifies the user
+of errors and recoveries and generates performance data for reporting.
+Scalable and extensible, Icinga can monitor complex, large environments
+across dispersed locations.
+
+Icinga is a fork of Nagios and is backward compatible. That said, Nagios
+configurations, plugins, and addons can all be used with Icinga. Though
+Icinga retains all the existing features of its predecessor, it builds on
+them to add many long awaited patches and features requested by the user
+community.
WWW: http://www.icinga.org/