aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-03-21 22:08:49 +0800
committerpav <pav@FreeBSD.org>2005-03-21 22:08:49 +0800
commite69172b632d5d7abbdb35baef5925a3a5e8d35ed (patch)
tree2030a085595c2c41a162fdd80887545d831a29e9
parent9d21fa478a44f29d13cf71158d20639003dced23 (diff)
downloadfreebsd-ports-gnome-e69172b632d5d7abbdb35baef5925a3a5e8d35ed.tar.gz
freebsd-ports-gnome-e69172b632d5d7abbdb35baef5925a3a5e8d35ed.tar.zst
freebsd-ports-gnome-e69172b632d5d7abbdb35baef5925a3a5e8d35ed.zip
- Add new knob to define default server collation
Requested by: ale (maintainer)
-rw-r--r--databases/mysql50-server/Makefile4
-rw-r--r--databases/mysql51-server/Makefile4
-rw-r--r--databases/mysql54-server/Makefile4
-rw-r--r--databases/mysql55-server/Makefile4
-rw-r--r--databases/mysql60-server/Makefile4
-rw-r--r--databases/percona55-server/Makefile4
6 files changed, 24 insertions, 0 deletions
diff --git a/databases/mysql50-server/Makefile b/databases/mysql50-server/Makefile
index 8a2e14dfae08..a3d67959066a 100644
--- a/databases/mysql50-server/Makefile
+++ b/databases/mysql50-server/Makefile
@@ -62,6 +62,9 @@ CONFIGURE_ARGS+=--without-innodb
.if defined(WITH_NDB)
CONFIGURE_ARGS+=--with-ndbcluster
.endif
+.if defined(WITH_COLLATION) && ${WITH_COLLATION} != ""
+CONFIGURE_ARGS+=--with-collation=${WITH_COLLATION}
+.endif
.include <bsd.port.pre.mk>
@@ -131,6 +134,7 @@ pre-fetch:
@${ECHO} ""
@${ECHO} " WITH_CHARSET=charset Define the primary built-in charset (latin1)."
@${ECHO} " WITH_XCHARSET=list Define other built-in charsets (may be 'all')."
+ @${ECHO} " WITH_COLLATION=collate Define default collation (latin1_swedish_ci)."
@${ECHO} " WITH_OPENSSL=yes Enable secure connections."
@${ECHO} " DB_DIR=directory Set alternate directory for database files"
@${ECHO} " (default is /var/db/mysql)."
diff --git a/databases/mysql51-server/Makefile b/databases/mysql51-server/Makefile
index 8a2e14dfae08..a3d67959066a 100644
--- a/databases/mysql51-server/Makefile
+++ b/databases/mysql51-server/Makefile
@@ -62,6 +62,9 @@ CONFIGURE_ARGS+=--without-innodb
.if defined(WITH_NDB)
CONFIGURE_ARGS+=--with-ndbcluster
.endif
+.if defined(WITH_COLLATION) && ${WITH_COLLATION} != ""
+CONFIGURE_ARGS+=--with-collation=${WITH_COLLATION}
+.endif
.include <bsd.port.pre.mk>
@@ -131,6 +134,7 @@ pre-fetch:
@${ECHO} ""
@${ECHO} " WITH_CHARSET=charset Define the primary built-in charset (latin1)."
@${ECHO} " WITH_XCHARSET=list Define other built-in charsets (may be 'all')."
+ @${ECHO} " WITH_COLLATION=collate Define default collation (latin1_swedish_ci)."
@${ECHO} " WITH_OPENSSL=yes Enable secure connections."
@${ECHO} " DB_DIR=directory Set alternate directory for database files"
@${ECHO} " (default is /var/db/mysql)."
diff --git a/databases/mysql54-server/Makefile b/databases/mysql54-server/Makefile
index 8a2e14dfae08..a3d67959066a 100644
--- a/databases/mysql54-server/Makefile
+++ b/databases/mysql54-server/Makefile
@@ -62,6 +62,9 @@ CONFIGURE_ARGS+=--without-innodb
.if defined(WITH_NDB)
CONFIGURE_ARGS+=--with-ndbcluster
.endif
+.if defined(WITH_COLLATION) && ${WITH_COLLATION} != ""
+CONFIGURE_ARGS+=--with-collation=${WITH_COLLATION}
+.endif
.include <bsd.port.pre.mk>
@@ -131,6 +134,7 @@ pre-fetch:
@${ECHO} ""
@${ECHO} " WITH_CHARSET=charset Define the primary built-in charset (latin1)."
@${ECHO} " WITH_XCHARSET=list Define other built-in charsets (may be 'all')."
+ @${ECHO} " WITH_COLLATION=collate Define default collation (latin1_swedish_ci)."
@${ECHO} " WITH_OPENSSL=yes Enable secure connections."
@${ECHO} " DB_DIR=directory Set alternate directory for database files"
@${ECHO} " (default is /var/db/mysql)."
diff --git a/databases/mysql55-server/Makefile b/databases/mysql55-server/Makefile
index 8a2e14dfae08..a3d67959066a 100644
--- a/databases/mysql55-server/Makefile
+++ b/databases/mysql55-server/Makefile
@@ -62,6 +62,9 @@ CONFIGURE_ARGS+=--without-innodb
.if defined(WITH_NDB)
CONFIGURE_ARGS+=--with-ndbcluster
.endif
+.if defined(WITH_COLLATION) && ${WITH_COLLATION} != ""
+CONFIGURE_ARGS+=--with-collation=${WITH_COLLATION}
+.endif
.include <bsd.port.pre.mk>
@@ -131,6 +134,7 @@ pre-fetch:
@${ECHO} ""
@${ECHO} " WITH_CHARSET=charset Define the primary built-in charset (latin1)."
@${ECHO} " WITH_XCHARSET=list Define other built-in charsets (may be 'all')."
+ @${ECHO} " WITH_COLLATION=collate Define default collation (latin1_swedish_ci)."
@${ECHO} " WITH_OPENSSL=yes Enable secure connections."
@${ECHO} " DB_DIR=directory Set alternate directory for database files"
@${ECHO} " (default is /var/db/mysql)."
diff --git a/databases/mysql60-server/Makefile b/databases/mysql60-server/Makefile
index 8a2e14dfae08..a3d67959066a 100644
--- a/databases/mysql60-server/Makefile
+++ b/databases/mysql60-server/Makefile
@@ -62,6 +62,9 @@ CONFIGURE_ARGS+=--without-innodb
.if defined(WITH_NDB)
CONFIGURE_ARGS+=--with-ndbcluster
.endif
+.if defined(WITH_COLLATION) && ${WITH_COLLATION} != ""
+CONFIGURE_ARGS+=--with-collation=${WITH_COLLATION}
+.endif
.include <bsd.port.pre.mk>
@@ -131,6 +134,7 @@ pre-fetch:
@${ECHO} ""
@${ECHO} " WITH_CHARSET=charset Define the primary built-in charset (latin1)."
@${ECHO} " WITH_XCHARSET=list Define other built-in charsets (may be 'all')."
+ @${ECHO} " WITH_COLLATION=collate Define default collation (latin1_swedish_ci)."
@${ECHO} " WITH_OPENSSL=yes Enable secure connections."
@${ECHO} " DB_DIR=directory Set alternate directory for database files"
@${ECHO} " (default is /var/db/mysql)."
diff --git a/databases/percona55-server/Makefile b/databases/percona55-server/Makefile
index 8a2e14dfae08..a3d67959066a 100644
--- a/databases/percona55-server/Makefile
+++ b/databases/percona55-server/Makefile
@@ -62,6 +62,9 @@ CONFIGURE_ARGS+=--without-innodb
.if defined(WITH_NDB)
CONFIGURE_ARGS+=--with-ndbcluster
.endif
+.if defined(WITH_COLLATION) && ${WITH_COLLATION} != ""
+CONFIGURE_ARGS+=--with-collation=${WITH_COLLATION}
+.endif
.include <bsd.port.pre.mk>
@@ -131,6 +134,7 @@ pre-fetch:
@${ECHO} ""
@${ECHO} " WITH_CHARSET=charset Define the primary built-in charset (latin1)."
@${ECHO} " WITH_XCHARSET=list Define other built-in charsets (may be 'all')."
+ @${ECHO} " WITH_COLLATION=collate Define default collation (latin1_swedish_ci)."
@${ECHO} " WITH_OPENSSL=yes Enable secure connections."
@${ECHO} " DB_DIR=directory Set alternate directory for database files"
@${ECHO} " (default is /var/db/mysql)."